Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Dave__Rakhal
Beginner
40 Views

Intel Modular Server / Compute module boots with drive assigned to another

We have 2 MFSYS25 Chassis. One populated with MFS500SI and one populated with MFS5520VI. They are working fine since many years.

After IMS end of life we purchased 2 additional chassis and some MFS5000SI compute module (second hand from two different sellers on ebay),

We are trying to duplicate the running setup as a backup.

We fired up compute Module 1 and installed an OS using virtual drive 'Linux1'. That worked fine. But then we ran into problems for the second install. If compute module 2 is booted with compute module 1 turned off, it boots correctly. If however, compute module 1 is already booted with 'Linux1' assigned to it, and then we try to boot compute Module 2 to which is assigned virtual drive 'Linux2'; then, instead of booting as 'Linux2', it comes up as 'Linux1' and the file system on compute module 1 (to which virtual drive Linux1 is assigned)  becomes read only.

The console of compute module 1 shows messages like:

sd 1:0:0:0: rejecting I/O to offline device

We then concluded that perhaps the second hand chassis we purchased was bad. 

So we tried using the chassis purchased from another seller and the issue was the same.

Also because we had 5 compute modules, we swapped the first 2 with 2 others and the problem was reproduced.

[All 5 compute modules have manufacture dates in Oct 2007].

If someone has any insight on what is going on here, it will be much appreciated.

(Please note that there is only 1 SCM installed so there is multipath complication)

Thanks

0 Kudos
0 Replies
Reply