Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
8 Views

Login issues with Intel XDK version 1826

Hello,

My name is Bhuvnesh Kumar and I am new to using Intel XDK.

I have been asked by my boss to update an app that was built using Intel XDK in 2014/15.

I tried to use the latest version of Intel XDK but I have had some issues to get it to work as some of the features like xdk base etc are no longer being supported by the new version of xdk.

I was able to find the intel xdk version 1826, which was used t build the app, but am having issues logging into the software. As soon as I put my login info, it goes back to the login page instead of logging me in, which as to what I read on the forums could be because of some account migration done by intel sometime last year.

I was hoping to get access on my account so that I can use this old version, and if you could help me get to this configuration.

Here’s the technology stack information that I have been given:

Intel XDK version 1826
AngularJS v1.2.25
Ionic v1.0.0-beta.6
React v0.10.0
(all the individual library files can be found in the www/lib/js folder)

These files need to be installed via npm install (ie: files listed in package.json):
"dependencies": {
"npm-install": "^0.0.1"
},
"devDependencies": {
"gulp": "^3.8.11",
"gulp-concat": "^2.5.2",
"gulp-jshint": "^1.10.0",
"gulp-less": "^3.0.2",
"gulp-notify": "^2.2.0",
"gulp-protractor-qa": "^0.1.17",
"gulp-rename": "^1.2.2",
"gulp-sourcemaps": "^1.5.1",
"gulp-watch": "^4.2.4"
}

Thank you
Bhuvnesh Kumar

Tags (2)
0 Kudos
5 Replies
Highlighted
8 Views

Bhuvnesh -- you cannot login with that version of the XDK, it will not work. Please upgrade to 3522 and login with that version. The app sources will not change, but the project file will. If you have trouble migrating please post on this thread.

0 Kudos
Highlighted
Beginner
8 Views

I tried using build 1826 initially but as I wasn't able to login and do stuff, I Uninstalled it and then installed the latest version. Now when I try to open the project, it first asks me to remove a plug in called Cordova battery status and then gives me the prompt where it tells me xdk base xdk music player etc apps are not supported and suggests me to either use directory or project files . After selecting either of the two (I have done it several times now) I just get to a place where I can see the project files but when I go to simulate the app, all I get is a device with the background and nothing else . I have attached screenshots of the prompts that I encountered. I have tried this several times with different settings too and done it on mac as well as a pc. I would really appreciate if someone could help me migrate the code to the new xdk version so that I can at least compile it and start making changes to it. Thank you Bhuvnesh
0 Kudos
Highlighted
8 Views

Bhuvnesh -- I sent you a private message.

0 Kudos
Highlighted
8 Views

Bhuvnesh -- see the private message for a version of the project that will open in 3522. It was configured as an App Designer app, but the index.html file did not appear to be an App Designer app, so I converted it into a regular Cordova app. Also, I fixed some device ready issues and added in a few helper files, you can do a compare of what you sent me to this to see where I made a few changes. Based on a quick scan, I think you can easily eliminate the use of the intel.xdk.device and intel.xdk.player and, perhaps, the intel.xdk.base plugins; you'll have to experiment. In general, we recommend you not use those old intel.xdk plugins, as they are no longer being updated. There are a few places where the old intel.xdk. web root function is being called, see the util lib file I added for a replacement.

To fully debug your app you're going to have to debug a built app, the intel.xdk functions are not part of the Simulate tab. You may have to use weinre or add special code to get around those functions, but there's a lot going on with the intel.xdk.cache plugin, so that might be hard to do. See this doc page for ideas on how to debug > https://software.intel.com/en-us/xdk/docs/intel-xdk-debug-and-test-overview < You can do a little in the Simulate tab, but not everything.

0 Kudos
Highlighted
8 Views

p.s. The keyboard and screen plugins and file plugins have changed a lot over the past two years. You should confirm that the APIs your app is using from those plugins are still valid, they may have changed since this app was originally written.

0 Kudos