Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JJK
New Contributor III
360 Views

MPSS 3.8.6 modules for CentOS 7.8

Hi all,

I've created an RPM and SRPM of the mpss 3.8.6 mpss-modules files to allow you to use your KNC Xeon Phi's on CentOS 7.8. The resulting files can be found here:

https://www.nikhef.nl/~janjust/mpss

or simply install the RPM using

rpm -ivh https://www.nikhef.nl/~janjust/mpss/mpss-modules-3.10.0-1127.el7.x86_64-3.8.6-2.x86_64.rpm

This works fine on my CentOS 7.8 box, but of course, use at your own risk and rattle your local Intel rep for an official update.

share and enjoy,

JJK

0 Kudos
2 Replies
Valjean__Jean
Beginner
360 Views

Hi,

I have read good reviews about ClearLinux and I've just found out that intel compiler works under ClearLinux.

I'm curious if KNC/mpss or KNL/xppsl works also under ClearLinux to give it a try.

Thank you

JJK
New Contributor III
360 Views

I am not surprised that the intel compiler installs on intel's own Linux distro ;)

As for running mpss:  the mpss-modules package needs to be ported to the ClearLinux kernel (kernel-lts = 4.19 which is way newer than what mpss-modules supports).

As for xppsl for KNL: I have not seen the need to run xppsl on KNL hardware in years; the system runs fine without it. for the KNL PCIe cards you need mpss 4.4 (which is not publicly available and which I don't have) and yes, that also would need to be ported to kernel 4.18+

 

Reply