Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Shati__Khaqan
Beginner
71 Views

Opensuse Leap 42.2 and parallel_studio_xe_2017_update1

I just installed Opensuse leap 42.2 and later tried to installed parallel studio xe 2017 on it and it tells me that its not a supported OS. While on the other page https://software.intel.com/en-us/articles/installing-intel-compilers-on-opensuse about installing intel compiler on opensuse ... it says

"COMPATIBLE Intel Compiler Versions: In order to use Intel® Compilers (C++  or  Fortran) under the lastest release of OpenSLES/SLES/SLED, you will need the latest version of the Intel compiler(s).   Do NOT try to install older Intel Compilers such as 12.x, 11.0, 10.x, 9.x or 8.x under OpenSUSE 12.3 or newer - they will not install easily and probably will not work - and they are NOT supported."

Now question is should I give up on opensuse of intel ? that is I need to go back to previous version of intel compiler or I need to find old opensuse distribution but for old I will definitely y need old intel compiler....

so what are my options ... if opensuse isn't good option I can switch to ubuntu ... will it be a good move or I should stick with opensuse ....

 

 

0 Kudos
1 Reply
Devorah_H_Intel
Moderator
71 Views

Hello,

Please refer to Release Notes for Parallel Studio XE 2017 for system requirements:

https://software.intel.com/sites/default/files/managed/80/c1/PSXE2017Update1_Release_Notes_en_US_Lin...

other Release Notes for different versions and individual components are here:

https://software.intel.com/en-us/articles/intel-parallel-studio-xe-release-notes

The operating systems listed below are supported by all components on Intel® 64
Architecture. Individual components may support additional operating systems and
architecture configurations. See the individual component release notes for full details.
 Debian* 7.x, 8.x
 Fedora* 23, 24
 Red Hat Enterprise Linux* 6.x, 7.x
 SUSE Linux Enterprise Server* 11.x, 12.x
 Ubuntu* 14.04, 16.04
 CentOS* 6.x, 7.x
 Microsoft* Windows* 7, 8.x, 10
 Microsoft* Windows* Server 2008, 2008 R2, 2012, 2012 R2

Please let me know if the above helps.

Regards,

 

 

Reply