Software Archive
Read-only legacy content
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
17065 Discussions

Parallel Studio XE 2017 Update 4 - Installation Failure

Brian_G_
Beginner
775 Views

I am seeing an installation failure on this just released version.  I have tried the off and on-line installers and both fail in the same way.  

The package downloads and decompresses to a local folder without any problems.  After this the product installation display appears and a series of component loads are displayed ending with config.xml, after which the installer abruptly exits.

I am running Windows 10 Professional version 1703 (OS Build 15063.296).

I would appreciate any help with this issue.   

    best regards, Brian Gladman

 

 and the install screen appears and a sequence of loads occurs ending with config.xml after which the installer abruotly exist

0 Kudos
20 Replies
Brian_G_
Beginner
749 Views

I have been looking at the installation logs and find the following errors at the end of the log:

-----------------------------------------------------

[t2b80 2017.05.11 18:41:15.551 00004317] [context]: INFO: Processing: vs_2017: Microsoft Visual Studio* 2017 software
[t2b80 2017.05.11 18:41:15.551 00004318] [context]: INFO: Trying to load all installed instances.
[t2b80 2017.05.11 18:41:15.553 00004319] [context]: ERROR: Scripting error: 
[t2b80 2017.05.11 18:41:15.553 0000431a] [context]: ERROR: Uncaught SyntaxError: Unexpected token b
[t2b80 2017.05.11 18:41:15.554 0000431b] [context]: ERROR: 
[t2b80 2017.05.11 18:41:15.554 0000431c] [context]: ERROR: Line: 1: soft.VisualStudio.Devenv", "version":"15.0.26507.0", "type":"Vsix", branch:"pr
[t2b80 2017.05.11 18:41:15.554 0000431d] [context]: ERROR: 
[t2b80 2017.05.11 18:41:15.554 0000431e] [context]: ERROR: Scripting error: 
[t2b80 2017.05.11 18:41:15.554 0000431f] [context]: ERROR: Uncaught TypeError: Cannot call method 'GetVSInfo' of null
[t2b80 2017.05.11 18:41:15.554 00004320] [context]: ERROR: C:\Users\brg\Downloads\Intel\parallel_studio_xe_2017_update4_professional_edition_online_setup\config\Scenario\base.js
[t2b80 2017.05.11 18:41:15.554 00004321] [context]: ERROR: Line: 38:     var ns_vs = base("vs_processing.js").GetVSInfo();
[t2b80 2017.05.11 18:41:15.554 00004322] [context]: ERROR: 
[t2b80 2017.05.11 18:41:15.555 00004323] [bind_script]: INFO: execute_script: C:\Users\brg\Downloads\Intel\parallel_studio_xe_2017_update4_professional_edition_online_setup\config\Scenario\activation_actions.js
[t2b80 2017.05.11 18:41:15.561 00004324] [context]: INFO: context_imp::execute_script: origin:C:\Users\brg\Downloads\Intel\parallel_studio_xe_2017_update4_professional_edition_online_setup\config\Scenario\activation_actions.js
[t2b80 2017.05.11 18:41:15.567 00004325] [bind_script]: INFO: execute_script: C:\Users\brg\Downloads\Intel\parallel_studio_xe_2017_update4_professional_edition_online_setup\config\Base\license.js
[t2b80 2017.05.11 18:41:15.573 00004326] [context]: INFO: context_imp::execute_script: origin:C:\Users\brg\Downloads\Intel\parallel_studio_xe_2017_update4_professional_edition_online_setup\config\Base\license.js
[t2b80 2017.05.11 18:41:15.578 00004327] [context]: INFO: Scenario::activation: actions generation started
[t2b80 2017.05.11 18:41:15.580 00004328] [bind_script]: ERROR: Scripting error: 
[t2b80 2017.05.11 18:41:15.580 00004329] [bind_script]: ERROR: Uncaught TypeError: Cannot call method 'Add' of undefined
[t2b80 2017.05.11 18:41:15.580 0000432a] [bind_script]: ERROR: C:\Users\brg\Downloads\Intel\parallel_studio_xe_2017_update4_professional_edition_online_setup\config\Scenario\activation_actions.js
[t2b80 2017.05.11 18:41:15.580 0000432b] [bind_script]: ERROR: Line: 249:         ns.ConfigureByFlexlmFeatures.Add(ns.FilterComponentsByAvailableLicense
[t2b80 2017.05.11 18:41:15.580 0000432c] [bind_script]: ERROR: 
[t2b80 2017.05.11 18:41:15.580 0000432d] [context]: ERROR: Exception handled calling mediaconfig.Go
[t2b80 2017.05.11 18:41:15.580 0000432e] [context]: INFO: MICL script execution complete. Thank you.
[t2c90 2017.05.11 18:41:15.613 0000432f] [ISSA]: ERROR: issa_uninit_flex: library is not initialized

[t2c90 2017.05.11 18:41:15.613 00004330] [issa host]: INFO: issa_uninit_flex is called

-----------------------------------------------------

I have three versions of Visual Studio 2017 installed 'side by side' (Community, Community Preview and Enterprise) and it seems that the installation script doesn't handle this properly.

 

Brian_G_
Beginner
749 Views

I can confirm that uninstalling two of the three versions of Visual Studio 2017 that I had installed, leaving only one, leads to a successful installation of Parallel Studio XE 2017 Update 4.  So it seems that the installation script doesn't handle multiple 'side-by-side' installs of Visual Studio 2017. 

Devorah_H_Intel
Moderator
749 Views

Hi Brian,

Thank you for the report with details regarding installation failure. This instance is escalated to development for further investigation.

If possible please submit the complete log file of the failed installation. You can send it privately if that is preferred method.

Best regards,

 

Brian_G_
Beginner
749 Views

Hi Devorah, 

Thanks for getting back to me on this.  A log file is attached as requested.

 

BZimm4
Beginner
748 Views

I am inquiring whether any progress has been made on this issue.  Both Parallel Studio 2017 and and the 2018 beta exhibit this issue when multiple versions of VS2017 are installed.  In my case it is VS2017 enterprise and VS2017 enterprise preview.  Now that Microsoft has moved to an active development channel, i.e. preview, this will be a much more common situation for many of your users.  Uninstalling some versions of VS2017 in order to install this product is not feasible.

 

 

Devorah_H_Intel
Moderator
748 Views

Thank you for the information and logs. Unfortunately, our Install engineer is unable to reproduce the issue.  

Brian_G_
Beginner
748 Views

Since Bryan Z is also experiencing this issue, it is not a problem that is specific to my configuration.  What further information do you need from myself or others who are encountering this problem in order to diagnose and fix it?

BZimm4
Beginner
748 Views
I had this same exact failure on 3 different machines all with a dual install of VS2017. It is not worth the effort to remove and reinstall these products so the parallel studio can be installed since when the next update comes out the same issue will occur until root caused. As stated the 2018 beta also suffers from the same issue. I find it difficult to believe that this was non reproducible.
Devorah_H_Intel
Moderator
748 Views

Root cause of the reported issue was found and fix will be available in the Update 5 to Parallel Studio XE 2017

Workaround:

The issue is reproducible only if user trying to install above VS2017 Preview build. VS2017 RTM build is not impacted, including side-by-side installation of several instances (Enterprise, Pro, Community). As workaround remove VS2017 Preview build and run PSXE2017 installer above VS2017 RTM.

BZimm4
Beginner
749 Views
Thank you for root causing the problem. I eagerly await Update 5 or an updated 2018 beta.
BZimm4
Beginner
748 Views
The just released 2018 Update 1 Beta does not have this fix in it. Very disappointing.
Henrique_M_
Beginner
748 Views

Do you have any idea when the update 5 is going to be released? Or if someone found some workaround to make PSXE2017 work with the VS2017 Preview?

I have this same issue here.

Regards,

Henrique

 

 

Glen_F_
Beginner
748 Views

I'm having the exact same issue. I have both VS2017 RTM and VS2017 (Preview) installed. I tried installing both Parallel Studio XE 2017 Update 4 and 2018 Beta Update 1, and they both stop installing after displaying the initial install splash screen. When will the next update for both products be released? Please fix this for us Intel.

Leonid_K_
Beginner
748 Views

I have the same problem. Windows 10 x64, VS 2015 Community + VS 2017 Community. Integration work only in VS 2015.

Leonid_K_
Beginner
749 Views

On clear just installed VS 2017 (C++ only) integration is ok. 

But when I install additional component and locale, and try to install recommended by Intel Software Manager Adviser update 4, I lost integration with Adviser

On step of installing integration - very long timeout without errors, but no integration on fact. 

I reinstall VS & PS 3 times in different variants - the same problem repeated.

But, when I try install *vs2017*.vsix, VSIX installer show message about runned process PerfWatson2.exe. After I kill this process, VSIX install integration.

Problem in silent installation of .vsix - installation blocked by PerfWatson2.exe process.

Mateusz_L_
Beginner
748 Views

TL;TR: Having installed Visual Studio 2010, 2012, 2013, 2015, 2017 and 2017 Preview side-by-side, I'm experiencing the same problem.

[t3008 2017.07.05 16:38:35.811 00000290] [context]: INFO: Processing: vs_2017: Microsoft Visual Studio* 2017 software
[t3008 2017.07.05 16:38:35.811 00000291] [context]: INFO: Trying to load all installed instances.
[t3008 2017.07.05 16:38:35.816 00000292] [context]: ERROR: Scripting error:
[t3008 2017.07.05 16:38:35.816 00000293] [context]: ERROR: Uncaught SyntaxError: Unexpected token b
[t3008 2017.07.05 16:38:35.816 00000294] [context]: ERROR:
[t3008 2017.07.05 16:38:35.817 00000295] [context]: ERROR: Line: 1: soft.VisualStudio.Devenv", "version":"15.0.26621.2", "type":"Vsix", branch:"pr
[t3008 2017.07.05 16:38:35.817 00000296] [context]: ERROR:
[t3008 2017.07.05 16:38:35.817 00000297] [context]: ERROR: Scripting error:
[t3008 2017.07.05 16:38:35.817 00000298] [context]: ERROR: Uncaught TypeError: Cannot call method 'GetVSInfo' of null
[t3008 2017.07.05 16:38:35.817 00000299] [context]: ERROR: C:\Users\mateuszl\Downloads\Intel\parallel_studio_xe_2017_update4_professional_edition_for_cpp_online_setup\config\ProductConfig\component_shell.js
[t3008 2017.07.05 16:38:35.817 0000029a] [context]: ERROR: Line: 32:     var ns_vs      = base("vs_processing.js").GetVSInfo();
[t3008 2017.07.05 16:38:35.817 0000029b] [context]: ERROR:

 


First, I tried to update existing installation of Parallel Studio XE 2017 to 2017 Update 4, downloaded the whole 3.6 GB installer, extracted, run and noticed that nothing happens after the splash screen disappears.

 

Second, I tried the smaller Web installer with the same no installation result.

Third, I uninstalled all Intel Parallel Studio XE components and previous updates completely, repeated step 1st and 2nd. Same problem, nothing is installed.

I have not tried uninstalling Visual Studio 2017 Preview yet, but I don't really fancy doing that.

It has been two months since the release of Intel PS XE 2017 Update 4. Is there really no hope to get it fixed?

Devorah_H_Intel
Moderator
748 Views

Please see https://software.intel.com/en-us/forums/intel-software-development-products-download-registration-licensing/topic/733930#comment-1906333

Brian_G_
Beginner
749 Views

I am seeing another failure in the installation of this update.  As a result of an issue with a Microsoft update of Visual Studio 2017 Community, I had to uninstall and reinstall it.  After doing this I ran the Intel install procedure and selected repair in order to reintegrate it into VS 2017.  The integration into VS 2017 was not installed by doing this.  I then completely uninstalled Update 4 and reinstalled it but this did not recognise the VS 2017 installation so the integration into VS 2017 failed again.   If Visual Studio 2017 has to be reinstalled, how is it possible to reintegrate the Intel compiler into Visual Studio?  

Henrique_M_2
Beginner
748 Views

Same issue as Brian G., I uninstalled the VS2017 Preview version, installed Visual Studio 2017 Pro and tried to run PSXE2017 installer. Although I could run the installer, I was not able to select VS2017 in the "Choose Integration Target" menu.

Any ideas when the update 5 is going to be released? 

Ogilvie__Duncan
Beginner
463 Views
The bug is in vs_processing.js at this line 439:
instance.packages     = JSON.parse(VSSetupConfig.GetPackages(ids))
The implementation of VSSetupConfig.GetPackages in vs_setup_config.micl produces invalid JSON:
L", branch:\""
Should be (branch has to be quoted since it's a JSON key):
L", \"branch\":\""
I hacked a fix by replacing the offending line in vs_processing.js with:
instance.packages     = JSON.parse(VSSetupConfig.GetPackages(ids).replace(new RegExp('branch:', 'g'), '"branch":'));
For other people trying to install this without removing visual studio 2017 preview (I want to install it for VS2013): it is possible but it requires some hacks. Here a quick guide (do this after you modified vs_processing.js with the fix): 1. Let parallel_studio_xe_2017_update4_setup.exe extract it's contents and uncheck the 'Remove temporary files blahblah' 2. Get x64dbg, open release\x32\x32dbg.exe 3. File -> Restart as Admin 4. Open the extracted setup.exe (File -> Open) 5. Enter command: bpdll v8.micl 6. Enter command: erun 7. Enter command: erun 8. Enter command: erun 9. Enter command: strref 10. Switch to the 'references' tab and type "strong_trusted" You should now see two entries. Double click on the first, you should see code similar to this:
5F462BA0 | 83 EC 14                 | sub esp,14                           |
5F462BA3 | B9 40 6A 8E 5F           | mov ecx,v8.5F8E6A40                  | ecx:EntryPoint
5F462BA8 | C7 04 24 14 00 00 00     | mov dword ptr ss:[esp],14            |
5F462BAF | 68 D0 D0 8F 5F           | push v8.5F8FD0D0                     |
5F462BB4 | E8 68 99 38 00           | call v8.5F7EC521                     |
5F462BB9 | 8B 54 24 18              | mov edx,dword ptr ss:[esp+18]        |
5F462BBD | 89 44 24 04              | mov dword ptr ss:[esp+4],eax         |
5F462BC1 | 0F B6 05 14 E1 8F 5F     | movzx eax,byte ptr ds:[5F8FE114]     |
5F462BC8 | A8 01                    | test al,1                            |
5F462BCA | C7 44 24 08 52 28 82 5F  | mov dword ptr ss:[esp+8],v8.5F822852 | 5F822852:L"catalog"
5F462BD2 | C7 44 24 0C 62 28 82 5F  | mov dword ptr ss:[esp+C],v8.5F822862 | 5F822862:L"strong_trusted"
5F462BDA | 89 54 24 10              | mov dword ptr ss:[esp+10],edx        |
5F462BDE | 74 07                    | je v8.5F462BE7                       |
5F462BE0 | A1 10 E1 8F 5F           | mov eax,dword ptr ds:[5F8FE110]      |
5F462BE5 | EB 21                    | jmp v8.5F462C08                      |
5F462BE7 | 83 C8 01                 | or eax,1                             |
5F462BEA | A2 14 E1 8F 5F           | mov byte ptr ds:[5F8FE114],al        |
5F462BEF | 6A 00                    | push 0                               |
5F462BF1 | FF 15 D4 20 82 5F        | call dword ptr ds:[<&GetModuleHandle |
5F462BF7 | 68 10 2E 82 5F           | push v8.5F822E10                     | 5F822E10:"call"
5F462BFC | 50                       | push eax                             |
5F462BFD | FF 15 D8 20 82 5F        | call dword ptr ds:[<&GetProcAddress> |
5F462C03 | A3 10 E1 8F 5F           | mov dword ptr ds:[5F8FE110],eax      |
5F462C08 | 85 C0                    | test eax,eax                         |
5F462C0A | 75 07                    | jne v8.5F462C13                      |
5F462C0C | B8 FF FF FF FF           | mov eax,FFFFFFFF                     |
5F462C11 | EB 37                    | jmp v8.5F462C4A                      |
5F462C13 | 0F B6 15 14 E1 8F 5F     | movzx edx,byte ptr ds:[5F8FE114]     |
5F462C1A | F6 C2 01                 | test dl,1                            |
5F462C1D | 75 22                    | jne v8.5F462C41                      |
5F462C1F | 83 CA 01                 | or edx,1                             |
5F462C22 | 88 15 14 E1 8F 5F        | mov byte ptr ds:[5F8FE114],dl        |
5F462C28 | 6A 00                    | push 0                               |
5F462C2A | FF 15 D4 20 82 5F        | call dword ptr ds:[<&GetModuleHandle |
5F462C30 | 68 10 2E 82 5F           | push v8.5F822E10                     | 5F822E10:"call"
5F462C35 | 50                       | push eax                             |
5F462C36 | FF 15 D8 20 82 5F        | call dword ptr ds:[<&GetProcAddress> |
5F462C3C | A3 10 E1 8F 5F           | mov dword ptr ds:[5F8FE110],eax      |
5F462C41 | 8D 14 24                 | lea edx,dword ptr ss:[esp]           |
5F462C44 | 52                       | push edx                             |
5F462C45 | FF D0                    | call eax                             |
5F462C47 | 83 C4 04                 | add esp,4                            |
5F462C4A | 33 C9                    | xor ecx,ecx                          | ecx:EntryPoint
5F462C4C | BA 01 00 00 00           | mov edx,1                            |
5F462C51 | 85 C0                    | test eax,eax                         |
5F462C53 | 0F 44 CA                 | cmove ecx,edx                        | ecx:EntryPoint
5F462C56 | 8B C1                    | mov eax,ecx                          | ecx:EntryPoint <--- patch here
5F462C58 | 83 C4 14                 | add esp,14                           |
5F462C5B | C3                       | ret                                  |
Select the "mov eax,ecx" line near the bottom and press spacebar, this should pop up an assemble dialog. Enter "mov al, 1" and press OK. Now go back to the references tab and repeat for the second entry. Now enter the command "erun" again, the setup should run without checksum errors with your modified vs_processing.js Once you see the setup dialog, use "File -> Detach" to detach the debugger. Obviously this is in no way supported and all on your own risk etc. The method worked fine for installing on VS2013 with VS2013 and VS2017 Preview (not RTM!) installed. I'm not sure if it will install for VS2017 correctly with this fix applied but I don't care anyway.
Reply