Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Gabriel_D_
Beginner
59 Views

Rebuild ofed-driver-3.6.1-1.src.rpm MPSS installation issues

Hello,

Im installing MPSS 3.6.1 on two xeon phi nodes in a cluster connected to Infiniband, CentOS 6.6 and the kernel version is 2.6.32-504.8.1.el6.x86_64, so I update the kernel-headers and kernel-devel and rebuilt the MPSS host drives as the user guide says, and so far so good, but the problem comes when I tried to rebuild OFED drivers with rpmbuild --rebuild ofed-driver-3.6.1-.1.src.rpm,  I get the following error message:

error: Failed build dependencies:
        mpss-modules-dev-2.6.32-504.8.1.el6.x86_64 is needed by ofed-driver-3.6.1-1.x86_64

 

Please help

0 Kudos
2 Replies
Loc_N_Intel
Employee
59 Views

Hi Gabriel,

It seems like mpss-modules-dev-2.6.32-504.8.1.el6.x86_64 wasn't installed. According to the readme file, you need to rebuild the MPSS modules prior to installing the MPSS software stack (section 2.1).

After rebuilding the MPSS module, you copy the rebuilt mpss-modules and mpss-module-dev RPMs into ../mpss3.6.1/ and then install the MPSS stack at that time. With the new MPSS modules, you should rebuild OFED drivers successfully.

Thanks 

Gabriel_D_
Beginner
59 Views

Hi Loc N,

thanks for reply, this problem is solved. What I did was, first rebuild the mpss-modules, then install mpss and now rebuild ofed-drivers.

Then proceede with OFED installation...

Thanks, again.

Reply