Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mitchell_Franklin
New Contributor I
146 Views

[Resolved] App Movement in Build

Jump to solution

Hi All,

I hope this is going to make sense, once I build out to any device i.e. Android, IOS etc. if I hold my finger on the screen and swipe up or down the whole app moves - when I say moves this includes the header or/and footer as well.

This does not occur in the emulator and it may be that I am just blind but I cant see an option/code setting to prevent this.

I am thinking also that since it is Cordova Hybrid which is an inbuilt webview that this may be normal (hoping not).

Any feedback or suggestions would be greatly appreciated.

Thanks

Mitch

Tags (2)
0 Kudos
1 Solution
PaulF_IntelCorp
Employee
146 Views

Also, try this:

<preference name="DisallowOverscroll" value="true" />

In the intelxdk.config.additions.xml file in your project directory.

View solution in original post

7 Replies
Anusha_M_Intel1
Employee
146 Views

To make your header and footer fixed, try the CSS attribute - position: fixed;

Which UI framework are you using? And are you using App Designer?

PaulF_IntelCorp
Employee
146 Views
Mitchell_Franklin
New Contributor I
146 Views

Anusha M. (Intel) wrote:

To make your header and footer fixed, try the CSS attribute - position: fixed;

Which UI framework are you using? And are you using App Designer?

 

Thanks for the reply Anusha,

I am currently using framework7 as the UI and yes I am also using the App Desginer, i tried your suggestion but to no avail :( it is very strange as in the emulator this does not occur at all

Ta

Mitch

Mitchell_Franklin
New Contributor I
146 Views

Paul F. (Intel) wrote:

Mitch -- this might be what you're looking for > https://software.intel.com/en-us/forums/intel-xdk/topic/557191#comment-1...

Hi Paul and thanks for the information, I will try this out and let you know how I go

Thanks

Mitch

PaulF_IntelCorp
Employee
147 Views

Also, try this:

<preference name="DisallowOverscroll" value="true" />

In the intelxdk.config.additions.xml file in your project directory.

View solution in original post

Mitchell_Franklin
New Contributor I
146 Views

Paul F. (Intel) wrote:

Also, try this:

<preference name="DisallowOverscroll" value="true" />

In the intelxdk.config.additions.xml file in your project directory.

Hi Paul,

This setting is perfect - I had found that I already had the other option set then saw this, once again Paul to the rescue :)

Do you think that this may be something for the build management to have as a selection option? or is this overflow specific to certain framework UI?

Again thank you very much

Mitch

PaulF_IntelCorp
Employee
146 Views

Mitchell -- that option is something that should be in the settings UI, just hasn't made it. :( It is a Cordova option, you can read more about it in the official Cordova docs > https://cordova.apache.org/docs/en/5.4.0/config_ref/index.html#multi-platform-preferences

Reply