Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Marcelo_C_2
Beginner
147 Views

Stuck at "Cordova preparing sources..."

Hello Friends.

I imported an existing Cordova project, when I tried to emulate, it stuck at the "Cordova preparing sources..."
I finished XDK, but when I restart it returns to the same point with the same message.

Any Clues?

Thanks.

 

Tags (2)
0 Kudos
6 Replies
Swati_S_Intel1
Employee
147 Views

Close the XDK, clear the cache from XDK install location and restart.

 ~/Library/Application Support/XDK/Cache on Mac

%LocalAppData%\XDK\Cache

 

Marcelo_C_2
Beginner
147 Views

Dear Swati,
I cleared the cache, restarted windows.
When I started XDK, it got stuck at the same point.

PaulF_IntelCorp
Employee
147 Views

Marcelo -- make sure there are no plugin references in your intelxdk.config.additions.xml file and delete all plugins directories located inside your project (with the XDK closed). Then open the XDK and try opening your project. You may have to add back some of the plugins manually, using the plugin management tool on the Projects tab.

Swati_S_Intel1
Employee
147 Views

Marcelo, under the ~/Library/Application Support/XDK/ directory there is a global-settings.xdk file. Open that file and search for currenttab. It would be 'emulate' in your particular situation. Please change it to 'project' and save global-settings.xdk file. And then, restart the XDK, the XDK will restart with Projects tab open.

For our investigation purpose, before you do the above, please copy the xdk.log file from  ~/Library/Application Support/XDK/ folder and send it to us (attach here or Private Message). Also, if you are able to please send your project that caused this issue.

 

John_H_11
Beginner
147 Views

I am also experiencing this problem after upgrading to the latest XDK.  Cleared cache and removed plugins but still very slow when I switch to Emulator tab after making any kind of source edit.  Shows message "Cordova preparing sources...".  This is unusable in this state.

John_H_11
Beginner
147 Views

It turns out the slowness was due to me having installed node modules in the 'www' folder for testing purposes.  This made for a lengthy prep/build process when switching to Emulate.  Removing those folders solved the problem.

Reply