Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Flemming_P_
Beginner
155 Views

Trying cordova webrtc plugin for ios

Hi ... Has anyone had luck with a plugin that gets
webrtc run in ios

I tried this .. But cant find out why failed

https://github.com/eface2face/cordova-plugin-iosrtc

 

** BUILD FAILED **


The following build commands failed:
    CompileSwift normal arm64 .../Quiz Bornholm/platforms/ios/Quiz Bornholm/Plugins/cordova-plugin-iosrtc/iosrtcPlugin.swift
    CompileSwift normal arm64 .../Quiz Bornholm/platforms/ios/Quiz Bornholm/Plugins/cordova-plugin-iosrtc/PluginRTCTypes.swift
    CompileSwift normal arm64 .../Quiz Bornholm/platforms/ios/Quiz Bornholm/Plugins/cordova-plugin-iosrtc/PluginRTCPeerConnection.swift
    CompileSwift normal arm64 .../Quiz Bornholm/platforms/ios/Quiz Bornholm/Plugins/cordova-plugin-iosrtc/PluginRTCPeerConnectionConfig.swift
    CompileSwiftSources normal arm64 com.apple.xcode.tools.swift.compiler
(5 failures)
ERROR building one of the platforms: Error code 65 for command: xcodebuild with args: -xcconfig,.../Quiz Bornholm/platforms/ios/cordova/build-release.xcconfig,-project,Quiz Bornholm.xcodeproj,ARCHS=armv7 arm64,-target,Quiz Bornholm,-configuration,Release,-sdk,iphoneos,build,VALID_ARCHS=armv7 arm64,CONFIGURATION_BUILD_DIR=.../Quiz Bornholm/platforms/ios/build/device,SHARED_PRECOMPS_DIR=.../Quiz Bornholm/platforms/ios/build/sharedpch
You may not have the required environment or OS to build this project
Error: Error code 65 for command: xcodebuild with args: -xcconfig,.../Quiz Bornholm/platforms/ios/cordova/build-release.xcconfig,-project,Quiz Bornholm.xcodeproj,ARCHS=armv7 arm64,-target,Quiz Bornholm,-configuration,Release,-sdk,iphoneos,build,VALID_ARCHS=armv7 arm64,CONFIGURATION_BUILD_DIR=.../Quiz Bornholm/platforms/ios/build/device,SHARED_PRECOMPS_DIR=.../Quiz Bornholm/platforms/ios/build/sharedpch

 

Tags (2)
0 Kudos
7 Replies
Amrita_C_Intel
Employee
155 Views

Hello,

Are you able to build for other platforms?

Elroy_A_Intel
Employee
155 Views

At this time, Intel XDK Build system doesn't support Cordova* plugins that require xCode versions above 7.0.

Flemming_P_
Beginner
155 Views

OKAY thanks ... is it on the roadmap and in near future ?

PaulF_IntelCorp
Employee
155 Views

Flemming -- the version of Xcode on our build systems is currently 7.2.1, which is one minor version behind the latest (which is currently 7.3.x). Doing a little bit of searching regarding that error message, it may be due to using CLI 5.1.1 rather than CLI 5.4.1. Some of the search results indicated that you needed to be using cordova-ios@3.9.0, which means you need to be using CLI 5.4.1 on our build system. See this FAQ for more details > https://software.intel.com/en-us/xdk/faqs/cordova#cordova-version < about the cordova framework versions being used by our build system.

Alexandre_L_
Beginner
155 Views

Facing to the same issue. Seems to be related to unsupported hooks by intel xdk.

Do you have a roadmap to support them ?

PaulF_IntelCorp
Employee
155 Views

We plan to support hooks scripts in a future build system, which is under development. The build system needs to be reworked to eliminate the security threats caused by hook scripts and plugin-based gradle scripts. Sorry, but I am not allowed to publish an expected release date, but I can say that there is active work on that part of the project.

Denis_B_1
Beginner
155 Views

Ddid anybody find a solution in order to compile iosRTC with XDK?

Reply