Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Peter_R_
Beginner
70 Views

Uploading Project fails

Somehow Uploading project (for test) does not work anymore since yesterday for several projects (not all projects) - the upload bar stays at ~20% for a very long time and then giving just "http request failed" (looks like a timeout because it stops for ~5minutes before giving the error)

I've already reinstalled XDK, tried with new projects as well (using Cordova+HTML5 Template) - as soon as I add a plugin the upload stops working with the above error.

May be related: I had added a plugin which I removed afterwards because of typo. Remove failed - there was suddenly a file missing in xdk-scratchdir/platforms/android/res/xml/config.xml - it was impossible to add or remove any plugins anymore for this project - it has somehow corrupted itself I think. Deleting scratchdir doesn't help, it was recreated but the file was still missing.

Since then the upload is failing even with new projects as soon as I add a cordova plugin. Even when I remove the plugin again, the upload for this project is failing with "http request failed" - I cannot see how this is related but maybe it is. Creating a new project without adding anything, the upload works fine.

using latest XDK (3759)

how can I resolve the issue?

Tags (2)
0 Kudos
3 Replies
PaulF_IntelCorp
Employee
70 Views

There are several other threads also experiencing this "unable to add or delete plugins" issue. I've only been able to reproduce it once, on one day, and was never able to make it happen again. It's a very mysterious problem that, unfortunately, for which we have not been able to come up with a fix or workaround. I wish I had something more to offer, but this is proving to be a very difficult issue. Here's the main thread that I've been dealing with issue on > https://software.intel.com/en-us/forums/intel-xdk/topic/707086 < Take a look at that thread to see if there's anything there that helps.

Peter_R_
Beginner
70 Views

Hi Paul, thanks for your answer

I am not sure if the link provided is relevant for my problem - I do not use Construct 2, I have the problem with "native" XDK Cordova Apps (even with Hello World Sample with an added plugin.

I can add/remove plugins in new projects - but I cannot upload the project for testing, it looks like the request times out after some minutes and gives the following error:

Error uploading sources: Error in uploading project files: : Error in uploading project files: : Http request failed; More info: {"upload":"xhr","method":"PUT","proxy":"no","url":"https://am-xdk2.s3.amazonaws.com/cust.dac26a2c-17fa-44cc-be59-8d186205f5ea/app.452d3800-27b6-4880-b556-cdf817d8e25c/01c1d7bf-2c9c-48ba-bab8-53514f3e6035/QA/plugins.zip?X-Amz-Expires=600&x-amz-security-token=[....]U%3D&X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=ASIAJZQ2XN6T2NXFHRSQ/20170203/us-east-1/s3/aws4_request&X-Amz-Date=20170203T085555Z&X-Amz-SignedHeaders=content-length;content-md5;content-type;host;x-amz-security-token&X-Amz-Signature=[...]","headers":[{"headerName":"Content-Type","headerValue":"application/zip"},{"headerName":"Content-MD5","headerValue":"E0AUWcXQY/mC9zpRTFCxTA=="},{"headerName":"Content-Length","headerValue":"20885493"}]}

(I've removed some content with "[...]", not sure if they're ok to show publicly. let me know if you need the full message text)

The one project with the plugin add/remove failure - I would be fine to just make new one and reimport any scripts, but my main problem is, that I cannot upload any project with an added plugin at the moment.

Test-Case: New Project -> Template -> Cordova+HTML5 (no designer). Now I can upload the project with no issues. Now I add a plugin (cordova-plugin-admobpro in my case) -> upload fails with the above error.
The upload keeps failing, even when I remove the plugin again (which is possible without errors)

My projects are currently stored on a network drive, will test on normal HDD tomorrow

PaulF_IntelCorp
Employee
70 Views

Peter -- if the "unable to add/remove a plugin" bit happens again, try the following experiment:

  • after adding and removing the admob plugin and confirming that your project can no longer add or remove any pluings
  • exit the xdk
  • delete the plugins folder inside your project folder and all files within it
  • restart the xdk and open the problem project
  • see if you can add or remove a plugin

Regarding the unable to push to the backend Test server for use with App Preview, that is likely a different problem. I have not heard of any other issues regarding this, I just tried myself, to be sure the test server is working correctly, and I did not experience any issues. I added your admob plugin to an existing project and was able to push it to the Test server. That plugin is particularly large (~40MB) and took a very long time to install...

There is a workaround, rather than using the Test server to push your app into App Preview, use the Test tab's "wifi" mode. That way you will bypass the test server altogether. It requires that your dev machine and App Preview are on the same subnet and can see each other (the router does not implement wifi isolation); this is usually the case on most home networks, but may not always be the case with your work network. In that case, you can "get" the project from within App Preview by using the "Local Apps" button at the bottom of the App Preview screen. If App Preview sees the XDK (while the Test tab's "wifi" button is pressed) you will see the list of projects that are present on your XDK Projects tab list. Just select the project you want to run and App Preview will load it directly from the XDK, rather than going to the backend Test server to get the app.

Reply