Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
316 Views

VMware Workstation 9 collides with Intel Parallel Studio XE 2013

Jump to solution

VMware Workstation 9 collides with Intel Parallel Studio XE 2013. After I installed the Intel Parallel Studio XE 2013, the operating systems I have created in the VMware Workstation 9 (with Easy Install), such as Windows XP, Windows 8 Pro and Centos 6.3 crash down easily, reporting ” A fault has occurred causing a virtual CPU to enter the shutdown state. If this fault had occurred outside of a virtual machine, it would have caused the physical machine to restart. The shutdown state can be reached by incorrectly configuring the virtual machine, a bug in the guest operating system, or a problem in VMware Workstation. Click OK to restart the virtual machine or Cancel to power off the virtual machine.” or "The CPU has been disabled by the guest operating system", even if I reinstalled VMware Workstation 9 again and again. My operating system is Windows 7 Professional, running on a Thinkpad W520.

0 Kudos

Accepted Solutions
Highlighted
Employee
303 Views
I have been using VMware workstation 8.0.4 build-744019 on Windows 7 64-bit Enterprise with Windows 7 professional, and Ubuntu 11.04 guest operating systems running on a thinkpad x220 successfully. I have enabled VT on the thinkpad through system BIOS. I have installed C++ Composer XE 2013 under Windows 7 guest operating system without any issues. I will try installing the entire paralle studio 2013 to see if I can reproduce the problem. If VMware crashes due to an application (in this case parallel studio tools) then I tend to suspect VMware itself as the casue not the application. The VMware message you quoted seesm to suggest this: "The shutdown state can be reached by incorrectly configuring the virtual machine, a bug in the guest operating system, or a problem in VMware Workstation. Click OK to restart the virtual machine or Cancel to power off the virtual machine.” or "The CPU has been disabled by the guest operating system" There have been a number of VMware 9.0 crash reports with different operating systems; one involving Centos 6.x. I would suggest you also contact VMware support to see if they are aware of the issue you are facing. From VMware web site http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=100399... --mark

View solution in original post

0 Kudos
25 Replies
Highlighted
Employee
303 Views
Hi Jack, This is an issue I've not seen nor I see in any issues filed against the Studio. I've pinged our developers to find out more on this scenario you're facing with the Parallel Studio install and awaiting a response, and will get back to you soon. Appreciate your patience. Regards, Kittur
0 Kudos
Highlighted
Employee
304 Views
I have been using VMware workstation 8.0.4 build-744019 on Windows 7 64-bit Enterprise with Windows 7 professional, and Ubuntu 11.04 guest operating systems running on a thinkpad x220 successfully. I have enabled VT on the thinkpad through system BIOS. I have installed C++ Composer XE 2013 under Windows 7 guest operating system without any issues. I will try installing the entire paralle studio 2013 to see if I can reproduce the problem. If VMware crashes due to an application (in this case parallel studio tools) then I tend to suspect VMware itself as the casue not the application. The VMware message you quoted seesm to suggest this: "The shutdown state can be reached by incorrectly configuring the virtual machine, a bug in the guest operating system, or a problem in VMware Workstation. Click OK to restart the virtual machine or Cancel to power off the virtual machine.” or "The CPU has been disabled by the guest operating system" There have been a number of VMware 9.0 crash reports with different operating systems; one involving Centos 6.x. I would suggest you also contact VMware support to see if they are aware of the issue you are facing. From VMware web site http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=100399... --mark

View solution in original post

0 Kudos
Highlighted
Employee
303 Views
I installed parallel Studio XE 2013 and everything has been working fine so far. As stated earlier I am using VMware 8.x. I do not have 9.0. --mark
0 Kudos
Highlighted
Beginner
303 Views
Thank you a lot, Mark. The solution you give works so well. It seems that something is wrong with the vmware-workstation 9. You do help me a lot. Thanks, Mark.
0 Kudos
Highlighted
Employee
303 Views
Hi Jack, Thanks for your patience through this while Mark, my peer was investigating this issue. Mark - appreciate the resolution. Regards, Kittur
0 Kudos
Highlighted
Beginner
303 Views

I have the same issue.

Bellow is my post at vmware communities.

After a lot of testing (restore from backups, clean install, e.t.c) i found that the cause of all crashes and problems is a conflict between Intel Parallel Studio XE 2013 and Vmware Workstation 9, it may affect also other versions. As soon i realized the problem i searched for other reports of the problem and found http://software.intel.com/en-us/forums/topic/328380. ; If Vmware Workstation 9 is installed alongside with Intel's Parallel Studio XE 2013 all the problems that are analyzed bellow will happen. I speculate that there is conflict between some hw-monitor driver and Vmware Workstation that leads to crashes.

 

Unfortunately just uninstalling Intel Parallel Studio XE 2013 will not fix the problem.

 

The most common error codes are:

vcpu-0| W110: MONITOR PANIC: vcpu-0:VMM fault 6: src=MONITOR rip=0xfffffffffc2c14a0 regs=0xfffffffffc008a60
vcpu-0| W110: MONITOR PANIC: vcpu-0:VMM fault 14: src=MONITOR rip=0xfffffffffc2c147e regs=0xfffffffffc008a40
vcpu-0| W110: MONITOR PANIC: vcpu-0:ASSERT vmcore/vmm/main/crosscall.c:690s

 

Also process inside linux VM's crash with SIGSEGV.

 

Original Post:

Guest crashes with error vcpu-0:VMM fault 14: src=MONITOR or vcpu-0:VMM fault 6: src=MONITOR

 

I am using Vmware Workstation 9 on a Dell XPS L502x laptop with Windows 7 Professional x64. The laptop specs are:
Intel Core i7-2670QM
16Gb RAM
Intel HD 3000
Nvidia GT 540m
Crucial M4 512GB SSD
Seagate Momentus 750GB

 

When try to boot a virtual machine configured with more than two 2 CPUS's, most of the times it crashes immediately with the one of the following error messages.
vcpu-0| W110: MONITOR PANIC: vcpu-0:VMM fault 6: src=MONITOR rip=0xfffffffffc2c14a0 regs=0xfffffffffc008a60
vcpu-0| W110: MONITOR PANIC: vcpu-0:VMM fault 14: src=MONITOR rip=0xfffffffffc2c147e regs=0xfffffffffc008a40
vcpu-0| W110: MONITOR PANIC: vcpu-0:ASSERT vmcore/vmm/main/crosscall.c:690s

 

In another virtual machine that is configured with 2-CPUS and running Centos 6.3 64-bit. Processes randomly receiver SIGSEGV and crash for ex.
bzi2 crash
bzip2: Caught a SIGSEGV or SIGBUS whilst compressing.

 

   Possible causes are (most likely first):
   (1) This computer has unreliable memory or cache hardware
       (a surprisingly common problem; try a different machine.)
   (2) A bug in the compiler used to create this executable
       (unlikely, if you didn't compile bzip2 yourself.)
   (3) A real bug in bzip2 -- I hope this should never be the case.
   The user's manual, Section 4.3, has more info on (1) and (2).

 

   If you suspect this is a bug in bzip2, or are unsure about (1)
   or (2), feel free to report it to me at: jseward@bzip.org.
   Section 4.3 of the user's manual describes the info a useful
   bug report should have.  If the manual is available on your
   system, please try and read it before mailing me.  If you don't
   have the manual or can't be bothered to read it, mail me anyway.

 

In /var/log/messages, I see the following:
tpvmlpd2[3873]: readlink("/dev/vmwcomgw") failed with 2

 

I suspected that there is is a problem with the laptop's memory so i run memtest86 and laptops memory test and found no errors.

I tested also Vmware player and it has the same behaviour.

 

Any help appreciated!
Attachments:



0 Kudos
Highlighted
Valued Contributor II
303 Views
>>...I tested also Vmware player and it has the same behaviour. Thank you for these details! >>...bzip2: Caught a SIGSEGV or SIGBUS whilst compressing... SIGSEGV error is declared in signal.h header file: ... #define SIGSEGV 11 /* segment violation */ ... and it is a very-old-version of modern Access Violation exception. I also wanted to understand what the SIGBUS error is but it is not clear where the error is declared.
0 Kudos
Highlighted
Black Belt
303 Views

>>>I also wanted to understand what the SIGBUS error is but it is not clear where the error is declared.>>>

Is not this so called bus error?

0 Kudos
Highlighted
Black Belt
303 Views

@Savour.G

I did a quick research on the net and find that fault 6 is related to invalid opcode.This line containes address of invalid instruction rip=0xfffffffffc2c14a0

And the fault no. 14  this is page fault which probably occurs here at this addressn rip=0xfffffffffc2c147e by comparing these two locations you can see that this is the same piece of code related to VMM process.

0 Kudos
Highlighted
Beginner
303 Views

iliyapolak wrote:

@Savour.G

I did a quick research on the net and find that fault 6 is related to invalid opcode.This line containes address of invalid instruction rip=0xfffffffffc2c14a0

And the fault no. 14  this is page fault which probably occurs here at this addressn rip=0xfffffffffc2c147e by comparing these two locations you can see that this is the same piece of code related to VMM process.

I noticed that too, but why is that happening?

I will try identify which of the Parallel's Studios compenent conflicts and causes the crashes.

0 Kudos
Highlighted
Black Belt
303 Views

>>>I noticed that too, but why is that happening?

I will try identify which of the Parallel's Studios compenent conflicts and causes the crashes.>>>

Can you see how VMM monitor is implemented?I mean does it some kin of dll or kernel mode driver?

0 Kudos
Highlighted
Valued Contributor II
303 Views
>>>>...After I installed the Intel Parallel Studio XE 2013, the operating systems I have created in the VMware Workstation 9 >>>>(with Easy Install), such as Windows XP, Windows 8 Pro and Centos 6.3 crash down easily... >>... >>...I will try identify which of the Parallel's Studios compenent conflicts and causes the crashes... This is absolutely wise decision because the Intel Parallel Studio XE 2013 includes at least 8 different components. I would really suspect Vtune Amplifier XE or Inspector XE. Do you need a complete list of components of the Intel Parallel Studio XE 2013?
0 Kudos
Highlighted
Black Belt
303 Views

>>>>...After I installed the Intel Parallel Studio XE 2013, the operating systems I have created in the VMware Workstation 9
>>>>(with Easy Install), such as Windows XP, Windows 8 Pro and Centos 6.3 crash down easily...
>>...
>>...I will try identify which of the Parallel's Studios compenent conflicts and causes the crashes..

I did not understand is your Parallel Studio suite onstalled inside a guest OS or inside a Host OS?

0 Kudos
Highlighted
Black Belt
303 Views

>>>This is absolutely wise decision because the Intel Parallel Studio XE 2013 includes at least 8 different components. I would really suspect Vtune Amplifier XE or Inspector XE.>>>

Could that be the issue mainly becuse of low-level operations which require usage of priviledged instructions.

0 Kudos
Highlighted
Valued Contributor II
303 Views
>>...Do you need a complete list of components of the Intel Parallel Studio XE 2013? Here it is just in case: - C/C++ compilers - TBB - MKL - IPP - VTune Amplifier XE ( *** ) - Inspector XE ( *** ) - Static Analysis - Advisor XE Note: *** - suspected
0 Kudos
Highlighted
Valued Contributor II
303 Views
After installing Intel Parallel Studio XE 2013 with all components selected on a laptop with Windows 7 Professional ( 64-bit ) OS I have not detected any issues with VM Player ( latest version ) and QNX Neutrino v6.5 as a quest OS ( it was installed before IPS XE 2013 ). If interested I could provide details for versions and please confirm it.
0 Kudos
Highlighted
Black Belt
303 Views

Savour.G issue is related to VMware Workstation 9.Maybe this issue will not be reproduced when VM Player is installed.

0 Kudos
Highlighted
Valued Contributor II
303 Views
Savour.G clearly stated: >>...I tested also Vmware player and it has the same behaviour.
0 Kudos
Highlighted
Black Belt
303 Views

Sergey Kostrov wrote:

Savour.G clearly stated:

>>...I tested also Vmware player and it has the same behaviour.

Sorry I have not seen this when I read the text.

0 Kudos