Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Pedro_O_
Beginner
54 Views

iOS Build Error - With Pushwoosh Plugin

Hello, I want to help.

I am trying to compile my application, but I'm getting error in the build for iOS, the error that occurs is:

From what I could identify this error is occurring while adding PushWoosh plugin for push notifications.

Follow my application information:

  • Cordova CLI 5.1.1
  • Plugin: Network Information | Plugin ID: cordova-plugin-network-information | Plugin Version: 1.0.1
  • Plugin: Device | Plugin ID: cordova-plugin-device | Plugin Version: 1.0.1
  • Plugin: Notification | Plugin ID: cordova-plugin-dialogs | Plugin Version: 1.1.1
  • Plugin: Splashscreen | Plugin ID: cordova-plugin-splashscreen | Plugin Version: 2.1.0
  • Plugin: Intel XDK Device | Plugin ID: intel.xdk.device | Plugin Version: 1.2.5
  • Plugin: Geolocation | Plugin ID: cordova-plugin-geolocation | Plugin Version: 1.0.1
  • Plugin: Camera | Plugin ID: cordova-plugin-camera | Plugin Version: 1.2.0
  • Plugin: File | Plugin ID: cordova-plugin-file | Plugin Version: 2.1.0
  • Plugin: SocialSharing | Plugin ID: nl.x-services.plugins.socialsharing | Plugin Version: 4.3.19
  • Plugin: File Transfer | Plugin ID: cordova-plugin-file-transfer | Plugin Version: 1.2.1
  • Plugin: Pushwoosh | Plugin ID: com.pushwoosh.plugins.pushwoosh | Plugin Version: 4.2.0

Attached is the log of the build.

Tks!

Tags (2)
0 Kudos
4 Replies
John_H_Intel2
Employee
54 Views

The first thing that stands out to me is the plugin version of the pushwoosh plugin.

  • Plugin: Pushwoosh | Plugin ID: com.pushwoosh.plugins.pushwoosh | Plugin Version: 4.2.0

If you add it via the gui in the XDK, the version should be 

  • Plugin "com.pushwoosh.plugins.pushwoosh" (3.6.16) installed.
  •  

 

0 Kudos
Pedro_O_
Beginner
54 Views

Thanks for return, John!

But if I put the 3.6.16 version of this plugin is the identity of double error on Android, reported in post
https://software.intel.com/pt-br/forums/intel-xdk/topic/604103.

Because of that migrated version of the plugin to 4.2.0 version, because of that I'm having to work with a version of the app for Android and one for iPhone.

What I wanted to solve.

0 Kudos
John_H_Intel2
Employee
54 Views

I was able to build with 3.6.16 for both iOS and Android successfully. 

Where are you getting the double error on android? During the build? Submission to the store?

0 Kudos
John_H_Intel2
Employee
54 Views

Also, this thread might be of some help https://software.intel.com/en-us/forums/intel-xdk/topic/607293

0 Kudos