Showing results for 
Search instead for 
Did you mean: 

intel xdk Unhandled Exec Call not showing on simulate tab


I'm publishing a game using intel XDK. Also use Admob plugin "cordova-plugin-ad-admob". The problem is that the simulate tab is not showing the exec call "Admob.setUp". I've already published a game with Admob ads, and it works just fine, and in this case, i can see the Unhandled Exec Call Admob.setUp in the simulate tab even before running it on my device. But with this new app i can't!

I've already built it anyway, but it is not showing ads at all on real device.

i've tried to compare both app's code on develop tab and as far i can see there is one missing file "Admob.js" which is located (in the working ads app) at www folder. This file does not exist on this new app... but i really don't know if this is the problem... maybe it is just an obvious guess.

I have tried mutiple exports from Construct 2 (also double checked the code, the banner/instersticial Ids, test mode set to false and true), deleted the whole Xdk project and created a new one, also google it, searched on Scirra's website, than i decided to ask for help here.

May someone please, help me with this?

Thanks in advance! 

Tags (2)
0 Kudos
1 Reply

Sounds to me like you have not included the admob plugin in the new project. The plugin provides that admob.js file as part of the Cordova packaging (build) step. But the plugin needs to be part of the project.

The Simulate tab does a partial packaging process, but it does not include the native code that goes along with the admob.js, so the Simulate tab should see the admob.js, if the plugin is part of your project, but it will not be able to do anything meaningful with the plugin.