Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Andrea_P_1
New Contributor I
89 Views

intelxdk:crosswalk version="18"

Hello,

i'm trying to build a project *without* crosswalk. However i've a strange issue. While my other projects are dubugged correctly this project doesn't start the debug because the file intelxdk.config.android.app.xml shows me that the project should use crosswalk version 18

<intelxdk:crosswalk version="18"/>

I've tried to change it manually to 16, but once i start "Debug" the file is changed back to 18. I don't find a way to force a different value. Also changing the version on Build Settings tab doesn't cure the problem. I've tried a different CLI version, Enable or Disable Crosswalk using a different version but no luck. 

Who is creating that file?

Thank you

Tags (2)
0 Kudos
6 Replies
PaulF_IntelCorp
Employee
89 Views

Change your CW version to 17 in the Build Settings. There is a problem with Debug modules (built by the Debug tab) and Crosswalk 18.

Andrea_P_1
New Contributor I
89 Views

maybe i was not clear:

1) I'm not using CrossWalk at all (and i don't want to use it)
2) if i change CrossWalk version (to 17 for example) and enable it i have this error:

  • Building a Cordova 5.4.1 Project Preview application with Crosswalk 17.
  • Using platform cordova-android 5.0.0.
  • The application name is "AP Debug x17 CralItalia2000"
  • The package name is "com.intel.appx.CralItalia2000.xwalk17"
  • Plugin "cordova-plugin-crosswalk-webview" (1.5.0) installed.
  • Plugin "cordova-plugin-apx-webview" (1.0.0) installed.
  • Plugin "cordova-plugin-app-analyzer" (1.0.0) installed.
  • Plugin "cordova-plugin-app-analyzer23" (1.0.0) installed.
  • Plugin "cordova-plugin-cdt-xwalk17" (1.0.0) installed.
  • Plugin "cordova-plugin-device" (1.1.2) installed.
  • Error: Plugin CardIO cannot be added. The plugin contains Gradle scripts.
  • Error: Plugin PayPalMobile cannot be added. The plugin contains Gradle scripts.
  • Plugin "cordova-plugin-whitelist" (1.2.1) installed.
  • Plugin "com.intel.xdk.ppfa" (1.0) installed.

 

If i reenable it (with version 17 in the combobox) the project is already created with version 18 and cannoy be build

PaulF_IntelCorp
Employee
89 Views

Your problem is due to these two lines:

  • Error: Plugin CardIO cannot be added. The plugin contains Gradle scripts.
  • Error: Plugin PayPalMobile cannot be added. The plugin contains Gradle scripts.

The XDK build system does not work with plugins that include Gradle scripts, for security reasons. There is one exception, which is explained in this FAQ > https://software.intel.com/en-us/xdk/faqs/cordova#push-plugin-fix <

Also, the Debug tab ALWAYS uses Crosswalk, you cannot build a debug module without Crosswalk. If you want to debug an app without Crosswalk you must user remote CDT > https://software.intel.com/en-us/xdk/docs/intel-xdk-debug-and-test-overview#RemoteChromeDevTools <

Andrea_P_1
New Contributor I
89 Views

i've tried to change the plugin as the guide says because it "seems" that gradle script does nothing but when i try to compile the project there is a problem due compilation errors:

:compileArmv7ReleaseJava.../builds/build.2016-08-01.21-53-35.lJZpTT.tmp/cordova_project/platforms/android/src/com/paypal/cordova/sdk/PayPalMobileCordovaPlugin.java:20: error: package com.paypal.android.sdk.payments does not exist
import com.paypal.android.sdk.payments.*;
^
.../builds/build.2016-08-01.21-53-35.lJZpTT.tmp/cordova_project/platforms/android/src/com/paypal/cordova/sdk/PayPalMobileCordovaPlugin.java:28: error: cannot find symbol
    private PayPalConfiguration configuration = new PayPalConfiguration();
            ^
  symbol:   class PayPalConfiguration
  location: class PayPalMobileCordovaPlugin
.../builds/build.2016-08-01.21-53-35.lJZpTT.tmp/cordova_project/platforms/android/src/com/paypal/cordova/sdk/PayPalMobileCordovaPlugin.java:255: error: cannot find symbol
    private PayPalOAuthScopes getOauthScopes(JSONArray scopeList)  throws JSONException {
            ^
  symbol:   class PayPalOAuthScopes
  location: class PayPalMobileCordovaPlugin
.../builds/build.2016-08-01.21-53-35.lJZpTT.tmp/cordova_project/platforms/android/src/com/paypal/cordova/sdk/PayPalMobileCordovaPlugin.java:329: error: cannot find symbol
    private PayPalPaymentDetails parsePaymentDetails(JSONObject object) throws JSONException {
            ^
  symbol:   class PayPalPaymentDetails
  location: class PayPalMobileCordovaPlugin
.../builds/build.2016-08-01.21-53-35.lJZpTT.tmp/cordova_project/platforms/android/src/com/paypal/cordova/sdk/PayPalMobileCordovaPlugin.java:342: error: cannot find symbol
    private PayPalItem[] parsePaymentItems(JSONArray array) throws JSONException {
            ^

Can you try to add this plugin to one of you mantain until you didn't find a way to compile plugins with Gradle? It will be useful for a lot of people.

PaulF_IntelCorp
Employee
89 Views

The gradle script always does something useful, so removing it is only viable if the gradle script that you removed was equivalent to the one described in the FAQ (https://software.intel.com/en-us/xdk/faqs/cordova#push-plugin-fix). If the gradle script you removed is NOT equivalent to that scenario, removing it will not work.

We do not maintain any third-party plugins, the featured list is just a helpful list of plugins that are frequently used by developers. We have no control over third-party plugins, whether or not they are in the featured list.

jerome_g_2
Beginner
89 Views

Some plugin offer a gradle-free version, for instance I use One signal PUSH sdk plugin and there's a version specially made for phonegap/intel XDK without gradle. 

Reply