Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Pruthu_U_
Beginner
119 Views

phone gap build error 6.2 cli

When i am making application and uploading zip file in phone gap build . it creates both debug & release app but i cannot install it as it gives error pop up old sdk.

Tags (2)
0 Kudos
9 Replies
PaulF_IntelCorp
Employee
119 Views

Sorry, the information you're providing doesn't help to understand the issue. Can you provide a screenshot of what you are seeing? Are you trying to build for Android or iOS? Are you trying to install the debug version?

Pruthu_U_
Beginner
119 Views

I am trying to create android app using xdk & phonegapbuild. Sorry not to provide screenshot. in earlier post.  kindly see build query.pptx with instructions or screenshot of error as CLI displayed is 6.2 in all circumstances.

551864

 

551864Getting error in debug.apk and release.apk_. Please Help!.png

Pruthu_U_
Beginner
119 Views

 

i know process is right what is mentioned in xdk instructions as i have previously  created this apps using same steps.

1)https://play.google.com/store/apps/details?id=com.mumbaimarketmojos.boisar&hl=en

2)https://play.google.com/store/apps/details?id=com.hotelsorts.atlanta&hl=en

But this time i am facing this new error.

 

 

 

 

 

Getting error in debug.apk and release.apk_. Please Help!-2.png

 

PaulF_IntelCorp
Employee
119 Views

Pruthu U. wrote:

I am trying to create android app using xdk & phonegapbuild. Sorry not to provide screenshot. in earlier post.  kindly see build query.pptx with instructions or screenshot of error as CLI displayed is 6.2 in all circumstances.

Your config.xml file looks like it is incomplete. Are you using the "Cordova Build Package" export tool on the Build tab to create a ZIP file for use with PhoneGap Build? Please do that, first. If you can successfully build an APK using PhoneGap Build via the Build tab export tool, then you can proceed from there.

It is not strictly required that you change to CLI 6.5, first get everything working with 6.2, then you can consider moving to 6.5. Please also see this post > https://software.intel.com/en-us/forums/intel-xdk/topic/735296 < for additional help.

Pruthu_U_
Beginner
119 Views

Hi Paul,

Sorry for late response. I am only creating android application so i delete ios part. if you feel i have incomplete config.xml what part i am missing. 

I will retry to create app. just for your understanding i use onesignal for pushnotification  and basic html5 files to make application. i will ask you for correct step as its very crucial for my project to make app. I used same steps to create below app.

https://play.google.com/store/apps/details?id=com.mumbaimarketmojos.boisar&hl=en

If you feel my config.xml is wrong please guide me , as i will recreate Bogota app. Please show me once so i can replicate in other apps.

What all screenshots would you require for me to send you for next mail, so you can show my mistake.

 

with regards

 

Pruthu

Pruthu_U_
Beginner
119 Views

config.xml which i used now has same result it say older sdk. Why my .apk file is saying older sdk.
 
<!-- Change the debuggable preference to true to build a remote CDT debuggable app for -->
<!-- Crosswalk apps on Android 4.0+ devices and Cordova apps on Android 4.4+ devices. -->
<preference name="debuggable" value="false" />
<!-- IMPORTANT: set the debuggable preference to false before you build for the store! -->

<!-- 'value' = number of milliseconds to display the splash screen in a Cordova build. -->
<!-- This preference only affects Cordova builds for Crosswalk and Android. -->
<!-- <preference name="SplashScreenDelay" value="2000" /> -->

<platform name="ios">
  <!-- below requires the splash screen plugin -->
  <!-- docs: https://github.com/apache/cordova-plugin-splashscreen -->
  <preference name="AutoHideSplashScreen" value="true" />
  <preference name="FadeSplashScreen" value="false"/>
  <preference name="FadeSplashScreenDuration" value="2"/>
  <preference name="ShowSplashScreenSpinner" value="false"/>

  <!-- below requires the status bar plugin -->
  <!-- docs: https://github.com/apache/cordova-plugin-statusbar -->
  <!-- see http://devgirl.org/2014/07/31/phonegap-developers-guid -->
  <preference name="StatusBarOverlaysWebView" value="false" />
  <preference name="StatusBarBackgroundColor" value="#000000" />
  <preference name="StatusBarStyle" value="lightcontent" />
</platform>

<platform name="android">
  <!-- below requires the splash screen plugin -->
  <!-- docs: https://github.com/apache/cordova-plugin-splashscreen -->
  <preference name="SplashMaintainAspectRatio" value="false" />
  <gap:plugin name="onesignal-cordova-plugin" spec="^2.0.10" source="npm" />

<!--Requires cli-5.1.1+ for gradle Android but we recommend using the latest version. -->
<preference name="phonegap-version" value="cli-6.4.0" />
<preference name="android-build-tool" value="gradle" />
</platform>

<!-- use this feature to add command-lines to be used by Crosswalk builds on device -->
<!-- see http://peter.sh/experiments/chromium-command-line-switches/ for complete list -->
<intelxdk:crosswalk xwalk-command-line="--disable-pull-to-refresh-effect" />
<!-- ignore gpu blacklist for larger collection of gpu accelerated devices -->
<intelxdk:crosswalk xwalk-command-line="--ignore-gpu-blacklist" />

 

 

Pruthu_U_
Beginner
119 Views

Hi Paul is their any way i can send you .apk which is saying older sdk , why it says older sdk ... i use phonegap build to process app. please help. is their any mistake on my part.

 

thanks and sorry to bother you.

PaulF_IntelCorp
Employee
119 Views

Pruthu U. wrote:

Sorry for late response. I am only creating android application so i delete ios part. if you feel i have incomplete config.xml what part i am missing. 

There is no need to delete the iOS part of the config.xml, the <platform name="ios"> section tells Cordova (and PhoneGap Build) to only apply the preferences contained within to an iOS build.

The reason I say your config.xml is incomplete is because it is missing the <widget> tag and some other crucial bits. It looks to me like you are using an intelxdk.config.additions.xml file as your config.xml. You can add tags, like those you're showing, into the additions file, but you have to use the Cordova Build Package tool on the Build tab to create a proper config.xml. If you are renaming the intelxdk.config.additions.xml file to config.xml it will not work.

Perhaps I misunderstand what you are doing.

Pruthu U. wrote:

Hi Paul is their any way i can send you .apk which is saying older sdk , why it says older sdk ... i use phonegap build to process app. please help. is their any mistake on my part.

You are probably getting the "older sdk" message because of one of the plugins you are using. Getting that message is not a problem, it is a warning. It should not prevent your app from being built or from running.

BTW -- that <gap:plugin name="onesignal-cordova-plugin" spec="^2.0.10" source="npm" /> notation has been deprecated by PhoneGap Build, because Cordova CLI now offers an equivalent format. The config.xml file we generate, when you use the "Cordova Build Package" tool, emits the current version for that tag. You can use the XDK plugin management tool to add your plugin and the correct <plugin> tag will be in the config.xml that is generated.

See this doc for help > https://software.intel.com/en-us/xdk/docs/build-xdk-app-with-phonegap-cordova-cli < with creating a project that can be built using PhoneGap Build.

Pruthu_U_
Beginner
119 Views

Hi Paul ,

 

 

Thanks for your support & guidance, I will work on this project to make it work. thanks for your guidance. i like intel xdk, i will try few more time how i can get it correct. 

with gratitude 

Pruthu

 

Reply