Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Raiden_D_
Beginner
166 Views

phonegap-plugin-push build failed

Hi!

I created a new blank project, and i tried build it, but it not was success. (I attached error log)

I used this plugin: https://github.com/phonegap/phonegap-plugin-push
(and defaults: StatusBar, Device, SpalshScreen)

What is the problem?

Thank you!

Tags (2)
0 Kudos
13 Replies
Amrita_C_Intel
Employee
166 Views

Hi,

Include this URL in github repo: https://github.com/phonegap/phonegap-plugin-push.git#1.2.1

This is different version and now build it.

Anusha_M_Intel1
Employee
166 Views

There is some incompatibility with the current version of the push plugin. Version 1.2.1 works well with the XDK. 

Raiden_D_
Beginner
166 Views

Thanks!

I deployed and tried but not works on every kind of phone. This could be a phone or a plugin problem? Or an option promblem on phone?

Does work:
Samsung Galaxy Note 3 (android version: 5.0)
Xiaomi redmi note 4g (android version: 4.4.2)

Doesn't work:
Doogee DG700 Titans 2 (android version: 5.0)
Lenovo P-70 (android version: 4.4.4)"

PaulF_IntelCorp
Employee
166 Views

My suspicion is this is a phone problem. I think the plugin you are using requires some Google-specific libraries (I'm not positive). There are many Asian phones that are built without the necessary libraries to support Google services, because doing so requires a special license agreement with Google. A tip-off to such phones is whether or not they include the Google Play Store app.

If they DO NOT include the Google Play Store app, then they are phones that probably fit this profile. Is that the difference between the phones in the "does work" category and those in the "doesn't work" category?

Raiden_D_
Beginner
166 Views

Thank you for answer! It is device problem, but all phone includes Google Play Store :-/

Raiden_d_1
Beginner
166 Views

Hi!

Why it can't update newer version than 1.2.1 (https://github.com/phonegap/phonegap-plugin-push)? I need the newest version because of some new functions. Thanks the answer!

Luigi_Cama
Beginner
166 Views

You can change the version of the plugin directly from XDK project.
You can use up to version 1.4.3 with Cordova 5. The upgrade versions contain Gradle script not supported (we have to wait Cordova 6.0.0).

Bye.

Raiden_d_1
Beginner
166 Views

With the 1.4.3 version, the debug module always get an error, but with the 1.2.1 version work. Why?

PaulF_IntelCorp
Employee
166 Views

Raiden D. wrote:

Thank you for answer! It is device problem, but all phone includes Google Play Store :-/

Unfortunately, all phones do NOT include access to the Google Play Store. Many Asian phones do not include the Google services parts that are needed. The Android project is free and open source, but the parts that are needed to access Google services (such as the Google Play Store, Google Drive, etc.) are not free and open. In order to include those parts in a phone (or tablet) the device manufacturer has to sign an agreement with Google. Many Asian devices have their own store and do not have an agreement with Google, so they do not have access to any Google services.

PaulF_IntelCorp
Employee
166 Views

Raiden d. wrote:

With the 1.4.3 version, the debug module always get an error, but with the 1.2.1 version work. Why?

The current debug module builder is based on the "old" Crosswalk build system, which is like the CLI 4.1.2 build system. We are in the process of upgrading the debug module builder as part of the next major release. In the meantime, it has this limitation. In order to debug such an app, that you cannot build with the Debug tab, you have two options:

Raiden_d_1
Beginner
166 Views

Thanks for your answers!

Aahedi
Beginner
166 Views

I use this https://github.com/aahedi/PushPlugin

type in ID 

com.phonegap.PushPlugin

intelxdk.config.android.xml: add in git repo to #2.4.0 version like this 

<intelxdk:plugin intelxdk:name="PushPlugin" intelxdk:value="https://github.com/aahedi/PushPlugin.git#2.4.0"/>

 

PaulF_IntelCorp
Employee
166 Views

Please add it using the plugin explorer on the Projects tab. See the documentation for details > https://software.intel.com/en-us/xdk/docs/add-manage-project-plugins

Reply