Community
cancel
Showing results for 
Search instead for 
Did you mean: 
David_K_6
Beginner
55 Views

phonegap-plugin-push fails to build for iOS - how to set cordova-ios version?

Jump to solution

I've had various problems getting phonegap-plugin-push to build.

If I add it from the "Featured Plugins" section, I get a panel saying "Missing required variables". Pressing OK merely leads to a pause, a "Fetching, please be patient" and a return to the "Missing required variables" panel. By the way, the relevant variable (SENDER_ID) is not listed in the panel.

If I add it from the Cordova plugin registry, the relevant variable *is* listed and I can fill it in and install the plugin at its default version (1.6.2).

However, it fails to build for IOS, with the simple message: Error: Plugin PushPlugin failed to install/

If I back the plugin off to version 1.4.3, it builds OK.

The plugin author says that the current version of the plugin requires cordova-ios 4.x or later, whereas my build log says that I am using cordova-ios 3.8.0.

Is it possible to specify the version of cordova-ios, and if so, how do I do this? And can I set it to 4.x?

Thanks

Tags (2)
0 Kudos
1 Solution
Rakshith_K_Intel
Employee
55 Views

In build setting for iOS, change the Cordova CLI version to 5.4.1, this will use Cordova-iOS v4.0.1 to build.

This CLI 5.4.1 option is available in XDK 3088

View solution in original post

2 Replies
Rakshith_K_Intel
Employee
56 Views

In build setting for iOS, change the Cordova CLI version to 5.4.1, this will use Cordova-iOS v4.0.1 to build.

This CLI 5.4.1 option is available in XDK 3088

View solution in original post

David_K_6
Beginner
55 Views

Hi Rakshith

I've tried this and it does work, thank you, although at a cost: going to 5.4.1 means that iOS 7 and below are no longer supported.

We've got a small number of users still on iOS 7, but I guess I'll have to live with it.

Thanks for your help

Reply