Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
17 Views

xdk issue when not building for crosswalk

Hi,

There is an issue in the xdk (build 3759) when I want to build apk without crosswalk.

My project has "Optimize with Crosswalk" checkout but in the build tab I have a note that some values have errors and not to fix it in the project details.

It took me some time and the issue is with crosswalk. I needed to check "Optimize with Crosswalk" and below choose crosswalk version 19 (was marked 18 with a note that there is a security risk). Now I can uncheck "Optimize with Crosswalk" and the build tab doesn't report any error.

So the build tab is checking the crosswalk version even though "Optimize with Crosswalk" is checked out.

Thanks,

Roi

 

Tags (2)
0 Kudos
4 Replies
Highlighted
17 Views

Roi -- thanks for that heads up. The orange (!) symbol simply indicates a warning (although, in the scenario you describe it is a false warning). When the orange (!) symbol is present it does not prevent you from performing a build, but it can be confusing. I will file a bug regarding this confusing point.

0 Kudos
Highlighted
New Contributor I
17 Views

Note that it's not just false positive of the warning indicator. XDK actually doesn't let me execute the build process until I fix the version even though crosswalk is checked out. so I needed to check crosswalk, change version, uncheck crosswalk just so XDK will let me execute the build process.

 

 

 

0 Kudos
Highlighted
17 Views

Odd, in my experiment I was able to leave the Crosswalk version (!) warning icon on the Build Settings page, uncheck the optimize, and still do a build. I did my build with CLI 6.2.0, not sure if that makes any difference for you. I only attempted an Android build.

0 Kudos
Highlighted
New Contributor I
17 Views

you are right. I checked again. what I was doing before is probably just going over with the mouse and seeing the msg that I have an issue and need to fix it. but I can do the build.
so it's just a display issue as you said.

thanks

0 Kudos