Community
cancel
Showing results for 
Search instead for 
Did you mean: 
BMose1
Beginner
3,377 Views

Intel ProSet Drivers (14.8.16.1063 - 04/10/2017) and CM_DEVCAP_REMOVABLE capabilities flag

Hello Community,

I am installing these drivers for AHCI operation on an Asus Q87M motherboard in Windows 10 LTSB 1607. Upon installing the drivers I see that the USB "safely remove device" icon shows up in the system tray for the boot drive (C:\). I am unable to disable HotPlug in the BIOS/UEFI for this particular port (otherwise this would be a non-issue). It appears that the Intel RST drivers set the CM_DEVCAP_REMOVABLE flag to 1 because I don't see this flag set if I let the Microsoft standard drivers get installed during the Windows installation process. This leads me to believe that the Intel RST ProSet drivers must be setting this flag. From research I have found where in the registry this value/flag resides and I have been able to change it and see the systemtray icon go away, however, upon a restart it comes back. This tells me that Windows must be polling the iaStorA drivers on every boot. So my question is, is there a place anywhere in some configuration files where I can specify the drivers to not set this flag during ProSet driver installation process? I have looked in the "64bit" folder where the drivers and .inf files reside and the iaAHCIC.inf looks like the kind of place one would specify something like this but don't see this setting distinctly in this file.

In short I'm trying to force-disable the removability of the SATA connected device without using the BIOS/UEFI settings (because they are not available).

Any information would be greatly appreciated.

Thank you!

Message was edited by: Benjamin Moses

 

I wrote:

This tells me that Windows must be polling the storahci drivers on every boot.

 

 

But I meant:

 

This tells me that Windows must be polling the iaStorA drivers on every boot.
0 Kudos
7 Replies
idata
Community Manager
1,047 Views

Hello BenMoses,

 

 

I understand you are trying to disable hot plug for the C: drive.

 

 

Let me apologize for any inconvenience this issue may be causing to you.

 

 

In order to help you better I would like to gather more information about the configuration you have in the computer. Please attach to this thread the .txt file the Intel® System Support Utility will generate https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility

 

 

Please also attach the System Report. This link will show you how to generate it https://www.intel.com/content/www/us/en/support/technologies/000006351.html https://www.intel.com/content/www/us/en/support/technologies/000006351.html

 

 

To attach a file, you must click "Use Advanced Editor" on the upper right hand corner of the response box, then the "attach" option will appear on the bottom right hand corner of the response box.

 

 

Regards,

 

Fred D.
BMose1
Beginner
1,047 Views

Hi Fred,

Thank you for your prompt attention and clear instructions.

I am including the report files you have instructed me to include, the SSU.txt and the System Report.

Just to re-iterate, I am looking for a way to use registry keys such as or similar to "TreatAsInternalPort" or "IgnoreHotPlug" with the Intel RST drivers (iaStorA). These keys can be created and used with Microsoft's general driver (storahci) from the research I've found. I hope this description helps in explaining what I'm trying to do.

Thank you,

Ben

idata
Community Manager
1,047 Views

Hello BenMoses,

 

 

Thanks for the information you sent to me.

 

 

What happens is that there is no specific registry setting we can provide to disable hot plug.

 

 

What I can recommend is installing the Intel RST version ASUS* has validated for your specific motherboard model. You can download it from this link http://dlcdnet.asus.com/pub/ASUS/misc/sata/RAID_AHCI_Win7-8-81-10_V13101058_V14501081.zip http://dlcdnet.asus.com/pub/ASUS/misc/sata/RAID_AHCI_Win7-8-81-10_V13101058_V14501081.zip

 

 

Please uninstall current Intel RST version from Programs and Features in Control Panel, restart the computer, and then reinstall Intel RST version I provided.

 

 

Let me know if issue persists or not.

 

 

Regards,

 

Fred D.
BMose1
Beginner
1,047 Views

Hi Fred,

I did try installing the Asus RST version, to no avail.

I am checking to see how the RST drivers handle the HotPlug flag from the BIOS/UEFI for the other 5 SATA ports.

I believe the RST drivers are doing the right thing and are not at fault, I was just wondering if there was a way to disregard the HotPlug enable flag from the BIOS/UEFI via the RST drivers. There seems to be a direct correlation between the HotPlug being enabled in the BIOS/UEFI and the CM_DEVCAP_REMOVABLE being applied to the drive by, I assume, the RST drivers. And this would be totally appropriate behavior for the drivers.

I'll let you know what I find out.

Thanks again!

BMose1
Beginner
1,047 Views

Ok I tested the BIOS's HotPlug settings for the 5 regular SATA ports that are controllable for HotPlug feature. I used 3 different drive types.

1. Kingston SMS200S3/60G - 60GB mSATA fitted into a mSATA to SATA carrier (so I could plug it into one of the 5 regular SATA ports)

2. SanDisk 2.5" X110 SD6SB1M-064G-1022I SSD 64GB

3. Western Digital WD2503ABYX 250GB spinner drive

Installed Windows 10 LTSB on each of these drives connected to SATA port 1.

Restarted the system changing the HotPlug setting in the BIOS for SATA port.

Observed that the "Safely Remove Hardware" icon appeared in the system tray when HotPlug was enabled in the BIOS.

Observed that the "Safely Remove Hardware" icon did not appear in the system try when HotPlug was disabled. in the BIOS.

So, it appears that the RST drivers are working as expected and are directly correlating the BIOS feature with the CM_DEVCAP_REMOVABLE flag which, in turn I believe, causes Windows to display the "Safely Remove Hardware" system tray icon.

Concluding, it appears that there is no way to force the RST drivers to disregard the HotPlug setting in the BIOS and force the state to a disabled state so that Windows does not set the CM_DEVCAP_REMOVABLE flag. Is this statement true, Fred?

I will have to search for an alternative way of disabling this flag.

Thanks again for your support

-Ben

idata
Community Manager
1,047 Views

Hello BenMoses,

 

 

Correct, it is not possible to force Intel RST drivers to disregard the hot plug setting you set in the BIOS.

 

 

What I can recommend is contacting ASUS* so they can check if there is or not any other troubleshooting step that can be performed. This link will give you their contact information https://www.asus.com/us/support/ https://www.asus.com/us/support/

 

 

Regards,

 

Fred D.
BMose1
Beginner
1,047 Views

Thanks Fred.

I believe I've root caused the issue. I installed a previous version of the BIOS (Custom from Asus) where the HotPlug settings were all disabled by default (including the non-controllable mSATA port) and found that the "Safely Remove Hardware" icon does not show up in the system tray. In a later BIOS (The one I've been working with), they (Asus) had set the HotPlug flags to 1 across the board, leaving the non-controllable mSATA port also set to 1.

We are in the process of contacting Asus. We have a working business relationship with them.

thanks again for all of your Support.

-Ben

Reply