Community
cancel
Showing results for 
Search instead for 
Did you mean: 
David_B_24
Beginner
42 Views

Code Coverage Generation

I have a large live Fortran solution which I periodically build with Code Coverage switched on by setting /Qcov-gen in a special copy of ifort.cfg file used for the purpose.

I want to disable some of the projects from the Code Coverage statistics and so I tried the documented option /Qcov-gen- in the Fortran project command line properties. Unfortunately this generated the following message for each source file:

ifort: command line warning #10006: ignoring unknown option '/Qcov-gen-'

How can I disable individual projects in my solution from being included in the Code Coverage report?

0 Kudos
3 Replies
Patrick_F_Intel1
Employee
42 Views

Hello David,

If you post your code to the compiler forums, you'll probably get better, quicker responses.

Maybe try Intel® Visual Fortran Compiler for Windows*  or Intel® Fortran Compiler for Linux* and Mac OS X*

Pat

Pat

Patrick_F_Intel1
Employee
42 Views

I meant to say "if you post your questions" to the compiler forums.

David_B_24
Beginner
42 Views

OK, thanks. I'll try and find the correct forum.