Community
cancel
Showing results for 
Search instead for 
Did you mean: 
348 Views

Intel Power Gadget not installing on MacOS 10.13.1 High Sierra

Hi,

I tried to install the Intel Power Gadget and I got the following error. I am on the latest stable release of MacOS High Sierra on a fairly clean/new install. Is this something known? EDIT: typo fix

Nov 14 09:41:48 Michels-MacBook-Pro installd[2126]: PackageKit: ----- Begin install -----
Nov 14 09:41:50 Michels-MacBook-Pro installd[2126]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “Install Intel Power Gadget.pkg”." UserInfo={NSFilePath=./postinstall, NSURL=file://localhost/Volumes/Intel%C2%AE%20Power%20Gadget/Install%20Intel%20Power%20Gadget.pkg#Intel%20Power%20Gadget%20Driver%20(%3E=10.9).pkg, PKInstallPackageIdentifier=com.intel.pkg.PowerGadget.driver, NSLocalizedDescription=An error occurred while running scripts from the package “Install Intel Power Gadget.pkg”.} {
    NSFilePath = "./postinstall";
    NSLocalizedDescription = "An error occurred while running scripts from the package \U201cInstall Intel Power Gadget.pkg\U201d.";
    NSURL = "file://localhost/Volumes/Intel%C2%AE%20Power%20Gadget/Install%20Intel%20Power%20Gadget.pkg#Intel%20Power%20Gadget%20Driver%20(%3E=10.9).pkg";
    PKInstallPackageIdentifier = "com.intel.pkg.PowerGadget.driver";
}
Nov 14 09:41:50 Michels-MacBook-Pro Installer[75644]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
Nov 14 09:41:50 Michels-MacBook-Pro Installer[75644]: Displaying 'Install Failed' UI.
Nov 14 09:41:50 Michels-MacBook-Pro Installer[75644]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.
0 Kudos
1 Reply
348 Views

Ok, a solution was found.

A better message about allowing Intel Power Gadget to be loaded in the Security&Privacy preference panel should be added.

See discussion here:https://github.com/caskroom/homebrew-cask/issues/40755#issuecomment-344400968

Reply