Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Michael_M_15
Beginner
277 Views

Package C-State PC6/PC7 on Linux

Hi,

I have an i5 4590T processor, I'm running Ubuntu Linux. The package c-state never goes above pc3. I've searched all over for a solution, and tried all of the suggestions I've found, but none of them work.

I've set all of the Tunables in PowerTOP to good. I've enabled ASPM. It's enabled on all of the PCI devices:

lspci -vvvv | grep ASPM
		LnkCap:	Port #1, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <1us, L1 <4us
		LnkCtl:	ASPM L0s L1 Enabled; RCB 64 bytes Disabled- CommClk-
		LnkCap:	Port #4, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <512ns, L1 <16us
		LnkCtl:	ASPM L0s L1 Enabled; RCB 64 bytes Disabled- CommClk+
		LnkCap:	Port #5, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <512ns, L1 <16us
		LnkCtl:	ASPM L1 Enabled; RCB 64 bytes Disabled- CommClk+
		LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s unlimited, L1 unlimited
		LnkCtl:	ASPM L0s L1 Enabled; RCB 64 bytes Disabled- CommClk+
		LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <4us, L1 <32us
		LnkCtl:	ASPM L0s L1 Enabled; RCB 64 bytes Disabled- CommClk+

I've turned the monitor off with DPMS.

The cores are all 99% c7 but the package c-state remains at pc3:

Core     CPU Avg_MHz   %Busy Bzy_MHz TSC_MHz     SMI  CPU%c1  CPU%c3  CPU%c6  CPU%c7 CoreTmp  PkgTmp Pkg%pc2 Pkg%pc3 Pkg%pc6 Pkg%pc7 PkgWatt CorWatt GFXWatt
       -       -       1    0.15     952    2000       0    0.06    0.01    0.00   99.79      34      35    0.11   99.15    0.00    0.00    3.33    0.01    0.00
       0       0       1    0.14     866    2000       0    0.05    0.00    0.00   99.81      33      35    0.11   99.15    0.00    0.00    3.33    0.01    0.00
       1       1       2    0.16    1018    2000       0    0.10    0.00    0.00   99.75      32
       2       2       1    0.15     953    2000       0    0.04    0.03    0.00   99.77      32
       3       3       1    0.13     963    2000       0    0.05    0.00    0.00   99.82      34

Am I missing something? Is there a way to find out what is stopping it going above pc3? Any suggestions would be appreciated.

Thanks,

Michael

0 Kudos
3 Replies
Roman_D_Intel
Employee
277 Views

Hi Michael,

did you check BIOS options? BIOS could have an option to disable (deeper) power saving C-states.

Thanks,

Roman

Roman_D_Intel
Employee
277 Views

which Linux kernel version are you running? 

Michael_M_15
Beginner
277 Views

Hi Roman,

I'm running kernel 3.19. I tried some earlier kernels too - I think 3.5.

There are no BIOS options for the package c-states. There are just options for the c-states - which are all enabled. The motherboard is a Gigabyte GA-H97N-WIFI.

If you have any suggestions, I'll try them!

Thanks,

Michael

 

Reply