Wireless
Issues related to Intel® Wireless Adapters and technologies
6174 Discussions

6 GHz Wifi with AX210 and Ubuntu 20.04

Mergu
Beginner
6,544 Views

Hi,

i am currently using Ubuntu 20.04 LTS with kernel 5.14.8 and I want to connect my AX210 with my 6 GHz wifi. The router I am using is the Asus ROG Rapture GT-AXE11000. I downloaded the Intel driver iwlwifi-ty-59.601f3a66.0 which can be found here (https://www.intel.de/content/www/de/de/support/articles/000005511/wireless.html).

As described in the README, I checked whether CONFIG_FW_LOADER is supported by looking in my kernel`s config.

After "installing" the driver and looking at dmesg I am able to see that the driver is loaded correctly without any errors and the wifi card is identified:

iwlwifi 0000:04:00.0: loaded firmware version 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm

iwlwifi 0000:04:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420

Still I am only able to find and connect to my 2.4 GHz and 5 GHz wifi signal - no sight of the 6 GHz channels. I already measured whether my router sends in the 6 GHz range (which it obviously does) and set the used channel to channel 37 because I read somewhere that this channel is most likely to be found.

 

Has somebody already experience with this issue /  is it a common issue?

Thank you in advance! Looking forward to your replies.

0 Kudos
1 Solution
Spacefish
New Contributor I
6,195 Views
No, the AX210 automatically determines that you are in Germany and selects this regulatory profile. The card derives this info from beacon frames it receives from nearby APs (country is part of the beacon frame). This behavioir can't be override from software / operating system.

If you want to put it into US mode, put it into a cellar with only one AP which is set to US. But it will switch back to Germany once it receives beacon frames with DE as county code again.

View solution in original post

8 Replies
David_G_Intel
Moderator
6,413 Views

Hello Mergu


Thank you for posting on the Intel️® communities. We are currently working on this request, the updates will be posted on the thread.


Regards, 

David G 

Intel Customer Support Technician 


Mergu
Beginner
6,390 Views

Hello David

 

Thank your for looking into it!

I was busy in the meanwhile: I got a newer AX210 driver (iwlwifi-ty-a0-gf-a0-63.ucode) which now allows me the usage of the iwlwifi-ty-a0-gf-a0.pnvm without timing errors (with the -59 driver I removed the .pnvm file from /lib/firmware to avoid these errors). Still I am not able to see the 6GHz Wifi.

I also tried iNet wireless daemon (iwd) instead of wpa_supplicant but this also wasn`t helpful.

 

Parallel to Ubuntu I am using Windows on another machine. I subscribed to the Windows Insider Program, upgraded to 21H1 and got the latest AX210 driver. With Windows I get the same result: I can connect to the 2.4 GHz and 5 GHz wifi but I can`t see the 6 GHz wifi. I checked in the Registry Editor whether the parameter Is6GhzBandSupported is set.

Since Windows only supports OWE and Ubuntu (as far as I know) OWE and WPA3, I set my 6 GHz wifi to OWE. The distance between client and router is about 1.5 meters.

In addition to that I manually entered the SSID of my 6GHz wifi (as a so-called "hidden network") on both systems but they are still not able to connect.

 

Kind Regards!

Mergu

Spacefish
New Contributor I
6,285 Views

They probably did not enable the 6GHz Bands in their firmware embeeded regulatory DB.. At least in germany they did not do it yet. The intel properitary regulatory db lags behind the linux wireless-regdb by a long time typically.. Hopefully intel will make these updates somehow quicker in the future / we find a way to send the card into certification mode to manually set all these parameters.
There is an int32 "password" in the fimrware interface to enable certification mode, so it can probably brute-forced some day.

David_G_Intel
Moderator
6,273 Views

After checking the information provided, here are some details that might be helpful for you:

  • The Wi-Fi 6E/6GHz enablement in Linux-based operating systems is still in integration/validation phase. It might not work yet.
  • As the user above mentioned, the use of the 6GHz band may be prohibited by regulatory bodies in your country or might not be enabled on your platform by the system manufacturer. You can find more information in our article:

Be aware that the use of the 6GHz band may be prohibited by regulatory in your country or might not be enabled on your platform by the system manufacturer. Please also make sure to check with the system manufacturer if this is supported.


Regards, 

David G 

Intel Customer Support Technician 


Mergu
Beginner
6,242 Views

Thank you David and Spacefish! But that's kind of annoying since Germany enabled the 6 GHz band for wifi a few months ago.

I also tried setting up a new Ubuntu 21.04 without network connection. Therefore the machine set the default region to USA. Still I can't connect to the 6 GHz wifi. Shouldn't that work?

Spacefish
New Contributor I
6,196 Views
No, the AX210 automatically determines that you are in Germany and selects this regulatory profile. The card derives this info from beacon frames it receives from nearby APs (country is part of the beacon frame). This behavioir can't be override from software / operating system.

If you want to put it into US mode, put it into a cellar with only one AP which is set to US. But it will switch back to Germany once it receives beacon frames with DE as county code again.
Mergu
Beginner
6,134 Views

Thanks again! After removing the cooling body of my Wifi card I was able to remove the UFL connectors to the AX210. Afterwards I was able to only see my Wifi signal - with the 6 GHz channels. Of course with very weak signal strengths and low performance.

I am now setting up a network in an EMI chamber to do further tests.

David_G_Intel
Moderator
5,999 Views

We are glad to know you found a solution, since the thread is solved we will close it now.  

Please keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding.  


Best regards,  

David G  

Intel Customer Support Technician


Reply