Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
16,504 Views

AC 7260 frequent ping spikes

Anyone has had issues with this card? I cant seem to get rid of the regular and frustrating ping spikes. Im on Windows 7, running a Dell Precision 3800 laptop. I'm on an ASUS AC68U router, though Ive tried others with the same result. Ive also tried different driver versions and even reformatted my system to no avail. Anyone know whats going on? The collective knowledge of the internet seems rather divided and inconclusive on this matter despite my scouring of its depths over the last few days. Its definitely something to do with the wireless card. I just dont know what.

Here is the results I get when I ping my router. As you can see its sitting pretty dandy at 1ms and then it suddenly decides to explode to some ridiculous number for a second or two then it goes back to normal again.

Pinging 192.168.1.1 with 32 bytes of data:

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=2ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=160ms TTL=64

Reply from 192.168.1.1: bytes=32 time=80ms TTL=64

Reply from 192.168.1.1: bytes=32 time=2ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=2ms TTL=64

Reply from 192.168.1.1: bytes=32 time=2ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=190ms TTL=64

Reply from 192.168.1.1: bytes=32 time=109ms TTL=64

Reply from 192.168.1.1: bytes=32 time=82ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=2ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=3ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Reply from 192.168.1.1: bytes=32 time=80ms TTL=64

<span style="color: # 333333; font-family: Verdana, Arial,...

Tags (1)
78 Replies
tvete
Valued Contributor II
4,109 Views

I would guess that your neighbor has a device that operates on 5 GHz that interferes with your WiFi. 5 GHz interference isn't too common even in RF congested areas unless your neighbor is using 5.8 GHz home phone for example.

I just tested mine and only got exactly 1 random spike to 44ms (probably router is busy as I have other 5 GHz devices streaming internet at the same time as I'm doing this test) so I don't consider that it's wireless card fault unless yours is a hardware fault

idata
Community Manager
4,109 Views

Thanks for the reply. I actually just checked, and my 5Ghz spectrum is dead empty (unlike the 2.4Ghz which is really full). Both give me similar ping issues. Ive also tried this at my girlfriends house on her router to the same effect. Ive got another laptop which I upgraded with the same card. After the upgrade it gives me similar issues.

tvete
Valued Contributor II
4,109 Views

Make sure to set every power management options to high performance. However, I don't ever need to do this on my laptop. In fact, the ping test that I did was on the default balanced power plan.

I'm probably thinking it's a hardware issue if it happens on multiple locations. I would say (not a fact of course) that you just got a bad batch of 7260s like from many previous posts here.

idata
Community Manager
4,109 Views

Thanks for the advice. Didn't help though. Gonna see if I can get the replaced. Definitely a hardware issue because all the rest of the computers in my house run perfect on the router.

Kevin_M_Intel
Employee
4,109 Views

Let us know.

XReid
Beginner
355 Views

Hello,

After doing a bit of research, the ping spikes are caused when the wireless card scans for networks. I was actually able to reproduce the issue and can confirm this. You can do so yourself.

Go to cmd, type ping www.google.com -t

If you're on Windows 8 or 8.1, all you need to do is access the wireless network list by clicking on the wireless icon on the bottom right and it will automatically refresh. For those on Windows 7, click the wireless icon on the bottom right and click on the refresh button next to your connected network. As you are doing this, you'll notice that the ping counter on the command prompt will spike up. I thought it was an issue with the card as well and I was wondering about getting a replacement as well. It can be ridiculously annoying for gaming. It seems as though Windows likes to re scan for networks periodically causing random lag spikes. If there was a way to stop scanning while you're connected to a network, that would be great.

UPDATE: Oh boy, I was able to find a solution. It involves using the Registry Editor. Be careful not to change anything else except for the things that are listed.

1. Open Registry Editor (Windows 8/8.1, right click where Start button was, click Run, type regedit. Windows 7, click Start, click Run, type regedit)

2. Head to 'HKEY_LOCAL_MACHINE \ System\ CurrentControlSet \ Control \ Class \ {4d36e972-e325-11ce-bfc1-08002be10318} [Be sure to expand the 4d36e.... folder]

 

3. Inside will be a number of folders named 0000, 0001, 0002, etc. Look through all these folders until you get one that says Intel(R) Dual Band Wireless-AC 7260 in the registry.

 

4. Once the device has been found, search for a value called ScanWhenAssociated.

 

5. If you see this value, set it to 0 on hexadecimal. If you don't see the value, click edit from the top, select new, and click DWORD (32-bit) value. Rename this value to ScanWhenAssociated (exactly as shown). Make sure this value is set to 0 on hexadecimal.

 

6. Restart the computer. This is important. The changes won't take effect unless you do.

 

I rebooted and tried using cmd to ping google.com. I refreshed the networks and PRESTO! There were no more lag spikes!!! Try it out yourself. I'll give this a couple more days of testing. Big thanks to Lenovo for the guide: https://forums.lenovo.com/t5/Windows-8-and-8-1/SOLUTION-latency-spikes-and-network-unstability-on-In... [SOLUTION] latency spikes and network unstability ... - Lenovo Community

 

 

 

<span style="font-weight: inherit; font-style: inherit; font-size: 12px; font-family: ...

MMich22
New Contributor II
355 Views

I'm on Windows 10, everything is updated to the latest driver version.

I do have the 7260 wireless build into my notebook and I get those ping spikes on 2.4GHz and 5GHz. I used hrping to ping google.com and this is what is happening. I tried the ScanWhenAssociated fix, no change. BT is disabled. Any further suggestions? I'm a little dissapointed by the support here since I always hear that I should change settings, update to new driver and so on. I do have problems since ever with this wireless adapter.

 

http://answers.microsoft.com/en-us/windows/forum/windows8_1-networking/intel-wireless-ac-7260-random... http://answers.microsoft.com/en-us/windows/forum/windows8_1-networking/intel-wireless-ac-7260-random...

 

 

Just to be clear here. I do have several wireless devices on the same router and none shows those spikes. So, what should I try next Intel?

Update1:

I opened the wifi settings and the peaks correlate with the update of the wireless networks list. Adding "ScanWhenAssociated" in Windows 10 did not prevent it doing that. Other suggestions?

 

Update2:

I'm pretty sure that issue exist for everyone having this wireless adapter built in their notebooks. The only difference is, the more wireless networks available, the more significant these spikes become.

 

Update 3:

I found a possible solution. Restarting the "WLAN AutoConfig" service seems to help. I can still see spikes from time to time but more on a "several" minute basis instead of a second basis. Still I think the issue is related to the 7260 AC, since searching for wifi networks should not slow down the active connection. I blamed my wifi router for so long, I hope it will forgive me one day

 

MGart1
Beginner
355 Views

when i restarted "WLAN AutoConfig" its okay for 10-12 mins and then again spikes and unplayable... help me please

SKip1
Novice
355 Views

Running Windows 8.1 and have the same issue; lag spikes, even when pinging the router.

Adding ScanWhenAssociated with value 0 didn't work for me, but restarting the WLAN AutoConfig did work indeed. So I'm curious when I'll start seeing the ping spikes again.

Anyone's got a definitive solution?

AKpun
Beginner
355 Views

WTF...I bought the 7260 like a year ago and returned it since I didn't manage to get rid of the ping spikes. Now I have it again with Win10 and intel STILL DIDN'T FIX IT???

I also tried everything, played around with the settings in device manager etc. Nothing helps. Are intel developers even aware of this issue? And I must say the official support in this community should get another work... The normal users are of much more help than the intel staff... recommending things like lowering the resolution in video games, when it's so clear that this is an issue with the adapter/driver... wtf... IS INTEL EVEN AWARE OF THIS ISSUE? Because the staff here surely is acting like they have no idea whatsoever, just writing generic techhelp BS...

Mistakes happen, that's okay, but Intel is handling this issue very very poorly. I will never ever buy an intel wireless adapter in my life again.

MCode
Beginner
4,109 Views

Hi there,

I'm facing the exact same issue.

Were you able to figure out the cause?

Thanks!

VKuma29
Novice
4,109 Views

Hello,

After doing a bit of research, the ping spikes are caused when the wireless card scans for networks. I was actually able to reproduce the issue and can confirm this. You can do so yourself.

Go to cmd, type ping www.google.com -t

If you're on Windows 8 or 8.1, all you need to do is access the wireless network list by clicking on the wireless icon on the bottom right and it will automatically refresh. For those on Windows 7, click the wireless icon on the bottom right and click on the refresh button next to your connected network. As you are doing this, you'll notice that the ping counter on the command prompt will spike up. I thought it was an issue with the card as well and I was wondering about getting a replacement as well. It can be ridiculously annoying for gaming. It seems as though Windows likes to re scan for networks periodically causing random lag spikes. If there was a way to stop scanning while you're connected to a network, that would be great.

UPDATE: Oh boy, I was able to find a solution. It involves using the Registry Editor. Be careful not to change anything else except for the things that are listed.

1. Open Registry Editor (Windows 8/8.1, right click where Start button was, click Run, type regedit. Windows 7, click Start, click Run, type regedit)

2. Head to 'HKEY_LOCAL_MACHINE \ System\ CurrentControlSet \ Control \ Class \ {4d36e972-e325-11ce-bfc1-08002be10318} [Be sure to expand the 4d36e.... folder]

 

3. Inside will be a number of folders named 0000, 0001, 0002, etc. Look through all these folders until you get one that says Intel(R) Dual Band Wireless-AC 7260 in the registry.

 

4. Once the device has been found, search for a value called ScanWhenAssociated.

 

5. If you see this value, set it to 0 on hexadecimal. If you don't see the value, click edit from the top, select new, and click DWORD (32-bit) value. Rename this value to ScanWhenAssociated (exactly as shown). Make sure this value is set to 0 on hexadecimal.

 

6. Restart the computer. This is important. The changes won't take effect unless you do.

 

I rebooted and tried using cmd to ping google.com. I refreshed the networks and PRESTO! There were no more lag spikes!!! Try it out yourself. I'll give this a couple more days of testing. Big thanks to Lenovo for the guide: https://forums.lenovo.com/t5/Windows-8-and-8-1/SOLUTION-latency-spikes-and-network-unstability-on-In... [SOLUTION] latency spikes and network unstability ... - Lenovo Community

 

 

 

 

Here's mine (bold is when I clicked on refresh):

Pinging www.google.com [173.194.46.112] with 32 bytes of data:

Reply from 173.194.46.112: bytes=32 time=25ms TTL=248

Reply from 173.194.46.112: bytes=32 time=27ms TTL=248

Reply from 173.194.46.112: bytes=32 time=26ms TTL=248

Reply from 173.194.46.112: bytes=32 time=25ms TTL=248

Reply from 173.194.46.112: bytes=32 time=26ms TTL=248

Reply from 173.194.46.112: bytes=32 time=24ms TTL=248

Reply from 173.194.46.112: bytes=32 time=26ms TTL=248

Reply from 173.194.46.112: bytes=32 time=146ms TTL=248

Reply from 173.194.46.112: bytes=32 time=121ms TTL=248

Reply from 173.194.46.112: bytes=32 time=34ms TTL=248

Reply from 173.194.46.112: bytes=32 time=25ms TTL=248

Reply from 173.194.46.112: bytes=32 time=25ms TTL=248

Reply from 173.194.46.112: bytes=32 time=29ms TTL=248

Reply from 173.194.46.112: bytes=32 time=270ms TTL=248

Reply from 173.194.46.112: bytes=32 time=237ms TTL=248

Reply from 173.194.46.112: bytes=32 time=157ms TTL=248

Reply from 173.194.46.112: bytes=32 time=25ms TTL=248

Reply from 173.194.46.112: bytes=32 time=27ms TTL=248

Reply from 173.194.46.112: bytes=32 time=27ms TTL=248

Reply from 173.194.46.112: bytes=32 time=26ms TTL=248

Reply from 173.194.46.112: bytes=32 time=25ms TTL=248

Reply from 173.194.46.112: bytes=32 time=26ms TTL=248

Reply from 173.194.46.112: bytes=32 time=431ms TTL=248

Reply from 173.194.46.112: bytes=32 time=119ms TTL=248

Reply from 173.194.46.112: bytes=32 time=36ms TTL=248

Reply from 173.194.46.112: bytes=32 time=80ms TTL=248

Reply from 173.194.46.112: bytes=32 time=33ms TTL=248

Reply from 173.194.46.112: bytes=32 time=26ms TTL=248

Reply from 173.194.46.112: bytes=32 time=26ms TTL=248

Reply from 173.194.46.112: bytes=32 time=26ms TTL=248

Reply from 173.194.46.112: bytes=32 time=28ms TTL=248

Reply from 173.194.46.112: bytes=32 time=25ms TTL=248

Reply from 173.194.46.112: bytes=32 time=24ms TTL=248

Ping statistics for 173.194.46.112:

Packets: Sent = 33, Received = 33, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 24ms, Maximum = 431ms, Average = 67ms

VKuma29
Novice
4,109 Views

Sorry but disabling U-ASPD doesn't do a thing. It is absolutely, ABSOLUTELY atrocious that this wireless card is shipped on so many computers worldwide yet Intel didn't have the time to test the thing correctly.

lstas1
Beginner
4,109 Views

Thank you so much for this Vigz. It's the only solution I've found to be helpful. I have intel 3160 wireless card and now everything works smoothly, without lags and spikes.

I wish there were more people like you, since everyone else just threw some random solutions like changing the power management, increasing aggressiveness or changing channels of the wifi and so on, without even looking checking the problem. You described everything about the problem and solution.

Thank you again!!!

tvete
Valued Contributor II
4,109 Views

stasiek01 wrote:

Thank you so much for this Vigz. It's the only solution I've found to be helpful. I have intel 3160 wireless card and now everything works smoothly, without lags and spikes.

I wish there were more people like you, since everyone else just threw some random solutions like changing the power management, increasing aggressiveness or changing channels of the wifi and so on, without even looking checking the problem. You described everything about the problem and solution.

Thank you again!!!

All Vigz did there was to completely disallow roaming by completely disabling background scanning. Doing this tweak isn't good for those who roam a lot, but almost 99% of WiFi users are stationary so not having roaming capability isn't really a con. BTW, I don't have recurring ping spikes at all without the need to do this tweak. Once the drivers detect streaming, background scanning turns off COMPLETELY.

VKuma29
Novice
4,109 Views

@stasiek01 Wow, so this issue occurs on other Intel Wi-Fi cards too?

I wish I could test using the card on a 5ghz network. Perhaps this problem only occurs on 2.4ghz bands?

@theveterans

It stops scanning when you are connected to a network. When you disconnect from the network, the card will resume scanning for networks in the background hence the term disable ScanWhenAssociated. This tweak does not render network scanning useless.

tvete
Valued Contributor II
4,109 Views

The registry tweak stops background scanning after WiFi connection is associated. You can understand it clearly using the registry entry name "scan when associated" That's why it's bad for roaming since it'll not background scan for a stronger signals in multi-access point setup such as those found in universities, hospitals, etc. You can always manual (not background) scan for a better AP but this registry tweak will render your 7260 like a "sticky client"

Read this stuff to know what I mean: http://www.wifikiwi.com/cwap/a-sticky-problem-wi-fi-clients-that-wont-roam/ A sticky problem – Wi-Fi clients that won't roam | WiFi Kiwi's Blog

In my case, my Intel 7260 on my laptop works without the need to completely disable background scanning. When packet streaming are detected such as gaming, DLNA, Netflix, my Intel 7260 disables background scan completely, eliminating periodic ping spikes that you experience without the registry tweak. Then after packet streaming is done, my 7260 will background scan for to roam for better signals. Refreshing a page will sure cause ping spikes regardless of disabling or enabling background scan. That is an example of drivers working perfectly on my system.

CD5
Beginner
444 Views

Made an account just to thank you for this fix. I scrapped the bottom pits of internet to find a fix, thanks for passing this on !

This is on Windows 8.1.

Cheers Vigz for sharing the solution !

PS: Is this something which happens on Windows 8 onwards or people having the lag spike issue on Windows 7 ? Because if they don't I might want to revert back to Windows 7.

idata
Community Manager
489 Views

Can confirm this works on a Dell XPS 13 9333 with the terrible AC 7260 adapter running Windows 10.0.15063 and 7260 driver version 18.33.5.1 (this driver is needed to prevent frequent disconnects from 5GHz networks). Windows 10 users need to add the key "ScanWhenAssociated" to the registry and reboot.

I had problems with Steam In-Home streaming, games would stutter when being streamed to this laptop. Connecting an ethernet cable fixed this so it was definitely a WiFi problem. Those problems have been fixed now.

Reply