Wireless
Issues related to Intel® Wireless Adapters and technologies
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
6088 Discussions

AC 9560 D2W160 Mhz Code Error 10 after Intel Net update

federicofabbro
Beginner
511 Views

***INTRODUCTION***

 

Hello, I ask for help due to a problem of the network card (WiFi and Bluetooth) of my computer that, although I consider me an experienced user both in terms of software and hardware, I have not been able to solve in any way.

I’m providing a detailed description of all the attempts made for bringing the computer back to normal operation, premising that I could only obtain a partial and temporary result.

 

*** COMPUTER, NETWORK CARD AND PROBLEM SPECIFICATIONS ***

 

The computer model is Asus Zenbook UX480FD purchased in summer 2019.

The network card model is AC 9560 D2W, entirely soldered to the motherboard, so it is not a replaceable type of card.

Hardware IDs are:

WiFi: PCI \ VEN_8086 & DEV_9DF0 & SUBSYS_00008086 & REV_30

Bluetooth: USB \ VID_8087 & PID_0AAA & REV_0000

The network card is not working, detecting an error code 10 in "Device Manager" for both the WiFi network card and the BlueTooth device.

 

*** SOME PREMISES ***

I realized, browsing on eBay, that there are for sale other computer of the same model that suffer from the same problem and that are sold with a network card not working, however the problem seems to be of a software nature.

This is not the first time that driver problems have occurred, in fact I previously had a similar problem with the microphone.

The computer is constantly updated with Windows Update.

The problem occurs for the first time on 07/13/2021, when I turned on the computer that was set in sleep mode the day before (simply by closing the screen down).

Since an internet connection was required for most of the attempts described below, I used a USB WiFi Dongle.

 

*** RESOLUTION ATTEMPTS WITHOUT RESULT ***

- Troubleshooting through Windows which detects the absence of an Ethernet cable as problem, due to the fact that the computer does not even recognize the existence of a wireless network card, but only a LAN one. A system restart is carried out.

- Disabling and re-enabling problematic devices in "Device Manager" with and without system reboot.

- Uninstallation of both devices by deleting the driver software in "Device Manager" with system restart.

- Reinstalling the latest drivers found in Windows Update.

- Reinstalling the latest drivers found on the ASUS support page for the specific product and on MyAsys, with an installation procedure that either does not start, or starts and fails, or starts and ends but does not cause any changes, even by starting the installers with administrator permissions.

- Reinstall the latest drivers found in Intel Driver & Support Assistant.

- Reinstall the latest drivers found on various driver archive sites searching them by their hardware ID

- Rolling back the drivers using the ones found on the ASUS support page for the specific product and on various driver archive sites searching them by their hardware ID

- Run the comand sfc /scannow

- Run the following command list in the command prompt:

ipconfig / flushdns

ipconfig / registerdns

ipconfig / release

ipconfig / renew

netsh winsock reset

- Attempt to delete the Upper Filters and Lower Filters files from the system log files (regedit) in the folder relating to the GUID class of the two devices in the path Computer \ HKEY_LOCAL_MACHINE \ SYSTEM \ ControlSet001 \ Control \ Class, failed because they are not present.

- Reset BIOS settings.

- Update the BIOS to the latest version available on the ASUS support page for the specific product.

- Reset by disassembling the computer, removing the battery and pressing the power button for 10 seconds and restarting everything. (Sometimes used between one of the previous attempts and the other)

- Windows restore by deleting all files.

- Format with ISO without using diskpart to format volumes (not deep formatting).

 

*** RESOLUTION ATTEMPT WITH PARTIAL / TEMPORARY RESULT ***

I tried deep formatting, via ISO mounted on a USB stick and using diskpart to run the “format fs = ntfs” command by selecting each existing volume and then proceeding with the reinstallation of Windows.

At this point, both the BT and the WiFi work again until I proceeded with the installation of the latest (automatic) Windows Update.

Through the PowerShell I get the log of the latest Windows Update updates and I realize that it is the "Intel - Net 22.30.0.11" update that is causing a driver conflict, thus, I perform a rollback of this update to version “22.10.0.7”, also by following an advice found on the internet for a similar problem (but not the same).

The installer of the "Intel - Net 22.10.0.7" version is presented as a Proset / Wireless WiFi software installer.

 

The installation of the software results in the return to operation of both the BT and WiFi.

Although I had disabled automatic driver updates of Windows by changing the proper setting in "Advanced system settings> Hardware> Device installation settings", Windows decides to reinstall the "Intel - Net 22.30.0.11" version by itself again.

Initially I can NOT perform a rollback because, despite having uninstalled everything I could uninstall, the installer of "Intel - Net 22.10.0.7" inexplicably only gives me the possibility to repair the software already present, which in fact is not there.

After a series of attempts, reboots and reset by removing the battery, I succeed in having “Intel - Net 22.10.0.7” driver version installed and everything works.

I am therefore forced to disable automatic driver updates by Windows by also modifying the proper settings on the group policy and, for being careful, to completely disable Windows Update updates in the hope that in the near future a more recent software will put an end to the problem.

After a few weeks when everything works properly, inexplicably, despite Windows Update is still disabled, on 10/08/2021 around midnight, the network card stops working and the error code 10 reappears in "Device Manager" for both WiFi and for the Bluetooth device.

I have tried to perform again almost every attempt described above except the complete format, without ever being able to get the installation of "Intel - Net 22.10.0.7" driver version, whose installer only gives me the possibility to repair the software already present, even if in fact there is no software installed.

0 Kudos
10 Replies
federicofabbro
Beginner
473 Views

Edit 12/08/2021: I try to install the latest version available (22.60.0) of Intel Net found on the internet without any result, then I shut down the system and the day after the WiFi works again but the BT is still in code error 10. After uninstalling BT device in “Device Manager” and letting Windows installing its drivers by itself, both WiFi and BT work. After another system shutdown, I turn the computer back on and both WiFi and BT fail again. I try again to install the latest version of Intel Net, I reboot, but I don't get any results.

AndrewG_Intel
Moderator
460 Views

Hello @federicofabbro

Thank you for posting on the Intel® communities.


In regards to this request and considering all the troubleshooting steps that you have already tried, please allows us to check this further and we will be posting back in the thread as soon as more details are available.


Best regards,

Andrew G.

Intel Customer Support Technician


AndrewG_Intel
Moderator
430 Views

Hello federicofabbro


Code 10 errors in Device Manager for Bluetooth or Wireless (Wi-Fi) Devices can be caused by many different issues, one of them could be a hardware failure.


If your system has all the updates (BIOS, operating system updates, drivers, etc) and based on all the troubleshooting you have performed, at this point, the best would be to contact the Original Equipment Manufacturer (OEM) to check the possibility of a hardware inspection.

We noticed you mentioned that a lot of computers, the same model, have the same issue (based on internet results). We checked too and found information in our community and other Asus threads*, therefore, our recommendation is to report this behavior directly to the computer manufacturer (even if you think this is not hardware-related) as many systems designed by them are being affected, so they may provide a workaround to solve the issue.


Having said that, we will proceed to close this thread now. If you need any additional information, please submit a new question as this thread will no longer be monitored. For your convenience, here is the link to ASUS* Support.


Best regards,

Andrew G.

Intel Customer Support Technician


jarez95
Beginner
123 Views

Hi Federico, 

Has there been any update to your situation, have you managed to get either the Bluetooth or WiFi working ? 

You've done quite a thorough investigation into this issue, I am experiencing the exact same things you have and have attempted exactly what you have done. I am also trying to be methodical about this and considering what options I have. Quite upset as I have the same model as you and was rather expensive brand new. 

Best Regards, Jarez

federicofabbro
Beginner
103 Views

Hi Jarez, unfortunately I still haven't found any permanent solution. I managed to buy 2 dongles (one for Wi-Fi, one for BT) and connect them to a usb hub with a usb-c cable connected into the usb-c port of my asus (so i don't waste any usb port).

Best Regards.

jarez95
Beginner
92 Views

Morning Federico, 

Thanks for the reply, do you mind letting me know which USB-C WiFi and BT dongle you have? - as I think I will have to look into the possibility of purchasing one, it will be better than the USB3 one I currently have which is needed for other things.

I am going to see what further actions I can take with Asus and Intel to try and find a solution, I also have made forum posts across a number of forums to see if there are any solutions, none to do date. I do also believe that it is software and BIOS related for me it also persists under Ubuntu but as it is BIOS related that would make sense as it something that happens on the PCI express bus during switch on. 

I will keep you informed if I have there are any developments. It seems I will just have to comment on here, since Intel don't have a messaging system. 

Jarez

AlHill
Super User
83 Views

"since Intel don't have a messaging system"

 

The forum software supports private messages. 

AlHill_0-1659094984197.png

 

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

federicofabbro
Beginner
70 Views

Hello Jarez, thank you for the informations.

After all these months and failed attempts I lost my hope to solve the problem without getting the entire motherboard replaced so, as I said, I found that the best solutions in terms of space saving and usability is to use a UGREEN USB-C hub that has 4 USB3 ports in which I connect my two USB3 dongles. By doing this, none of the Asus USB3 ports is used and I still have two more extra USB3 ports in the USB-C hub and it's pretty easy to connect and disconnect the Hub when I need to bring my laptop outdoor.

I really never had the chance to interact with someone who has the same problem so I would be grateful if you will inform me about any development.

 

Federico

jarez95
Beginner
49 Views

Hi, 

Ok must have been confused with another forum, Windows possibly.

Thanks Federico just about to order one, I will send you a private message also. I am going to try to find other users with the same laptop UX480FD or something similar in the Zenbook range and perhaps look at approaching Intel and/or Asus as a collective group. I have heard that even RMA's and motherboard replacements might not fix the problem as there isn't much to prevent Windows pushing another update, there is a way but it is incredibly forceful and then the process of actually getting useful updates after is complicated. Either way it is a risky and time consuming process to RMA especially if you use your laptop nearly all hours of the day. 

We have: Windows Update -> Intel drivers -> Asus Hardware 

Windows are just annoyingly pushing the updates so they are not fully to blame, the problem is either with the quality of the hardware chipset (Intel) or the drivers (Intel) and perhaps compounded by a problematic Asus BIOS or hardware design flaw on the motherboard. This same problem has been reported on other vendors of laptop but it seems to only be non-fixable with the Asus Zenbook, I believe other Asus users have been unaffected or managed to find a solution as the BIOS is inherently different anyway. 

Regards, Jarez

federicofabbro
Beginner
40 Views

Hello Jarez, thank you again for the infos. I mentioned a motherboard replacement not because I think it would solve the problem but only because it's the last and only thing that Asus support offered me after reading the whole list of attempts I carried out. 

 

Federico

Reply