Wireless
Issues related to Intel® Wireless Adapters and technologies
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
6027 Discussions

AC 9560 failure and repair behavior that can be duplicated (Code 10)

SGKent
Beginner
442 Views

To begin with, 22.50.1.1 drivers did not fix the issue.

Have a Dell 7586 2-1 that is doing the AC 9560 wi-fi/bluetooth card dropout in Device Manager.  It has caused real issues for the staff at the company I support. In fact it has made this the laptop from hell.  The webpages are full of people with the same issues and the threads and videos are endless on fixes.  I won't list all the things I have tried, but I would guess that if you listed things to try it would be on the list from replacing the card, to reimaging, bios factory resets, rests to defaults, latest drivers,  etc etc, etc etc.  Here is what I have found has repaired the problem consistently.

When either the bluetooth or the WI-FI fail with either a code 10 or a complete disappearance, if I reflash an older bios like 1.7.1, the AC9560 will function normally for awhile.  Might be an hour, might be 5 minutes but it brings them back every time.  Next I went into BIOS settings and turned off all the adaptive power, sleep settings etc., and that has kept the wi-fi alive for the whole day, when it was quitting every few minutes before. Blue tooth still disappears occasionally but reflashing the bios always brings it back to life for awhile.  

I hope this helps whomever at Intel who is working on this issue find a fix, because based on my research the last few days, there are 10,000's of people out there with this issue and I am sure they and Intel would like it fixed permanently. 

UPDATE: I added a USB to Ethernet card and it works fine now with these settings whereas it simply cycled on and off before at the same time the AC9560 acted up.  When I removed it the Bluetooth quit again. Ran the latest Intel BT drivers and did a repair. Bluetooth still showed in USB as an unknown device. So I flashed the 1.7.1 bios again (it already has the 1.7.1) and when it started everything is back to normal again. 

 

SECOND UPDATE: Flashing the latest bios fixed it again when it failed.  This did not solve the issue last night. There is something about flashing the bios that resets the devices in a way that the laptop can see and talk with them. When it loses track of the bluetooth for example, it shows up in the USB items as a hidden device that has no descriptor so no driver loads for it.  An Internet search shows there are many people who have found the same to be true, and the threads saying try this try that all have negative results. 

 

I am convinced that this is either a hardware failure at the motherboard level, or it is a BIOS issue.  Based on the number of laptops that have this issue a solution must be found because when you build laptops with only wi-fi and it dies, the laptop is rendered useless other than a boat anchor or door stop.  I believe this will end up a class action suit of biblical proportions if it isn't fixed because so many manufacturers are involved who use this setup of the AC9560 series wi-fi card.  

0 Kudos
7 Replies
DeividA_Intel
Moderator
353 Views

Hello SGKent,  

  


Thank you for posting on the Intel® communities.   

  


In order to better assist you, please provide the following:  


  


1. Run the Intel® System Support Utility (Intel® SSU) to gather more details about the system.  


· Download the Intel® SSU and save the application on your computer: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-  


· Open the application, check the "Everything" checkbox, and click "Scan" to see the system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".  


· To save your scan, click Next and click Save.  



2. Is the issue recent? If not, when did it start?


3. Have you updated the operating system, including optional updates?


4. Have you tried a clean installation of the DELL drivers?


5. Have you tried a fresh installation of the operating system?


6. Have you contacted DELL for support?




Regards,  


Deivid A. 

Intel Customer Support Technician 


SGKent
Beginner
347 Views

2, Yes it is recent. About a month.Steps taken

a. Downloaded and updated drivers. No change

b. Flashed to the newest bios, it started working then quit an hour or so later

c. Reflashed the newest bios, it started working  then quit 20 minutes or so later

d. Reimaged with the factory image it came with and rolled back the bios 3 versions. It came back and quit an hour or so later.

e. Changed the OS sleep settings - no change

f. Replaced the drivers after all windows updates done. Used the latest Intel chipset, bluetooth and wi-fi drivers. No change still code 10.

g. Replaced image with the one downloaded from Dell for that serial number. No change, still code 10.

h. Updated drivers again. Let Windows update all the updates and then updated the drivers again. Still code 10.

i. Flashed the 1.7.1 bios. Bluetooth and Wi-fi worked for about an hour and died.

j. Flashed the 1.71. bios again. Bluetooth and wi-fi worked for about 30 minutes and died

h. Flashed the 1.8.1 bios. Bluetooth and wi-fi worked for about an hour and died.

i. Replaced the AC9560 card with a new seal one thru Amazon. No change. Still code 10. Ran driver updates again no change.

j. Put original card back in and inserted an insulator between bracket and antenna leads in case they were touching bracket. Tried a USB to Ethernet adapter but it just turned on and off in the device manager every few seconds.

k. changed sleep settings in bios to no sleep etc. No change.

l. Flashed 1.71. bios again. Wi-fi and bluetooth worked again. Blue tooth dropped out and showed up in USB devices as unknown descriptor. Wi-fi remained constantly on. Tried the USB to ethernet adapter again. It worked normal.

M. Flash the latest bios and bluetooth came back. Wi-fi continued to work for 2 days. Tried the USB to ethernet adapter again - it worked fine but bluetooth dropped out when it was unplugged from USB. Bluetooth appeared in USB with unknown descriptor.

N. Reflashed the latest bios again, bluetooth appears normal again. WI-fi continues to work with sleep settings and adaptive power turned off in bios. Please note: battery was disconnected while replacing the AC9560 and it made no change on status of Code 10.

O. Loaded bios into a folder on desktop with instructions to user to flash the bios anytime wi-fi or bluetooth drops out. This always brings it back for awhile.

 

I will run your scan shortly.  There are also some other troubleshooting steps tried as well not listed - ran the Windows troubleshooter several times, disabled and enabled network etc., etc. I spent 15 years in a State of CA IT help center for about 1500 users and have worked on 10,000's of computers as well and thousands of images. Never seen anything like this. It is not thermally sensitive either. It can work fine, turn it off, and the wi-fi goes code 10. Since power settings changed in bios only the bluetooth has dropped out of device manager. I also looked thru all hidden devices etc.. 

 

Laptop came with one year warranty. It expired six months ago. Dell will not be of any help on this beyond what I have already tried. In fact my experience at the state and now retired is to write KB's sometimes and send them to manufacturer with solutions when their staff can't figure it out.  Besides, if you know the AC9560 issue, it transcends many brands of laptops. Just do a search either on your site or Google AC9560 Code 10. Dell won't replace an 18 month old laptop that had a 1 year warranty.  The issue is with either the motherboard bios or the AC9560, both are Intel made.  even if Dell did replace the laptop, some people have had the issue 2 weeks into owning a laptop with an AC9560 in it. Something else is going on and I am sure y'all would like it solved too. The latest bios or your KB on the issue did not fix the issue.

SGKent
Beginner
340 Views

well, fired up laptop after sitting unused several days and wi-fi is code 10 again. Reflashed recent bios and it would not come back. tried several times and now it will not come back at all. Reloaded recent drivers still no joy.  Ran SSU from a flash drive - attached.

 

Nothing is working to bring it out of code 10 today.

 

update: worked on it most of the day, played with bios, drivers etc but nothing would bring the wi-fi or bluetooth to life today. I guess the bios reflash was a fluke the other day even though it worked consistently.  I did make sure that the latest Intel drivers were showing as the loaded drivers, and they were after deleting the other drivers, however that did NOT bring the  wi-fi or bluetooth to life. It reads that it is a power state failure. I am out of bullets for this laptop unless someone finds something else that hasn't been thought of or tried. 

 

 

DeividA_Intel
Moderator
317 Views

Hello SGKent,


  


Thank you for the detailed information provided, I do appreciate it.


  


I will proceed to check the issue internally and post back soon with more details. 


  


Best regards,  


Deivid A.  

Intel Customer Support Technician 


SGKent
Beginner
297 Views
DeividA_Intel
Moderator
288 Views

Hello SGKent, 



Thanks for your patience.




Based on the research and the information provided, seems that you have tried enough troubleshooting steps, since the wireless card is installed on a laptop there is not too much we can do.


My recommendation at this point is to check with the laptop manufacturer for further steps. I am aware that the warranty period is over, but they may be able at least to provide you with more troubleshooting steps.


Please keep in mind that this thread will no longer be monitored by Intel.  




Best regards,  


Deivid A.  

Intel Customer Support Technician 



DornT
Beginner
276 Views

I have the same problem like u with my asus zenbook and i wonder what i should do? Will there be an windows update to fix it soon? do i really have to reset my laptop?

 

An answer would be very helpful

 

Kind regards

Reply