Wireless
Issues related to Intel® Wireless Adapters and technologies
Announcements
Bluetooth mouse lag problem on specific systems with 11th Gen Intel processors. See details here.

How to Enable Wi-Fi 6E/ 6GHz Band Using Intel® Wi-Fi 6E AX210 (Gig+)
5637 Discussions

AX201 not connecting to p2p go on 5 GHz

norserob
Beginner
546 Views

I am having trouble connecting to 5 GHz p2p GO for Wi-Fi Display.

I am using Intel NUCs running Arch Linux, and this works fine for NUCs with ac chips (Wi-Fi 5), but not
for NUCs with ax chips (Wi-Fi 6). I have several generations of NUCs available, and see this problem only on the newer ones with Wi-Fi 6.

Upon connecting it is switched to world safe mode, and cannot connect. It only connects if the p2p GO is on 2.4 GHz. Is this a known issue? This is an AX201.

I can connect to 5 GHz APs, but not to p2p GO on 5 GHz. 

From dmesg: iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6 AX201 160MHz, REV=0x354.

 

0 Kudos
16 Replies
Sebastian_M_Intel
Moderator
530 Views

Hello norserob,  

  

Thank you for posting on the Intel® communities.    

  

In order to better assist you, please provide the following:  

  

1. Run Intel® System Support Utility for the Linux* Operating System for more details: https://downloadcenter.intel.com/download/26735/Intel-System-Support-Utility-for-the-Linux-Operating... 

2. Is this the original adapter that came pre-installed with the NUC or did you change/install the adapter to this one?   

3. Run the following commands and send us the outcome:  

  • modinfo iwlwifi > If there is no output, then the module isn’t installed this is the distribution installation issue.  
  • lsmod | grep iwlwifi > If the result is empty, the driver hasn't been loaded. Most likely to be a distribution issue.  
  • To verify, please type: dmesg | grep iwlwifi > If the result is empty, the driver wasn’t initialized and this is a distribution issue. If there is a result populated, proceed with the next step.   
  • dmesg | grep “no suitable firmware found!” > If the result is not empty, it means you don't have a suitable FW (api mentioned in the dmesg).  
  • Please visit here: h ttps://wireless.wiki.kernel.org/en/users/drivers/iwlwifi  for supported FW,  or here https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/ for the latest versions.  

  

4. If the above steps don't work, collect the debug data:  

  

Type: dmesg | grep ASSERT    

  

If the output is empty, please follow this wiki: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging  to extract dmesg and trace-cmd.  

  

If the output has value, please collect from the wiki FW dump too.  

  

Regards,  

  

Sebastian M  

Intel Customer Support Technician   


norserob
Beginner
518 Views

Hi Sebastian,

 

Thank you for the quick reply. Please find included output from ssu and the other commands.

 

Regards,

-Robert

 

Sebastian_M_Intel
Moderator
505 Views

Hello norserob,   

 

Thank you for your update. 

 

Please let me review this internally, once we have an update, we will share it on this thread. 

 

Please kindly wait for a response.   

 

Regards,   

   

Sebastian M   

Intel Customer Support Technician   


Sebastian_M_Intel
Moderator
473 Views

Hello norserob,    

  

Thank you for waiting.  

  

Please try the following: 

 

  1. We could see on the iwlwifi.txt: "parm: disable_11ax:Disable HE capabilities (default: false) (bool)". Can you try to enable these capabilities? 
  2. Also, can you please let us know which p2p Go are you using? 
  3. You may refer to this article for further information: http://w1.fi/cgit/hostap/commit/?id=5a3319ab1b23a588d608ead1e85c28a5b7149bbe 

 

Any questions, please let me know.  

 

Regards,    

    

Sebastian M    

Intel Customer Support Technician    


Sebastian_M_Intel
Moderator
457 Views

Hello norserob,  

 

Were you able to check the previous post and follow our recommendations? Please let me know if you need more assistance.   

 

Regards,  

  

Sebastian M  

Intel Customer Support Technician  


norserob
Beginner
451 Views

Hi Sebastian,

I tried adding the "he" option to the p2p_connect command, and also added it in the settings file. It did not help, the driver seems to force a revert to world mode when I try to connect.

The GO is a Cisco videoconferencing unit. Connecting works fine with a NUC with Wi-Fi 5 (ac chip), but not with Wi-Fi 6. I'll see if I can get hold of a Windows laptop with Wi-Fi 6 chip to check that it works.

I'll include snippets from the wpa_supplicant log.

-Robert

Sebastian_M_Intel
Moderator
445 Views

Hello norserob,   

  

Thank you for your reply. 

 

Please let me check this internally again, we will come back once we have more details to share.  

  

Regards,   

   

Sebastian M  

Intel Customer Support Technician


Sebastian_M_Intel
Moderator
416 Views

Hello norserob,    

  

Thanks for waiting. 

 

After checking, we noticed your logs indicate the Wi-Fi fails to load the matching firmware 56 for kernel 5.9.11. Please try to load the FW 56 successfully and check if the issue still occurs. 

[  2.273622] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-56.ucode failed with error -2 

  

If the issue still occurs, please provide the following information and logs: 

 

What is the specific wireless device used as the P2P GO? 

 

Assuming the P2P GO is also an Intel Wi-Fi device, please collect the following logs on both P2P GO and P2P GC (i.e. the AX201) at 5 GHz band: 


1) Collect full dmesg.log -> Please type # dmesg > dmesg.log 

2) Tracing log 'trace.dat' 

Step1. Before establishing P2P link, please type # sudo trace-cmd record -e iwlwifi -e mac80211 -e cfg80211 -e iwlwifi_msg 

  

Step2. Start to establish the link. When the issue occurs, stop tracing by hit Ctrl^C, collect the log 'trace.dat' 

  

3) Collect entire P2P commands and output on both P2P Go and P2P GC. 

  

4) Collect passing logs: Proceed 1), 2) and 3) again when establishing a P2P link at the 2.4 GHz band 

  

Regards,    

    

Sebastian M    

Intel Customer Support Technician


Sebastian_M_Intel
Moderator
402 Views

Hello norserob,  

 

Were you able to check the previous post and get the information requested? Please let me know if you need more assistance.   

 

Regards,  

  

Sebastian M  

Intel Customer Support Technician 


norserob
Beginner
395 Views

Hi Sebastian,

I collected logs now, and it looks like iwlwifi actually crashes in the 5GHz case, looks like it in dmesg (see dmesg in client-5.tar.gz). To be able to collect logs from both client and go I used another NUC as go now, running my own software using wpa_supplicant. So both sides are running my software on arch linux and using wpa_supplicant, playing video from client to go with wifi display.

I collected trace.dat, dmesg and wpa_supplicant.log for both cases. I extracted the wpa_supplicant.log from journalctl.

The 2.4 GHz case works, the client connects and plays. See client.tar.gz and go.tar.gz.

For the 5 GHz case I need to restart the wpa_supplicant on the go after boot, since I start wpa_supplicant from my software, and the go selects 2.4 GHz if it is not on wifi. After restarting my software (which starts wpa_supplicant) the go starts up on 5 GHz. And then I connect from the client, but this does not succeed. See client-5.tar.gz and go-5.tar.gz.

-Robert

 

norserob
Beginner
393 Views

By the way, I did add "ht40 vht he" to both the p2p_connect and p2p_start_group commands.

-Robert

 

norserob
Beginner
389 Views

But in my original setup with the go having a non-ac chip (it is a Cypress ac chip) I guess using the he option will not make any difference.

 

Sebastian_M_Intel
Moderator
381 Views

Hello norserob,   

 

Thanks for the response. 

 

Please remember that we are investigating this internally, so kindly wait for an update while we check these logs. 

 

In the meantime, did you try to load the firmware 56 successfully and check if the issue still occurs as we advised previously? If not, please try it. 

  

Regards,   

   

Sebastian M  

Intel Customer Support Technician  


norserob
Beginner
378 Views

Hi Sebastian,

I upgraded linux and got firmware version 59, which was installed.

Now I installed Windows 10 on a NUC with ax chip, and after upgrading the network drivers and the graphics driver I got it to connect to my original go on 5 GHz.

So this is the same model NUC, which can not connect with the Linux driver (iwlwifi crashes), but it works with the Windows drivers.

I upgraded the BIOS as well during the driver updating with Windows, not sure if that had an effect. I can upgrade the BIOS on a Linux box and test that too.

-Robert

Sebastian_M_Intel
Moderator
357 Views

Hello norserob,   

 

In order to get some additional information that may contain personal data, we will send you an e-mail to the e-mail address associated with your account. 

 

Please reply to that e-mail with the information we will request.  

 

Regards,    

    

Sebastian M   

Intel Customer Support Technician


Sebastian_M_Intel
Moderator
336 Views

Hello norserob,   

 

I would like to let you know that the engineering team has started investigating this P2P issue more deeply. This might take some time.


Kindly wait for a response.

 

Regards,    

    

Sebastian M   

Intel Customer Support Technician


Reply