Community
cancel
Showing results for 
Search instead for 
Did you mean: 
kiraliu7
Beginner
241 Views

AX201 unstable connection on Ubuntu 20.04

Hi! I just built a linux system but the wifi is so unstable it disconnects every couple minutes. Ubuntu is the only OS on my computer. I need to switch wifi on and off to reestablish connection. I tried to refer to this thread on the forum and installed newest firmware (iwlwifi-Qu-*-59) but the issue persists. 

I am using the onboard intel AX201on ROG H470i mobo.  Kernel is 5.8.0

0 Kudos
13 Replies
Maria_R_Intel
Moderator
227 Views

Hello kiraliu7,


Thank you for posting on the Intel® communities.    

  

In order to better assist you, please provide the following:  

  

1. Run Intel® System Support Utility for the Linux* Operating System for more details: https://downloadcenter.intel.com/download/26735/Intel-System-Support-Utility-for-the-Linux-Operating... 


3. Run the following commands and send us the outcome:  

  • modinfo iwlwifi > If there is no output, then the module isn’t installed this is the distribution installation issue.  
  • lsmod | grep iwlwifi > If the result is empty, the driver hasn't been loaded. Most likely to be a distribution issue.  
  • To verify, please type: dmesg | grep iwlwifi > If the result is empty, the driver wasn’t initialized and this is a distribution issue. If there is a result populated, proceed with the next step.   
  • dmesg | grep “no suitable firmware found!” > If the result is not empty, it means you don't have a suitable FW (api mentioned in the dmesg).  
  • Please visit here: h ttps://wireless.wiki.kernel.org/en/users/drivers/iwlwifi  for supported FW,  or here https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/ for the latest versions.  

  

4. If the above steps don't work, collect the debug data:  

  

Type: dmesg | grep ASSERT    

  

If the output is empty, please follow this wiki: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging  to extract dmesg and trace-cmd.  

  

If the output has value, please collect it from the wiki FW dump too.  



Best regards,

Maria R.

Intel Customer Support Technician


kiraliu7
Beginner
219 Views

Thanks for the advice! I tried these steps and unfortunately its still not working. I am attaching the logs to this comment

Maria_R_Intel
Moderator
213 Views

Hello kiraliu7,


Thank you for letting us know the outcome.


I will proceed to check the case internally and post back soon with more details.


Best regards,

Maria R.

Intel Customer Support Technician


Maria_R_Intel
Moderator
193 Views

Hello kiraliu7,


Thank you for patiently waiting, please follow these steps:

 

1) Your dmesg log indicates the Wi-Fi fails to load the matching firmware 56 for kernel 5.8.

 

Please try to load the FW 56 successfully and check if the issue still occurs.

Line 957: [  3.250465] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-56.ucode failed with error -2

 

2) Does the slow speed issue occur when connecting to the Wi-Fi router at 2.4 GHz band?

 

If so, please try to connect to the router at the 5 GHz band and see if the issue improves

 

3). According to the post https://askubuntu.com/questions/1230525/ubuntu-20-04-network-performance-extremely-slow?newreg=89f45... , please have customer check if this issue can be fixed by:

Option 1:

editing /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf and then change the value wifi.powersave from 3 to 2, save the changes and reboot the system.

Option 2:

Remove the backport-iwlwifi-dkms package, type: $ sudo apt remove backport-iwlwifi-dkms

 

Best regards,

Maria R.

Intel Customer Support Technician




Maria_R_Intel
Moderator
181 Views

Hello kiraliu7,


Were you able to check the previous post?

 

Let me know if you need more assistance.

 

Best regards, 

Maria R.  

Intel Customer Support Technician 


kiraliu7
Beginner
170 Views

Hi Maria,

Thanks for the update. However, it seems that i can not find iwlwifi-QuZ-a0-hr-b0-56.ucode anywhere. Can you send me a download link? 

Maria_R_Intel
Moderator
162 Views

Hello kiraliu7,


Sure, please let me ask for the link and I will post back soon.


Best regards,

Maria R.

Intel Customer Support Technician


Maria_R_Intel
Moderator
132 Views

Hello kiraliu7,


Thank you for patiently waiting.

 

It seems the iwlwifi-QuZ-a0-hr-b0-56.ucode is no longer available at git tree (https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/), which makes your current firmware 'QuZ-a0-hr-b0-55.ucode' the Max version available for his Kernel 5.8.

 

 

In this way, please try the 2) and 3), and let us know if the AX201 works better.

 

i.e.

 

2) Does the slow speed issue occur when connecting to the Wi-Fi router at 2.4 GHz band?

 

If so, please try to connect to the router at the 5 GHz band and see if the issue improves


 

3). According to the post https://askubuntu.com/questions/1230525/ubuntu-20-04-network-performance-extremely-slow?newreg=89f45... , please have customer check if this issue can be fixed by:

 

Option 1:

 

editing /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf and then change the value wifi.powersave from 3 to 2, save the changes and reboot the system.

 

Option 2:

 

Remove the backport-iwlwifi-dkms package, type: $ sudo apt remove backport-iwlwifi-dkms

 


Best regards, 

Maria R.  

Intel Customer Support Technician 


Maria_R_Intel
Moderator
101 Views

Hello kiraliu7,


Were you able to check the previous post?

 

Let me know if you need more assistance.

 

Best regards, 

Maria R.  

Intel Customer Support Technician 


kiraliu7
Beginner
77 Views

Thanks for the update! Unfortunately I am in Texas and suffering from outage so I wont be able to check it until utility comes back.

Maria_R_Intel
Moderator
71 Views

Hello kiraliu7,


Thank you for let us know!


Don't worry we will keep your thread open and may do a follow-up at the end of the next week if we don't have a response for you.


I hope you have a great weekend!


Best regards,

Maria R.

Intel Customer Support Technician


DeividA_Intel
Employee
47 Views

Hello kiraliu7,  


  


Were you able to check the previous post? And were you able to try the steps recommended? Please let me know if you need more assistance.   


  


Regards,  


Maria_R_Intel
Moderator
9 Views

Hello kiraliu7,  


Please let us know if you need extra time to test and complete the steps.



Best regards,

Maria R.

Intel Customer Support Technician