Wireless
Issues related to Intel® Wireless Adapters and technologies
5970 Discussions

Intel Wireless AC-9260 does not work in Ubuntu VM on a ESXi host.

RVK
Beginner
697 Views

We have a Intel Xeon - E-2176M host with a Intel(R) Wireless-AC 9260 160MHz pcie card. We passthru the Wireless device from the ESXi host to the Ubuntu VM. On the ESXi host the lspci shows

0000:01:00.0 Network controller: Intel Corporation Wireless-AC 9260

On the Ubuntu VM 

03:00.0 Network controller: Intel Corporation Wireless-AC 9260 (rev 29)

So the pass thru works and it gets detected. On bootup of the VM the card gets detected (from dmesg)

[ 2.661583] iwlwifi 0000:03:00.0: Detected Intel(R) Wireless-AC 9260 160MHz, REV=0x324

But it timesout after 5 seconds

[ 7.731490] iwlwifi 0000:03:00.0: Failed to load firmware chunk!
[ 7.731492] iwlwifi 0000:03:00.0: iwlwifi transaction failed, dumping registers

The same Ubunut image works on bare-metal on the same system without the ESXi host.

I tried the backport iwlwifi drivers and tried to isolate where it could be failing. 

It looks like it is failing in writing to  FH_TFDIB_CTRL0_REG(FH_SRVC_CHNL) register (I tried to read it back and it was missing some data). On a bare-metal with the same test it would read back fine and the driver would load up fine. 

Using the backport wireless drivers on Ubuntu the CSR registers are as follows. 

[ 2.670768] iwlwifi 0000:03:00.0: CSR values:
[ 2.670772] iwlwifi 0000:03:00.0: (2nd byte of CSR_INT_COALESCING is CSR_INT_PERIODIC_REG)
[ 2.670778] iwlwifi 0000:03:00.0: CSR_HW_IF_CONFIG_REG: 0X18c89004
[ 2.670791] iwlwifi 0000:03:00.0: CSR_INT_COALESCING: 0X00000040
[ 2.670803] iwlwifi 0000:03:00.0: CSR_INT: 0X00000000
[ 2.670814] iwlwifi 0000:03:00.0: CSR_INT_MASK: 0X00000000
[ 2.670826] iwlwifi 0000:03:00.0: CSR_FH_INT_STATUS: 0X00000000
[ 2.670838] iwlwifi 0000:03:00.0: CSR_GPIO_IN: 0X00027e1f
[ 2.670849] iwlwifi 0000:03:00.0: CSR_RESET: 0X00000010
[ 2.670861] iwlwifi 0000:03:00.0: CSR_GP_CNTRL: 0X0c04000d
[ 2.670874] iwlwifi 0000:03:00.0: CSR_HW_REV: 0X00000321
[ 2.670886] iwlwifi 0000:03:00.0: CSR_EEPROM_REG: 0Xd55555d5
[ 2.670897] iwlwifi 0000:03:00.0: CSR_EEPROM_GP: 0Xd55555d5
[ 2.670907] iwlwifi 0000:03:00.0: CSR_OTP_GP_REG: 0Xd55555d5
[ 2.670918] iwlwifi 0000:03:00.0: CSR_GIO_REG: 0X001f0042
[ 2.670931] iwlwifi 0000:03:00.0: CSR_GP_UCODE_REG: 0X00000000
[ 2.670941] iwlwifi 0000:03:00.0: CSR_GP_DRIVER_REG: 0X00000000
[ 2.670952] iwlwifi 0000:03:00.0: CSR_UCODE_DRV_GP1: 0X00000000
[ 2.670963] iwlwifi 0000:03:00.0: CSR_UCODE_DRV_GP2: 0X00000000
[ 2.670974] iwlwifi 0000:03:00.0: CSR_LED_REG: 0X00000020
[ 2.670985] iwlwifi 0000:03:00.0: CSR_DRAM_INT_TBL_REG: 0X00000000
[ 2.670996] iwlwifi 0000:03:00.0: CSR_GIO_CHICKEN_BITS: 0X07800200
[ 2.671008] iwlwifi 0000:03:00.0: CSR_ANA_PLL_CFG: 0Xd55555d5
[ 2.671019] iwlwifi 0000:03:00.0: CSR_MONITOR_STATUS_REG: 0X3f7fae10
[ 2.671030] iwlwifi 0000:03:00.0: CSR_HW_REV_WA_REG: 0X0001001a
[ 2.671041] iwlwifi 0000:03:00.0: CSR_DBG_HPET_MEM_REG: 0Xffff0000

The registers are identical in case of VM or Bare-Metal other than one register CSR_MONITOR_STATUS_REG. 

 

On the ESXi host I have tried setting the following variables

pciPassthru.use64bitMMIO and iovDisableIR   but no luck in the result. 

I have tried both Ubuntu18.04 as well as Ubuntu 20.04 VM. 

Any help would be appreciated. Please let me know if if any more information is needed.

Thanks,

RVK

 

Labels (2)
0 Kudos
4 Replies
Maria_R_Intel
Moderator
672 Views

Hello RVK,


In order to better assist you, please provide the following:  


  • Can you please confirm if the card works fine in the host OS/machine?

  

1. Run Intel® System Support Utility for the Linux* Operating System for more details: https://downloadcenter.intel.com/download/26735/Intel-System-Support-Utility-for-the-Linux-Operating... 

 

3. Run the following commands and send us the outcome:  

  • modinfo iwlwifi > If there is no output, then the module isn’t installed this is the distribution installation issue.  
  • lsmod | grep iwlwifi > If the result is empty, the driver hasn't been loaded. Most likely to be a distribution issue.  
  • To verify, please type: dmesg | grep iwlwifi > If the result is empty, the driver wasn’t initialized and this is a distribution issue. If there is a result populated, proceed with the next step.   
  • dmesg | grep “no suitable firmware found!” > If the result is not empty, it means you don't have a suitable FW (api mentioned in the dmesg).  
  • Please visit here: h ttps://wireless.wiki.kernel.org/en/users/drivers/iwlwifi  for supported FW,  or here https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/ for the latest versions.  

  

4. If the above steps don't work, collect the debug data:  

  

Type: dmesg | grep ASSERT    

  

If the output is empty, please follow this wiki: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging  to extract dmesg and trace-cmd.  

  

If the output has value, please collect it from the wiki FW dump too.  

 

 

We really appreciate it if you can send the logs to us in case the issue persists.



Best regards,

Maria R.

Intel Customer Support Technician




Maria_R_Intel
Moderator
665 Views

Hello RVK,


We received your internal message about the problem with handling Interrupt handling using MIS-X on the Ubuntu VM (not sure if it is the Ubuntu VM or the ESXi host).


We understand that you find a solution: "The solution for Ubuntu VM seems to be setting the following variable in the appropriate .vmx file for the particular pciePassthru"


Can you please confirm if you need further help or if you consider this thread as solved? If not, please provide us with the logs and report we requested.


Thank you

 

Best regards, 

Maria R.  

Intel Customer Support Technician 


Maria_R_Intel
Moderator
648 Views

Hello RVK,


Were you able to check the previous post?

 

Let me know if you need more assistance.

 

Best regards, 

Maria R.  

Intel Customer Support Technician 


Maria_R_Intel
Moderator
634 Views

Hello RVK,


We have not heard back from you, so we will close this thread. If you need any additional information, please submit a new question as this thread will no longer be monitored.

 

Best regards, 

Maria R.  

Intel Customer Support Technician 


Reply