Showing results for 
Search instead for 
Did you mean: 

Another Windows 8.1/ Wireless-N 2230 problem user

I have a MSI GT60 laptop with Win 8.1 Pro x64 and Intel Wireless-N 2230 adapter that is sporadically dropping the WiFi connection. Two other PC's with Win7, two Winphones 8 and two Android tablets + one phone on the same network have no WiFi problems of any kind.

I have tried the solution suggested in another thread here, namely installing intel® PROSet/Wireless Software version 16.7.0_e164.exe to no avail. It actually causes me more headaches. Also tried solutions suggested on other forums and nothing seems to make any difference. Here is the general M.O. of my problem:

1. Letting Windows handle WiFi connection results in sporadic, brief interruptions, perhaps one drop every hour or two. I connect to this PC via RDP and see it lose connection occasionally. Usually it will reconnect automatically after one retry but sometimes I have to disable/enable WiFi manually on the laptop. Aside from this the connection is working as expected.

2. Letting PROset handle the WiFi connection and it becomes limited. Oddly it only shows as limited on the WiFi icon on the lock and login screens. Once logged in to the desktop the system tray icon indicates normal access. But, when opening the PROSet configuration window the connection status is shown as "Connecting..." and this never changes. Internet access works normally but when I try to connect remotely RDP will freeze on the login screen.

Reinstalling the driver, rebooting or kicking the PC makes no difference. Driver version is I also tried the Wireless event logging that comes with PROSet but the messages are cryptic and tells me nothing. There are a lot of these (network name changed, RSSI=-29 is sometimes RSSI=-30):


427,S24EvMon,01/07/2014 09:04:37,Information,Driver,SYSTEM,ATC a4:b1:e9:e4:5c:dd NetworkName 11 RSSI=-29

428,S24EvMon,01/07/2014 09:04:37,Information,Driver,SYSTEM,AddToExclude a4:b1:e9:e4:5c:dd NetworkName 11

Any suggestions would be appreciated.

Tags (2)
0 Kudos
6 Replies

I noticed you installed the driver package 16.7 but somehow you got the driver version Such driver version matches an older driver package, meaning that you probably have non-matching driver and Intel® Proset software versions.

I suggest a complete uninstall of Intel® Proset from Programs and Features, and then restart your system before attempting again with package version 16.7. This latest package version should load driver

I am sorry for this inconvenience, hopefully this will help. Intel� PROSet/Wireless Software; Intel� PROSet/ Wireless Software Downloads Intel� Wi-Fi Products; Intel� PROSet Wireless Software driver versions by Operating System


Sorry for the confusion, the driver version mismatch is likely due to me fiddling around in the device manager and trying different drivers. It was correct when I first installed the latest PROSet but just to be sure I followed your instructions and it made no difference.

If it's any help, here is the entire wireless event log, from when I press "Connect" in the WiFi Connection utility to "Disconnect" (user and profile names redacted):

# Event,Source,Time,Error Severity,Domain,User,Description

1,IWA,01/10/2014 06:49:16,Information,Adapter,xxxxxx,Scan end event from the Service.

2,Task Tray,01/10/2014 06:49:16,Information,General,xxxxxx,End scan event from the service.

3,IWA,01/10/2014 06:49:02,Information,Adapter,xxxxxx,Scan end event from the Service.

4,IWA,01/10/2014 06:49:02,Information,Adapter,xxxxxx,Link down event from the adapter.

5,IWA,01/10/2014 06:49:02,Information,Profile,xxxxxx,Profile update/added event from the Profile database.

6,Task Tray,01/10/2014 06:49:00,Information,General,xxxxxx,End scan event from the service.

7,Task Tray,01/10/2014 06:49:00,Information,Adapter,xxxxxx,Link down event from the adapter.

8,S24EvMon,01/10/2014 06:49:00,Information,TCP/IP,SYSTEM,VoIP: Got link down - deleting flows .

9,Profile Manager API,01/10/2014 06:49:00,Error,Profile,xxxxxx,An unexpected error occurred!

10,Profile Manager API,01/10/2014 06:49:00,Error,Profile,xxxxxx,An unexpected error occurred!

11,Profile Manager API,01/10/2014 06:49:00,Error,Profile,xxxxxx,An unexpected error occurred!

12,ZCfgSvc,01/10/2014 06:49:00,Information,Security,SYSTEM,Link down Wireless Profile: MyProfile

13,Profile Manager API,01/10/2014 06:49:00,Error,Profile,xxxxxx,An unexpected error occurred!

14,Task Tray,01/10/2014 06:48:59,Information,Profile,xxxxxx,Profile orderupdate/update/added event from the profile manager.

15,IWA,01/10/2014 06:48:22,Information,Adapter,xxxxxx,Link up event from the adapter.

16,IWA,01/10/2014 06:48:22,Information,Adapter,xxxxxx,Scan end event from the Service.

17,IWA,01/10/2014 06:48:22,Information,Adapter,xxxxxx,Link up event from the adapter.

18,Task Tray,01/10/2014 06:48:20,Information,Adapter,xxxxxx,Link up event from the adapter.

19,ZCfgSvc,01/10/2014 06:48:20,Success,Security,SYSTEM,Connected Wireless Profile: MyProfile

20,ZCfgSvc,01/10/2014 06:48:20,Information,Security,SYSTEM,Authenticating Wireless Profile: MyProfile

21,ZCfgSvc,01/10/2014 06:48:20,Success,Security,SYSTEM,Link up Wireless Profile: MyProfile

22,Task Tray,01/10/2014 06:48:20,Information,General,xxxxxx,End scan event from the service.

23,S24EvMon,01/10/2014 06:48:20,Information,General,SYSTEM,Start Wireless Connection


An update; I got me a Surface 2 Pro and have been using it for two straight days now, exact same scenario as the laptop. Surface has Win 8.1 Pro and a Marvell AVASTAR wireless network adapter and there are no problems whatsoever. The problems with the MSI laptop and 2230 continues.

Is this issue being looked into by Intel or should I just ditch the 2230 and put in another wireless adapter?


The log appears to indicate a problem with the profile (association failure). You may try deleting the profiles to try again, or with the connection as unsecured, just for testing. Updating the router's firmware may also help.


I have tried uninstalling/reinstalling the PROSet software several times, in the process removing all settings and profiles. This has made no difference. Also tried changing various configuration settings without success. The router firmware is distributed centrally by my ISP and I have the latest firmware.

As mentioned previously the connection is continuously limited when using PROSet but full access when letting Windows handle the connection, albeit then I get the occasional connect drops that prompted me to post here in the first place. No other wireless device (10 of them running different O/S's and wireless adapters) suffers from this or any other kind of problem.

I have not tried running unsecured connection but then, if it worked, what would that tell me?


Just to see if it is related to the security/encryption configuration.