Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Toa_Of_Justice
Beginner
1,230 Views

Application auto launch: How to start Firefox with your profile

I appreciate the ability to automatically launch an application whenever I connect to a certain wireless network ("Enable Intel connection settings" in Control Panel\Network and Internet\Manage Wireless Networks). However, when I choose to launch Firefox, it launches without my profile.

I located the profile folder according to the directions at "https://support.mozilla.org/en-US/questions/830656 How can I determine which profile Firefox 3 is currently using?". I was greeted with this error message upon trying to open the profile folder:

I tried to set my application path using a http://kb.mozillazine.org/Starting_your_Mozilla_application_with_a_specified_profile command line argument, but that resulted in a message indicating that my program path was invalid.

My workaround was to create a batch file that started Firefox, then I set my application path to that batch file.

On my Windows 7 x64 PC, the text of my batch file is (including quotes):

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

Please let me know whether or not my workaround works for you.

0 Kudos
3 Replies
ASouz7
Honored Contributor II
76 Views

Toa_Of_Justice,

We also would like to add that if the application launches, it means that this particular wireless function is working as it should. However, if it is not loading the profile, we recommend to contact Mozilla* for further assistance. For your convenience, here is the link to their support: https://support.mozilla.org/en-US/ Mozilla Support

Addtionally, as workaround, it is possible to create a task by using Windows* Task Manager, of course, the type of task created will depend entirely on what you need it to do.

Toa_Of_Justice
Beginner
76 Views

It seems my batch file trick didn't work after all. I will contact Mozilla support as you suggested.

Toa_Of_Justice
Beginner
76 Views

I contacted Mozilla support, and they helped me fix my batch file. However, the auto launch feature didn't launch my batch file when I first started my PC and connected to the wireless network. Only when I flipped the auto launch switch on and off did it work. (Each time, the network disconnected and reconnected with the new settings.) Could you please help me figure out why my batch file didn't launch the first time? I appreciate your help.

EDIT: My problem has been https://support.mozilla.org/en-US/questions/1119385# answer-871570 solved. Thank you for your assistance.

Reply