Issues related to Intel® Wireless Adapters and technologies
5974 Discussions

Disconnection Issues WiFi Link 5100 agn.


I am running Windows 7 Home Premium 64-bit on a Dell Studio 1555. Intel WiFi Link 5100 AGN, driver version: Microsoft Virtual WiFi Miniport Adapter, driver version: 6.1.7600.16385.

Backstory: It all started when, one day, months ago, the internet was very slow. All of my devices were being affected similarly, so I concluded that the problem must be with the router or the ISP itself (I learned later that Comcast "oversold" our area, and the resultant congestion caused the slowdown). I reset the cable modem/router, but this didn't solve the slowness (duh). The speed eventually returned to normal without further intervention, and all my devices connected normally again—except for my laptop. The problem, in detail, is as follows:

Sometimes the computer will disconnect from the internet. When this happens, in the system tray I see the yellow exclamation point in front of the WiFi bars symbol. Hovering over the symbol reveals the message "no network access." For months, right-clicking on that icon and selecting "troubleshoot problems" would fix the problem (which Windows Network Diagnostics listed as "default gateway not available") by resetting the wireless network adapter. Recently, however, this is no longer sufficient. Now Windows Network Diagnostics will try to solve the problem, but it will fail. Sometimes it will list the problem, like before, as "default gateway not available," and sometimes it won't even be able to identify the problem.

Once the problem has occurred, opening the Network and Sharing Center and navigating to "change adapter settings" shows that the WiFi adapters have been disabled. I did not disable them, and it won't let me re-enable them. If I try to, I will see the "enabling" message, but this process will get hung up forever and the adapter will not be enabled.

If I try to restart my computer after this problem has occurred, the system will hang at the "Shutting Down" screen, and I will be forced to turn the computer off by holding down the power button. After restarting Windows, it will allow me to enable the WiFi adapters, and everything will behave normally until the problem happens again, which it always does.

Here is a list of what troubleshooting steps I can remember having done:

  • I have tried deleting all my computer's stored wireless networks and rejoining them.
  • I have tried uninstalling/re-installing/updating Intel wireless adapter drivers.
  • When the system hangs trying to enable the adapters, I have tried restarting the WLAN AutoConfig process but this will fail and produce the error message: "Windows could not stop the WLAN AutoConfig service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion." Trying to restart the dependencies for that service yield various other error messages.
  • I have tried turning off (TCP/IPv6) in the properties for the Intel WiFi adapter (I turned it back on when this solved nothing).
  • I have tried resetting TCP/IP in the command prompt.
  • I have tried resetting the Winsock catalogue in the command prompt.
  • I experience no connectivity issues with any of my other devices, and the laptop's connectivity issues do not occur with any other wireless networks.

I am in over my head. I appreciate any help.



0 Kudos
2 Replies

I wonder how often the issue happens so you can try to reproduce it in safe mode with networking.

You may also try sfc /scannow in CMD.


Well this sounds just like my situation ( except mine is Time Warner, new modem, and all computers stay on, but not my Lenovo Windows 7 laptop) so almost to a T ....anyhow since your desperate, as I have been, I signed up on this website, so I can offer you what I believe may end up being a solution for you, I did massive internet search and tried almost all of what you also tried, and here is what I found that actually seems to be helping me. So its something else to try, hope that it helps:

Got this on another website:https://social.technet.microsoft.com/Forums/windows/en-US/f9b835f2-c2da-43b9-883f-2b2a157c3921/unabl...


( go to services) and then click on these and make sure they are automatic and started: 

CNG Key Isolation.


Remote Procedure Call RPC, and

Remote Procedure Call RPC Locator.

DCOM Server Process Launcher.

RPC Endpoint Mapper.

Network Location Awareness.

After u have started all those services and turned as Automatic start up then select

EAP(extensible Authentication Protocol) and right click set it as Automatic,

and start it. and then the same with WLan Autoconfig