Community
cancel
Showing results for 
Search instead for 
Did you mean: 
myne
Beginner
128 Views

Dual Band Wireless-AC 3168 freezes PC when downloading at ~50mbit

Haven't found any other posts on this issue. They all seem to relate to BSODs but this doesn't.

Asrock Z390m-itx/ac which comes with the intel AC 3168.

Haven't used wifi much until I moved. Can't use ethernet.

Normal browsing and short downloads are fine, but when loaded, whether that's netflix, amazon, or another fast download for an extended period the pc completely freezes. It locks particularly reliably with the torrent based downloader for "snappy driver installer".

Hard lock. No mouse. Numlock doesn't switch, sleep button... doesn't, screen stuck on whatever second it crashed and if sound was playing, the last fraction of a second of buffer looping. The only option is to turn it off.

There are no events in eventviewer. There is only "the last shutdown was unexpected."

It is stable under all other circumstances. It'll loop a stress test for days if I want it to. It is only while downloading and only on wifi. 

I can only assume that the kernel is locking because of the card. Haven't seen that kind of behaviour since windows 9x.

Tried several drivers. WHQL, most recent (which supposedly fixed BSODs), and others. No change. Downloading = lock.

 Win 10 20H2

Maybe there's some settings I can turn off like ns offload?

Is intel aware of continuing issues with this card? Is it just mine that's a dud?

0 Kudos
7 Replies
Sebastian_M_Intel
Moderator
94 Views

Hello myne, 

 

Thank you for posting on the Intel® communities.   

 

In order to better assist you, please provide the following: 

 

1. Run the Intel® System Support Utility (Intel® SSU) and attach the report generated:   

  • Open the application, check the "Everything" box, and click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View".    
  • Click on the menu where it says "Summary" to change to "Detailed View".    
  • To save your scan, click on "Next", then "Save".    
  • Use the option under the reply window to attach the report to the thread (Drag and drop here or browse files to attach).   

 

2. Are you having issues with Bluetooth also or only Wi-Fi?  

3. Were you able to have you wireless connection in a normal/expected performance before? If yes, did you make any changes before the issue started?  

 

Regards, 

 

Sebastian M  

Intel Customer Support Technician


myne
Beginner
89 Views

Thanks for replying. 

1: Attached. Note I tried the WHQL driver again and it's still on that. Still does it.

2: I don't use bluetooth enough to notice. It seemed ok the few times I did use it. 

3: As I said, I didn't really use the wireless (I prefer ethernet for exactly these reasons) until I moved. So I don't know how it would have been until recently. No changes except for the usual windows updates in the past few months.

All I know is that this is quite reliably repeatable. Open Prime at full quality and wait. Or open SDU RUS and wait less time. It did not do this on ethernet. It has to be the wifi.

 

Sebastian_M_Intel
Moderator
83 Views

Hello myne,  

 

Thank you for your reply. 

 

Please try the following steps and let us know about the outcome: 

 

1. Try a clean install of the wireless drivers following these steps to the letter: https://www.intel.com/content/www/us/en/support/articles/000022173/network-and-io/wireless.html  

 

Step 1: Download and save the drivers on your computer: 

 

Step 2: Uninstall the Wi-Fi driver. 

  1. Uninstall your Wi-Fi driver. 
    1. Go to Device Manager
    2. Expand the Network Adapters category. 
    3. Right-click your Intel Wireless Adapter and choose to uninstall it. 
    4. Make sure to select the option to Delete the driver software for this device
    5. Repeat steps A through D until the option to Delete the driver software for this device is greyed out. 

 

2. Restart your computer. 

 

Step 3: Driver installation. 

Locate the drivers you downloaded back in Step 1. Run as administrator, and follow the wizard to completion. To run as administrator, right-click over the file you downloaded and select the option to Run as administrator. You should test first the driver provided by ASRock as they have been validated to work with your system, if that does not work then you can do the same procedure with the Intel generic driver.  

 

2. Set the recommended settings for 802.11AC Connectivity: https://www.intel.com/content/www/us/en/support/articles/000024678/network-and-io/wireless.html  

 

3. Set the wireless card to Maximum Performance: https://www.intel.com/content/www/us/en/support/articles/000005879/network-and-io/wireless.html  

 

4. Have you checked if this issue happens regardless of the network configuration? I.e. happens connected to the 2.4 GHz and 5GHz band, happens in different networks, different routers/APs, etc. Please provide your router/AP model number. 

 

Regards,  

  

Sebastian M   

Intel Customer Support Technician


myne
Beginner
78 Views

I've tried multiple versions of drivers. Yes, uninstalling, installing different. It still does it.

Asrock have the old 21.10.1.2 drivers. Yes. Tried them. Tried WHQL. Tried WiFi_21.120.0, WiFi_22.10.0

(Which I might note "addressed" flaws with the driver that crashed windows. From the release notes: "Windows* Stop Errors (BSOD) may occur which are associated the Intel Wireless driver")

Power has been set to max and done it, power saving off and done it. NS offload on/off and done it. 2.4ghz it does it, 5ghz it does it.

Just to refresh your memory it freezes the PC.  Complete lock up. It will run whatever stress test you like. Prime95? Furmark? Memtest? XTU stress? Endlessly. But it completely freezes when the wireless is downloading at a decent speed.

The AP is an archer VR400.

IF a wireless AP can do that to a PC because the PC is downloading, that's not a problem with the AP. It's a problem with the wireless card/driver not handling something correctly and crashing the kernel so badly it can't even BSOD properly. 

Honestly, I don't get where you're going with this. It reads like just your generic copy paste from the generic troubleshooting flow chart "have you tried turning it off and on again" which I already addressed in the first post. Which... frankly it doesn't seem like you read.

 

I have to wonder are "you" an "AI"?

Sebastian_M_Intel
Moderator
52 Views

Hello myne,   

 

Based on what we have done so far, this seems to be a hardware problem instead of a driver one. 

 

You can reinstall the Operating System (OS) to rule out any software issues, you can follow Microsoft's recommendations https://www.microsoft.com/en-us/software-download/windows10startfresh  

 

It can also be a problem of the software "snappy driver installer", as this may violate copyrights, you may check with the software developer for more help. 

 

If that does not work, you must contact your motherboard manufacturer for further help on a physical inspection or a replacement.  

 

Regards,   

   

Sebastian M    

Intel Customer Support Technician

 

Links to third-party sites and references to third-party trademarks are provided for convenience and illustrative purposes only. Unless explicitly stated, Intel® is not responsible for the contents of such links, and no third-party endorsement of Intel or any of its products is implied. 

 

myne
Beginner
44 Views

I guess I'll have to get a realtek wireless card. 

Sebastian_M_Intel
Moderator
26 Views

Hello myne,    

 

We strongly believe this issue is a hardware problem. 

 

Our recommendation is to work with the board maker for additional help, chances are you need a physical inspection or a replacement. 

 

Based on that, we will close this inquiry; if you need further help, please submit a new question and we will gladly assist you.  

 

Regards,    

    

Sebastian M     

Intel Customer Support Technician