Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AMaso2
Beginner
960 Views

Dual band AC 7260 and Netgear R7000, no AC connection, very slow speeds

mITX build with Gigabyte z97n-WIFI with onboard intel dual band AC 7260 in an mPCIe slot. I also have a netgear R7000 router. I can't get the thing to connect via 5GHz AC, only via 5GHz N. Speeds hover around 27Mbs as well. I've turned on WMM in the intel client, as well as thoroughput booster. Did nothing. I've updated to the latest Windows 7 64 Proset drivers for wifi and Bluetooth. Still nothing. Any pointers?

Cheers,

Alex

0 Kudos
2 Replies
ASouz7
Honored Contributor II
34 Views

Hello withalligators,

Could you please try the following configurations by accessing advanced settings on the card and the configurations on the router?

Preferred Band: Prefer 5.2GHz band

  1. 802.11n channel width for band 5.2: Auto (not in 20 MHz only)
  2. 802.11n mode: Enabled

Fat channel intolerant: Disabled

Roaming aggressiveness: lowest

Throughput enhancement: Disabled

Transmit Power: 5. Highest

Wireless mode: 802.11a/b/g

HT mode: VHT mode

On the router, you could try different channels

Auto channel scan: Disable

Set router Channel width to 40 MHz (mixed mode) try channels 36, 44, or 48.

  1. 802.11 mode: Use 802.11n only

Enable WMM (Wi-Fi multimedia) settings

Let us know if this helped you.

AMaso2
Beginner
34 Views

Hey,

I tried all this but couldn't get anything better out of it. I got a sweet deal on a new MB though, and this one has a Broadcom card on it. Still having some trouble, but better speeds than before. Regardless, thanks for the help.

Cheers,

Alex