Community
cancel
Showing results for 
Search instead for 
Did you mean: 
BB4
New Contributor II
1,597 Views

How I got 7260AC to work without drops, after sleep, and at rated speeds

One guy's solution to getting his 7260AC network adapter working and connected consistently, with optimal speeds:

The players:

Thinkpad T440p, bought December, 2013. Core i5 4300M, FHD Display 1920 x 1080

Hardware upgrades, from the low-end basics offered, knowing that I was going to put in better stuff:

  • Samsung 840 Evo, 1TB
  • RAM, GSkill 16GB (2 x 8G) DDR3 1600 (PC3 12800) Class 9

TP-Link Archer D7 modem/router. There is one firmware update but I haven't run it. Release notes describe a couple of issues that I'm not having. I am a believer in not fixing what isn't broken.

OS: Win 7 Pro 64. Fresh install from a downloaded.iso, activated with the CoA that came with the OEM install from Lenovo.

Drivers from Lenovo:

  • fingerprint reader
  • onscreen display/hot keys
  • SDHC card reader
  • trackpad
  • camera

No Lenovo "helpful" utilities.

Drivers from providers:

  • Sound from Realtek

From Intel

  • chipset
  • 4600 graphics
  • ethernet
  • wireless
  • bluetooth
  • Rapid Start

All others are generic MS.

Sequence:

  1. Downloaded chipset driver and graphics from Intel, saved to USB key.
  2. Install Windows from iso burned to DVD.
  3. After restart, install chipset, restart.
  4. Install graphics so I could see better than the VGA that came up on install.
  5. Next, navigate to Intel and run driver update. Installed what it found. I don't remember versions that far back.
  6. Then, installed Lenovo Update to let it search for what it wanted to install. I hid everything it found except for those devices noted above. Installed from there.

_____________________________________________________

Conditions of use: I live in a baroque-construction cut stone house in Italy on three levels that is very unfriendly to wireless on the 5Ghz band. The ADSL2 modem/router, two band, is located on the middle level. The signal will barely penetrate the ceiling. With the Thinkpad on the top level, connection speed is limited to double digits, typically no more than 20 Mbps. Up here, from where I'm writing, I use the 2 band. Windows' network status tells me I'm getting 216 to 270 right now, with spikes to 300.

In proximity to the modem on the second level, I get 750-866 on the 5 band no sweat. On the lower level, about 350. On the lower level on the 2 band, 300 steady.

_____________________________________________________

I picked up this Thinkpad in the US at the end of January, 2014. Problems noted early on:

1) Thinkpad often wouldn't shut down. Would hang after leaving Windows but wouldn't turn off without hard button press. Solution found at Lenovo Forum to update the fingerprint driver. Fixed.

2) Turning on bluetooth, to talk to my tablet, would cause the wireless to disconnect. Had to restart the Thinkpad to reconnect. Solution: set broadcast channel in router to 1, on the 2GHz band. Default channel had been "Auto".

_____________________________________________________

Things seemed to be fine for quite a while, until I got the bug to experiment with later wireless drivers. I had gotten on 16.6 pretty early and all was well. This was the full install of the driver package which included ProSet, but I never used any of that software, letting Windows manage my connections.

Then, I switched to 16.8 sometime in April I think it was, and I found that the wireless connection was off and wouldn't reconnect after sleep, in my case, Deep Sleep aka Intel Rapid Start sleep on the hibernation partition. But I don't think the type of sleep/hibernation matters. Others are having the problem who don't use RST.

I was traveling away from the Thinkpad off and on at that time and I think that I just didn't put that together with the driver. So I kept trying with the later slew of drivers, into the 17s. Then I started to rethink what I'd done after reading more and more threads here and elsewhere about peeps talking about drivers. I kept messing around with the ProSet app and it didn't do anything to help. Restarting the Thinkpad would connect. Uninstalling/reinstalling the adapter in Device Manager would connect. Disabling/enabling would connect.

This was not optimal and all the online talk about drivers, and some concerted study about wireless connections, router settings, and bands finally hit me with the clue-by-four. Roll it back to when it worked.

So I cleared the table. I deleted ProSet from the PC. I uninstalled the adapter. I downloaded the IT Administrator's Set of drivers from Intel for the earliest version that I could find, which is numbered 16.10.0. This driver, when installed with the re-installed adapter shows in Device Manager as 16.6.0.8, dated 10/14/13. The 16.6 is the one that I remember working, and which was also cited by others, for example at notebookreview.com.

It works. It doesn't disconnect. It's on when the Thinkpad wakes up. It gets maximum rated speeds per band under optimal conditions of proximity.

___________________________________________________________

My wireless settings:

Bare driver from Admin Set 16.10.0 from here: https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23628 https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23628

No ProSet.

Adapter settings:

802.11n Channel Width (band 2.4/band 5.2) Both Auto

Ad Hoc Channel 802.11 b/g 1

Ad Hoc QoS Mode WMM Enabled

ARP ofload for WoWLAN Enabled

Bluetooth® AMP Enabled

GTK rekeying for WoWlan Enabled

HT Mode VHT Mode

Mixed Mode Protection CTS-to-self Enabled

NS offload for WoWLAN Enabled

Preferred Band Prefer 2.4GHZ band (because that's what I need the most where I use the PC)

Roaming Aggressiveness Medium

Sleep on WoWLAN Disconnect Disabled

Transmit Power Highest

Wake on Magic Packet Enabled

Wake on Pattern Match Enabled

Wireless Mode 802.11 a/b/g

Other settings discussed in these threads don't appear in this version/type of driver install. Under Power Management, I have "Allow the computer to turn off the device" enabled. "Allow the device to wake the computer" is disabled.

______________________________________________________________________________

Bluetooth:

17.0.1401.422 dated 12/16/13

______________________________________________________________________________

Router settings:

2GHz band

11bgn mixed mode

Channel 1

Channel width auto

SSID broadcast yes

WPA2-PSK AES

Short GI enabled

Client isolation disabled

WMM enabled

5GHZ band

11a/n/ac mixed mode

Channel Auto

Channel width Auto

SSID broacast yes

WPA2-PSK AES

That's it. No MAC filt...

4 Replies
tvete
Valued Contributor II
223 Views

Thanks. I'm using 16.8.0.6 though which never had problems whatsoever.

BB4
New Contributor II
223 Views

Edited the title to make it more relevant.

BJone12
Beginner
223 Views

Mr GattoNero sir, you are a gentleman and a scholar ! Thanks for posting this.

For anyone with an "_INTEL" username on this forum, For me (and obviously hundreds of others) AC7260 and AC3160 support is a TOTAL JOKE. Intel, why can't you create a driver or document that will clearly help all of your frustrated customers resolve this problem? Shame. Shame!!

BB4
New Contributor II
223 Views

I have an update:

I've been trying out this driver: https://www.crc.id.au/files/Intel%20AC-7260%20v17.12.0.4.exe https://www.crc.id.au/files/Intel%20AC-7260%20v17.12.0.4.exe

Another member here, CRCinAU posted this. It's version 17.12 of the driver that he got from one of the OEMs and extracted the bare driver to that executable file. It's also available at Lenovo.

I've been using it for several weeks and, unlike the other releases of v 17, it doesn't have the problem of not waking up. At this point, for my devices, I'm calling it a Release Candidate. I tried all the others and always rolled back to 16.8, as it was the only one that woke up properly. This one, 17.12, is the first one since then, almost a year later, to perform similarly on my PCs. Lenovo's release notes even mention that it was intended to fix that issue. Where they got that, I don't know, but it does seem to do that. I'll assume Intel, since they don't post release notes with their drivers--hint hint, again.

Disclaimer: these setting work for me on my PCs. Your mileage may vary. Windows 8 versions may work better with alternative settings. And I'm convinced that router chips and models also affect the equation of getting the AC part to work optimally.

Reply