Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PHolt2
Beginner
1,096 Views

How do I correct slow speeds with my AC7260?

I have a ThinkPad X1 Carbon with an AC7260 wireless adapter. It's running Windows 10 (1511), and all the drivers are current. For some reason, wireless performance is horrible, rarely getting above 2.5Mbps. I'm about 20' away from a Linksys WRT1200AC router. I have 50Mbps from my ISP (verified). Performance on the wired part of the in-house network should be in the 1GB range, so wireless should be able to run as fast as it can there. I've combed the forums, looked at and tried the various bits of conflicting advice. Nothing seems to change the outcome. Ideas?

Phil

0 Kudos
4 Replies
ASouz7
Honored Contributor II
81 Views

Hello Phil_NM,

Intel recommends that you contact your computer manufacturer first and see if they have any solution or updates that might resolve this issue. You can find their contact information right here: http://www.intel.com/support/oems.htm Computer Manufacturer Support - However, there are a some steps you can try that can also help to improve your connection:

1 - Choose the best wireless channel - most routers come by default set to channel 11 or 6. Choosing a different channel as far a spossible from these ones can help improve your speed.

2 - Set the Transmit Power to 5. Highest.

3 - Disable WMM

4 - Use AES WPA2 as it can get best throughput, however, legacy devices may not connect.

5 - Make sure you don' t have any interference from other appliances such as cordless phone, microwaves...etc as they can muck with your sginal as well.

You can also look at these other solutions:

http://www.intel.com/support/wireless/sb/CS-030709.htm?wapkw=wifi+recommended+settings Wireless Networking — What are the Recommended Settings for 802.11n Connectivity?

http://www.intel.com/support/wireless/wlan/sb/CS-030282.htm Intel® Wi-Fi Products — Why am I Not Able to Connect at 300 Mbps with My 802.11n Device?

http://www.intel.com/support/wireless/wlan/sb/CS-025332.htm Intel® Wi-Fi Products — Resolving Wi-Fi Network Connection Issues

http://www.intel.com/support/wireless/wlan/sb/CS-031509.htm Intel® Wi-Fi Products — Possible Interference by Other Wireless Devices May Impact 802.11n Performance

http://www.intel.com/support/wireless/wlan/sb/CS-006321.htm Intel® Wi-Fi Products — Access Point (AP) Firmware Updates May Resolve Wireless Network Issues

http://www.intel.com/support/wireless/wlan/sb/CS-025393.htm Intel® Wi-Fi Products — What are the Advanced Wi-Fi Adapter Settings?

http://www.intel.com/support/wireless/sb/CS-029893.htm Wireless Networking — Frequently Asked Questions - Wi-Fi

http://www.intel.com/support/wireless/wlan/sb/CS-035591.htm Intel® Wi-Fi Products — Current Top 10 Frequently Asked Questions

PHolt2
Beginner
81 Views

I've followed the steps you recommended with no appreciable change. Since there are quite a few devices in the house communicating over WiFi, interference is a potential problem, though it doesn't seem probable they are crushing the bandwidth such fractions.

ASouz7
Honored Contributor II
81 Views

Phil_NM,

Since you have tried the solutions above, please try the following below and then let us know if thsi worked for you.

Windows®10 comes with an intelligent feature that uses a lot of bandwidth that comes activated by default upon OS upgarde. It is called Windows Update Delivery Optimization (WUDO) and it is designed to help users to get faster software updates which is quite a good idea to habdle massive traffic of up to 40 Terabits per second (TBps). See illustrative picture below:/servlet/JiveServlet/showImage/2-360064-249026/WUDO.JPG

To turn this feature OFF, follow the given steps:

1. Go to Settings in the Start Menu.

2. Search for Updates & Security.

3. Under Windows Update, open Advanced Options.

4. Under Choose How Updates are Installed, select Choose How Updates are Delivered.

5. Disable the toggle under Update from More than One Place.

/thread/96201 Intel Dual Band Wireless AC 3160 slow Connection and only 2,4 GHz

PHolt2
Beginner
81 Views

I already have that feature turned off. It has been for some time.

Reply