Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7580 Discussions

How to fix slow wifi speeds after wake from sleep with modern standby on windows 10

GPfei
Novice
17,631 Views

My lenovo laptop uses an Intel AC-9560 wireless adapter. With modern standby activated, the connection after wake from sleep is extremely slow and limited to about 20Mbps. When I disconnect and connect the adapter, i get back to my normal speed of 500Mbps. Currently the only work-around is to disable modern standby in my bios. i am using the most current driver (21.50.1.1) and have been hoping for this problem to be resolved with every driver update I received.

43 Replies
AndrewG_Intel
Employee
4,532 Views

Hello GPfei,

 

We have not heard back from you, so we will close this inquiry. If you need further assistance, please post a new question.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
GPfei
Novice
4,532 Views

I will be back on friday and be able to test this right after the Christmas holidays. Sorry for the delay.

0 Kudos
AndrewG_Intel
Employee
4,532 Views

Hello GPfei,

 

We are checking this thread and we would like to know if you were able to collect the traces (packet capture) when reproducing the issue. What we would like to collect is all the back and forth process when reconnecting after sleep between the adapter and the network. You may use third-party software for this, for instance, Wireshark*.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

 

*Links to third-party sites and references to third-party trademarks are provided for convenience and illustrative purposes only. Unless explicitly stated, Intel® is not responsible for the contents of such links, and no third party endorsement of Intel® or any of its products is implied.

0 Kudos
MKOVA16
Novice
4,532 Views

Hi Andrew, I would like to follow-up on this thread, if the original poster doesn't end up getting back. I have found the exact same issue, and I am finding that it's an incredibly common problem actually -- a combination of Intel hardware not working correctly, and the Windows sleep state settings. I will let the original poster respond first, and I have to solve a completely different problem with my laptop first, but once that's settled, please let me know how I can continue this discussion directly with you -- so there's a degree of continuity in troubleshooting and solving.

0 Kudos
GPfei
Novice
4,532 Views
Hi Andrew, I ran two wireshark captures after deactivating the group policy. * Capture 1: After wake from sleep; 17Mbps. Disconnect wifi and re-connecting wifi; speed back to >500 Mbps * Capture 2: Connection working as normal with >500Mbps. Close lid for sleep. Open lid and speed now <20Mbps, hovering at about 17Mbps The files are quite large, I posted them here: https://drive.google.com/open?id=1EFLg44CD9-WDa4LCfBj8tM7-7Z0uXze_ I think capture 2 is the one you wanted. I ran both after installing the latest driver that was made available to me today (version 20.60.2.1) I hope this helps. Goetz
0 Kudos
AndrewG_Intel
Employee
4,532 Views

Hello GPfei,

 

Thank you for your response and for the packet captures provided.

We will check this further and as soon as we have more details available we will be updating this thread.

 

PD: Hello MKOVA16, we understand you are experiencing the same issue but since you will need to work on a different issue with your laptop first if this issue persists we recommend you to post a new thread to better assist you and you may provide this thread as a reference.

 

Best regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
AndrewG_Intel
Employee
4,532 Views

Hello GPfei,

 

We have been investigating this behavior and we would like to recommend the following steps. Please report back the outcome:

 

1- Go to the device manager ->expand network adapters -> Intel® Wireless-AC 9560 -> Right-click -> Properties -> Advanced -> MIMO power save mode -> Change "Auto SMPS" to "No SMPS". And test.

 

2- Also, please go to the Windows Settings App -> System -> Power & Sleep -> When my PC is asleep and on battery power, disconnect from the network -> Change "Never" to "Always.

 

We will be looking forward to hearing back from you regarding the outcome of these tests.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
AndrewG_Intel
Employee
4,532 Views

Hello GPfei,

 

We are checking this thread and we would like to know if you were able to check the last recommendations provided. Please feel free to report back the outcome and to let us know if the issue is solved or still persists.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
GPfei
Novice
4,531 Views
Hi Andrew, I did try both of the options before I opened this topic on the forum and just did run the tests again. * Auto SMPS off * Disconnect from network to always * With auto smps off and * With auto smps on I was surprised to find that there is no change of behaviour when I did this a few months ago and even with the most current driver testing it again today, the problem did persist without any change. For some reason the change of the group policy seems to be the only reliable workaround for me. Thank you for your ongoing help! Goetz
0 Kudos
AndrewG_Intel
Employee
4,532 Views

Hello GPfei,

 

Thank you for your response and the details provided.

 

Please allow us to investigate more on this behavior and as soon as we have more information available we will be posting back on this thread. Thank you for your patience in this matter.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
AndrewG_Intel
Employee
4,532 Views

Hello GPfei,

 

We would like to know if you were able to check and test our previous recommendations.

Please feel free to share the outcome of the tests.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
RCham10
Beginner
4,532 Views

I am interested in this as I have a Dell with exactly the same problem. It is actively being worked on this thread too. https://forums.intel.com/s/question/0D50P00004Z135pSAB/how-to-improve-the-network-speed?language=en_US

Richard

0 Kudos
AndrewG_Intel
Employee
4,532 Views

Hello RCham10

 

Thank you for posting on the Intel® communities.

 

Even though you have a similar issue, it seems it is not strictly related to Windows® modern standby. In this case, our recommendation is that you continue the support on your own thread. I can see that we are doing research to provide more information about this problem.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
RCham10
Beginner
4,532 Views

Hi Andrew,

I shall do that, but it's still fair to say that the symptoms are extremely similar.

The workaround that I am using which has so far been effective is to change the Adapter advanced properties from Enabled (Default) to Disabled for the both

'Wake of magic package' and the 'Wake on pattern match'.

Richard

0 Kudos
AndrewG_Intel
Employee
4,532 Views

Hello RCham10

 

Thank you for your response and for sharing the details of the workaround you found. This feedback is really appreciated and hopefully, it may be helpful for other community members.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
AndrewG_Intel
Employee
4,532 Views

Hello GPfei,

 

Thank you for your patience in this matter.

We have sent you a private message with more details regarding this behavior.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
AndrewG_Intel
Employee
4,531 Views

Hello GPfei,

 

We would like to know if you were able to check the private message we sent you. Please let us know any feedback or additional concerns.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
GPfei
Novice
4,532 Views
Hi Andrew, I did uninstall and completely remove the driver once at the beginning of our conversation. I now did it again, but it has not resolved the situation. I will create a post and support request with Lenovo as well. Best regards Goetz
0 Kudos
AndrewG_Intel
Employee
4,531 Views

Hello GPfei,

 

Thank you for your response and the details provided.

We are still checking this behavior and we would appreciate it if you share any feedback you may get from Lenovo™ while working with them. Please feel free to post back in this thread.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
AndrewG_Intel
Employee
4,500 Views

Hello GPfei,

 

We would like to know if you were able to work on this issue with your laptop manufacturer and if they provided you any feedback.

 

Also, you may disable Modern Standby from Windows® settings directly following the steps in the attached image. Please let us know the outcome.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
AndrewG_Intel
Employee
4,501 Views

Hello GPfei,

 

We would like to know if you were able to try disabling Modern Standby from Windows® settings and if the behavior was better.

 

Also, were you able to work with your OEM and did they provide you with any feedback that you can share while we still work on this issue?

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
Reply