Issues related to Intel® Wireless Adapters and technologies
6404 Discussions

Intel 7260N Can't Connect to network


Summary of my problem to date, I purchased a laptop with an intel 7260 N wireless card (lenovo yoga 2 pro). Running windows 8.1

My computer successfully detects wireless networks and I can connect to 2 of the 3 network I have access too.


One being my school wifi and the other being my tethered lte from my galaxy s3.

However, it is my home network that gives me problems. I can successfully see the network, and if I enter an invalid security key it detects it is invalid and asks for the correct one. However, upon entering the correct key WPA2 key I get a can not connect to network.


The network I speak of is a bell dsl internet network with a 2.4gHz modem/router combination that bell provides you with. It is a 2wire modem.

This really puzzles me, every other computer in my house can connect to this modem no problem.


So far I have tried to connect with my lenovo running the stock 16.0 drivers. 16.5.6, 16.6.6, 16,6,7 (which only installed the 16.6.6 driver) and even the 16.8 drivers extracted from the dell package for the 7260AC model of the modem. Of course the dell runs the 7260N.

I have also played with the wireless setting like HT mode plus many more. Not change. I have changed all my power setting to not turn off my network card for power saving etc as per one of the tutorials and yet I can not figure out how to fix this problem.

Is it possible it is a driver problem and the driver is incompatible with a specific modem?? Is it a problem with the windows 8 drivers? I tried installing windows 7 drivers however the system autoupdates my wireless drivers to the stock ones that came with the computer when i uninstall the device and it wont all me to install the 7 drivers bc they are older. (I tried removing the drivers folder in the D drive but it still installed the stock drivers).

0 Kudos
1 Reply

I am sorry for this issue.

Is it possible that your router has a MAC filter enabled? Can you also test with the connection as unsecured?

You may also check for a router's firmware update.