Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CReve
Novice
5,865 Views

Intel 8265 ac constant high latency jitter

I have a new laptop with an intel 8265ac wifi card in it. The card connects fine, downloads fine, etc, but there is very high latency issues. In general, every few seconds, the card's latency just spikes.

Even running a ping command to my wireless modem often shows pings north of 100ms, just to the modem.

There are two other devices in my house that use intel wifi cards. One is an intel 7260ac card and one is an intel 8260ac card. Both connect to the same network without any problems or ping spikes in that manner; only this new 8265ac wifi card does.

I can access my full, consistent download. I can watch streaming sites like twitch.tv just fine, and I can watch video playback sites like Youtube just fine. I simply notice some issues with voice chat via programs like Teamspeak 3 or Discord, and I am unable to play reaction-based online multiplayer games as a result of the constant spikes.

The OS is windows 8.1 Pro x64.

The power plan is "High Performance", and "prefer maximum performance" is selected.

WLAN Optimizer has been used (as it fixed intermittent spikes on both the 7260ac and 8260ac in the past) but seems to have zero effect on the 8265ac. The card also does not seem to spike ping when I manually search for networks, unlike the 7260ac/8260ac. It makes me feel that for some reason it is constantly searching no matter what I want, and is giving me bad performance as a result.

Note that the roaming aggressiveness of the card is left at the default "3. Medium", if that makes any difference.

Any more information that can be provided by me I shall be happy to provide; simply ask for it. If I just have a bad card, then so be it. But I really hope it isn't the case.

33 Replies
CReve
Novice
831 Views

Here is a shot of command prompt explaining the latency issue:

https://hostr.co/file/we3O4M69B35F/Screenshot2898.png

idata
Community Manager
831 Views

Hello D2ultima,

 

 

Latency and ping spikes can happen for different reasons. We see that you already tried some actions that normally help in this matter. Please check these recommendations as well:

 

 

- Try placing the computer closer to the access point and away from possible sources of interference (Bluetooth* devices, cordless phones, microwaves, etc.), then let us know if this helps.

 

 

- Contact the http://www.intel.com/content/www/us/en/support/topics/OEMs.html Computer Manufacturer Support and make sure you are using their recommended drivers.

 

 

For further assistance, please let us know the following information:

 

 

- Wireless Access Point model and firmware version.

 

 

- https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility Download Intel® System Support Utility, run the tool and use it to create a report with all sections, on the next screen, Save the report to a file. Then use the Advanced editor options to add the resulting XML file to your post as an attachment.

 

 

Regards,

 

Jonathan B.
CReve
Novice
831 Views

The laptop is approximately 10 feet from the wireless modem. It is in the exact spot as the laptop that has the 7260ac card used to be in. There is nothing that should cause any sort of interference like this here. This is a jitter problem directly to the modem, without even touching the "internet". All other devices in the house work fine.

Windows 8.1 only has three driver versions open to it. There is not much else to "try".

Here is the report:

** Edited by Moderator to remove Log posted in text format (see log in attachment) **

In case adding all of this did not work well, I've also attached the file.

idata
Community Manager
831 Views

Hello D2ultima,

 

 

We checked the log and would like to provide the following recommendations:

 

 

- Go to the Advanced Driver settings in Device Manager and set the U-APSD support to: Disabled. This may help with some access points. If the issue persists, you can set it back to Enabled.

 

 

- The Signal Strength shows 88%, this should be enough to have a reliable connection, however, for troubleshooting, try changing the position of the computer, or placing it closer to the Access point, then check if this helps.

 

 

- Try disabling the Bluetooth* component in your computer and check if the connection improves. This is normally done with a switch in the PC chassis, or with a key combination.

 

 

Regards,

 

Jonathan B.
CReve
Novice
831 Views

Ah, right. I turned on U-APSD in the first place to see if it would help (it does, slightly). It was initially disabled. I've manually checked almost every single QoS setting on the card, including raising/lowering the roaming aggressiveness.

Honestly, any closer to the access point and I could just use Ethernet. It's that close.

I disabled the bluetooth component by disabling it directly in device manager. No change.

idata
Community Manager
831 Views

Hello D2ultima,

 

 

Was the PC next to the access point at the time you retrieved the log? it would be weird to see 88% in the Signal Strength being so close. If this is the case, you might want to check with the Computer Manufacturer as well.

 

 

On the other hand, the screenshot you sent was not attached properly, please post it again, and if possible, use the command prompt and run a continuous ping to the default gateway, then post the result as well.

 

 

Regards,

 

Jonathan B.
CReve
Novice
831 Views

It is no more than 10 feet from the wireless modem (due to room design/positioning I cannot run an Ethernet cable from this point, though). The range on the modem isn't the best, but all other devices work fine (even from further away than this one). In fact, going by signal strength (number of bars) I often see the 7260ac unit in the same spot as this unit drop to 4/5 signal strength in windows sometimes. So, to be absolutely certain, this has BETTER signal strength than the other device which works perfectly fine.

I have contacted the sellers and informed them about the issue. Also, I've checked and the antennas are plugged in correctly.

Am I to understand that this is a faulty card, or is it a driver issue from using Windows 8.1? This is the main thing I am trying to determine.

idata
Community Manager
831 Views

Hello D2ultima,

 

 

The Intel® Dual Band Wireless-AC 8265 is actually a reliable adapter and shouldn't have any issues working in Windows* 8.1. Nevertheless, it is always possible for the driver to have problems with the operating system, or other software specific to your computer; also, it can be faulty hardware. For this reason, we advise you to check on this with the OEM (computer manufacturer) since they would be the best source to confirm this.

 

 

If what you are experiencing is ping spikes caused by wireless background scans, you might want to consider the actions mentioned by Vigz in the following thread:

 

 

/message/246711# 246711 AC 7260 frequent ping spikes

 

 

Regards,

 

Jonathan.
CReve
Novice
831 Views

I already did that, actually. It's what WLAN Optimizer is supposed to do, but it wasn't working, so I did the edit. I'm going to guess that this card is probably then faulty. I'll ask my OEM about a warranty exchange for it.

I had indeed figured it was very odd, but at least I know for certain now.

idata
Community Manager
831 Views

Hello D2ultima,

 

 

Since the issue persists after all the actions we tried, then contacting the Computer Manufacturer is the best course of action. We hope you are satisfied with the assistance provided.

 

 

Feel free to contact us if you have any additional questions.

 

 

Regards,

 

Jonathan B.
CReve
Novice
831 Views

No problem; it does seem to be a hardware issue of some kind. The OS was freshly installed only 6 days ago and from the second day when I tried using teamspeak 3 and the like, I noticed the jitter issue being high. I thought it was my ISP but I asked my sister to check her connection to the same server and hers was fine, so I determined it was probably the card. Thanks for trying, even if all you did was confirm my own testing that there is nothing further one can do on the software side of things.

NAspi
Novice
831 Views

I have two problems with my 8265, the effects of which sound similar to what D2ultima is seeing. I am using Windows 10 with the latest drivers (19.50.1). I have tried a clean reinstall of Windows 10 and the drivers and it made no difference to these problems.

Problem 1: Every ten minutes there is a brief latency spike. For example if I have Pingplotter set to ping my router every second, then at exactly ten minute intervals the ping will jump from the normal 1-2ms up to 50-100ms, for one or two pings.

This is similar to behaviour observed with the Intel 7260 Wireless-AC card that I was previously using. With that card, the spikes could be prevented by using http://www.martin-majowski.de/ WLAN Optimizer with "streaming mode" enabled. (As a technical aside, this application works by calling the Windows WLAN API function https://msdn.microsoft.com/en-us/library/windows/desktop/ms706791(v=vs.85).aspx WlanSetInterface with the "wlan_intf_opcode_media_streaming_mode" flag enabled.) However as D2ultima noted above, this seems to have no effect on the behaviour of the 8265.

The real-world impact of this problem is a brief increase in latency every ten minutes, most noticeable during online gaming where the increased latency causes lag.

Problem 2: At seemingly random intervals the card/driver stops and restarts the security of the wireless connection. This is seen in the Windows Event Viewer in the WLAN-Autoconfig log as a group of three events: "Wireless security stopped", "Wireless security started", "Wireless security succeeded". The three events all happen within the space of one second. The restarts may happen just once in isolation or they may happen several (ten or more) times in a row, with a gap of about a second between restarts.

The effect of this is similar to the connection being briefly dropped, leading to packet loss. For example in the Pingplotter test described above, one or two pings to the router will be completely lost when this happens. However Windows doesn't consider the connection to have been dropped, as the connection duration displayed still correctly reflects the time since the connection was established.

(As below, this was caused by the router switching channels.)

Is there anything that can be done to alleviate or at least explain these problems? If nothing else, please could this feedback be provided to the Intel Wifi driver team in the hope that they can reproduce and fix these issues?

idata
Community Manager
831 Views

Hello Trilby,

 

 

Please keep in mind that Wireless connectivity can be affected by multiple factors such as configuration, interference, access point issues, compatibility, etc. Make sure you apply the actions mentioned in previous posts.

 

Please review the following recommendations as they may help in this scenario:

 

 

- Apply the advanced driver settings mentioned in the following advisory: http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005544.html Recommended Settings for 802.11n Connectivity.

 

- Place the PC away from possible sources of interference, such as microwave ovens, power lines, or other electric devices.

 

- Check for interference or contention from other Wi-Fi networks, and try using other wireless channels.

 

- Make sure that the wireless power plan options are set for Maximum Performance.

 

 

All these items are mentioned in the document: http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005493.html Quick Checks to Improve or Fix Wireless Connection Issues.

 

 

If the issue persists, we will need the following information:

 

 

- https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility Download Intel® System Support Utility, run the tool with the connection working fine, and use it to create a report with all sections, once the report is created, click on the "Next" button. In the following screen, save the report to a file. Then use the Advanced editor options to add the resulting XML file to your post as an attachment.

 

- Let us know the access point model and firmware version.

 

 

Regards,

 

Jonathan B.
NAspi
Novice
831 Views

Further experimentation has shown that Problem 2 (wireless security restarts) was being caused by my router switching channels automatically. I've now chosen a channel manually so hopefully that's resolved.

That leaves Problem 1, that of latency spikes every ten minutes. After further investigation I'm certain that these are caused by the card scanning for networks automatically. Running the command "netsh wlan show networks" at a command prompt will show all of the WLAN networks that Windows currently knows about (without attempting to perform a scan for available networks). If I run the command between latency spikes then the network list remains the same, but if I run it before and after a spike then the list is different. From that it can be concluded that the spikes are caused by the interface scanning for networks.

While that is not really a problem under normal circumstances, I believe it should not be doing that when streaming mode is enabled for the interface (and probably not when background scan is disabled either). As I mentioned above, streaming mode and background scan can be enabled/disabled by calling the Windows WLAN API function https://msdn.microsoft.com/en-us/library/windows/desktop/ms706791(v=vs.85).aspx WlanSetInterface, and the easiest way for a user to do that is with the http://www.martin-majowski.de/ WLAN Optimizer application.

As I and D2ultima mentioned, the Intel 7260 Wireless-AC card appeared to work as expected in this regard. When put into streaming mode, it would not attempt to automatically scan for networks. However this is not the case with the 8265, and unless this is an intentional change I believe it to be a bug with the driver (or firmware?) of the card. As it stands there appears to be no way to prevent the interface from automatically scanning for networks every ten minutes. I think this needs to be brought to the attention of the Intel Wifi driver team so that they can hopefully rectify the situation.

I don't think any of the general troubleshooting steps are applicable in this case, but for the sake of argument: I've applied all of the recommended settings, ensured that there is no interference and I'm using a channel that no other nearby router is using, and my power options are set to Maximum Performance. I'm using a D-Link DIR-880L router with latest firmware 1.07WW and the output of the System Support Utility is attached.

idata
Community Manager
831 Views

Hello Trilby,

 

 

We are glad to know that one of the problems was solved by using a fixed wireless channel. Regarding the other issue, keep in mind that sporadic ping spikes due to background network scanning are normal in wireless connections, having 50-100 ms in 10 minutes intervals is not high when compared to what other users have reported.

 

 

We know there are ways to reduce this, like the ones mentioned in the /message/246711# 246711 AC 7260 related thread, for example the "ScanWhenAssociated" fix and using WLAN optimizer. However, we don't endorse/support these actions, and you can apply them at your own discretion.

 

 

In our best effort, we would like to mention some features in Windows® 10 that also may cause sporadic ping spikes, as other users have reported:

 

 

- About location services in Windows® 10:

 

 

http://windows.microsoft.com/en-us/windows-10/location-service-privacy

 

 

- WiFi Sense:

 

 

http://windows.microsoft.com/en-us/windows-10/wi-fi-sense-faq

 

 

- P2P updates in Windows*:

 

 

https://communities.intel.com/thread/78067 https://communities.intel.com/thread/78067

 

 

*Note: These links are being offered for your convenience and should not be viewed as an endorsement by Intel of the content, products, or services offered there.

 

 

We checked the SSU log provided and there are a few things to consider:

 

 

Receive Rate: 780 Mbps

 

Transmit Rate: 780 Mbps

 

Signal Strength: 95%

 

 

An optimal 802.11ac 2x2 connection would have a rate of 867 Mbps and 99% signal strength. Maybe changing the antenna position, or using the Access point closer to the PC would help.

 

 

Regards,

 

Jonathan B.
NAspi
Novice
831 Views

Ping spikes due to background network scans aren't normal or acceptable if you have explicitly asked your Wifi adapter not to perform them. Regardless of any other method of doing that, Windows 10 has a user interface option specifically designed for it, which is accessed from Control Panel -> Network and Sharing Centre -> (Connection Name) -> Wireless Properties. I've attached a screenshot of what it looks like on my system. If the option "Look for other wireless networks while connected to this network" is unchecked (as it is by default) then the adapter should not be automatically scanning for other networks, but the 8265 appears to disregard this option.

For the reasons I described in my previous post, I know that the latency spikes correspond exactly to instances of the adapter performing automatic network scans, and are not caused by any other Windows functionality. For the avoidance of doubt: Windows Location services, Wifi Sense and peer-to-peer updates ("Updates from more than one place") are and always have been disabled on my system.

I realise that 99% signal strength is better than 95%, but I don't think the extra 4% is going to make a difference to this problem. Regardless, as I write this my signal strength is showing 99% and the latency spike problem is still occurring, so that avenue of investigation can be discarded.

My use case for this adapter is connecting to one and only one access point, and I never need the adapter to know about any other access points. I'm fairly certain that I can't be the only person in that situation, as it seems typical of a home user who has one wireless router for internet access. It's fine if the adapter performs automatic network scans as its default behaviour, but there needs to be some way for users to override that behaviour so that they can maintain a consistent and uninterrupted connection to a single access point if they decide to do so.

If the ScanWhenAssocated registry setting and the WLAN Optimizer application aren't endorsed or supported (and they also have no effect), and the Windows option "Look for other wireless networks..." described above also has no effect, then what is the correct and supported way to prevent this adapter from automatically scanning for networks? If there is no way, then what is the procedure for requesting that it be added in a future driver update?

idata
Community Manager
831 Views

Hello Trilby,

 

 

Thank you for all the details you provided. We will look into this with our additional resources and will be updating as soon as we have more information about it.

 

 

Regards,

 

Jonathan B.
idata
Community Manager
831 Views

Hello Trilby,

 

 

This is likely caused by the periodic background scan.\

 

 

Currently there is no way to disable this, the ScanWhenAssocated registry key has been removed in the recent drivers thus has no effect. We have placed a request with our development team to bring this back on a future driver version, but we cannot make any promises.

 

 

A potential workaround that may mitigate the issue is to try to disable the wireless band(2.4G or 5G) that is not used in order to reduce the number of channels for scanning.

 

 

For e.g if you use the 2.4G band, you can try to set Wireless Mode to 802.11g or 802.11b/g or if you use the 5G band then set this to 802.11a.

 

 

Note the WiFi card will not be able to connect to other network on the frequency band that has been disabled in the above setting.

 

 

Best regards,

 

Carlos A.
idata
Community Manager
831 Views

Hello Trilby,

 

 

Please let us know if the information provided helped to clarify your inquiry, or if you have any additional questions.

 

 

Regards,

 

Jonathan B.
NAspi
Novice
321 Views

Thank you for the replies, it's great to hear that a request has been submitted to the driver team to provide users with a way of disabling the automatic scans. I believe that would resolve the problems that the thread creator and I (and others) are seeing so hopefully it's something they'll be able to implement. I'd still consider this issue open until that is done though.

Reply