Wireless
Issues related to Intel® Wireless Adapters and technologies
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
6091 Discussions

Intel AX200 as AP in Ubuntu 20.04 (hostapd)

gusarg81
Beginner
2,032 Views

Hi,

 

I am trying to "unlock" 5Gghz frequencies with this board and is impossible. I only bought Intel board because is supposed to have good support on Linux/Open source but seems I was wrong.

My ONLY intention is to use this board as AP (for start, as 5Ghz... if works, the idea is to buy another one for 2.4Ghz with the same purpose), so I can use my Home Linux Server as a WIFI Router as well (and to remove unnecessary WIFI Router).

 

Now, here is the problem:

 

Frequencies:
* 5180 MHz [36] (22.0 dBm) (no IR)
* 5200 MHz [40] (22.0 dBm) (no IR)
* 5220 MHz [44] (22.0 dBm) (no IR)
* 5240 MHz [48] (22.0 dBm) (no IR)
* 5260 MHz [52] (22.0 dBm) (no IR, radar detection)
* 5280 MHz [56] (22.0 dBm) (no IR, radar detection)
* 5300 MHz [60] (22.0 dBm) (no IR, radar detection)
* 5320 MHz [64] (22.0 dBm) (no IR, radar detection)
* 5340 MHz [68] (disabled)
* 5360 MHz [72] (disabled)
* 5380 MHz [76] (disabled)
* 5400 MHz [80] (disabled)
* 5420 MHz [84] (disabled)
* 5440 MHz [88] (disabled)
* 5460 MHz [92] (disabled)
* 5480 MHz [96] (disabled)
* 5500 MHz [100] (22.0 dBm) (no IR, radar detection)
* 5520 MHz [104] (22.0 dBm) (no IR, radar detection)
* 5540 MHz [108] (22.0 dBm) (no IR, radar detection)
* 5560 MHz [112] (22.0 dBm) (no IR, radar detection)
* 5580 MHz [116] (22.0 dBm) (no IR, radar detection)
* 5600 MHz [120] (22.0 dBm) (no IR, radar detection)
* 5620 MHz [124] (22.0 dBm) (no IR, radar detection)
* 5640 MHz [128] (22.0 dBm) (no IR, radar detection)
* 5660 MHz [132] (22.0 dBm) (no IR, radar detection)
* 5680 MHz [136] (22.0 dBm) (no IR, radar detection)
* 5700 MHz [140] (22.0 dBm) (no IR, radar detection)
* 5720 MHz [144] (22.0 dBm) (no IR, radar detection)
* 5745 MHz [149] (22.0 dBm)
* 5765 MHz [153] (22.0 dBm)
* 5785 MHz [157] (22.0 dBm)
* 5805 MHz [161] (22.0 dBm)
* 5825 MHz [165] (22.0 dBm)
* 5845 MHz [169] (disabled)
* 5865 MHz [173] (disabled)
* 5885 MHz [177] (disabled)
* 5905 MHz [181] (disabled)

 

No matter what I set in /etc/default/crda (or via driver option), all those needed frequencies (lets say, channel 40 for example) will always be no IR which makes impossible to make it work as AP mode.

 

Tried to install a newer kernel but the result is the same.

 

OS: Ubuntu 20.04

Kernel: 5.11.16 (custom from ubuntu mainline kernel, https://kernel.ubuntu.com/~kernel-ppa/mainline/)

Device: TP-Link Archer Tx50e (Intel AX200)

 

Please, I need a solution. Thanks.

Labels (1)
0 Kudos
8 Replies
AndrewG_Intel
Moderator
2,007 Views

Hello @gusarg81

Thank you for posting on the Intel® communities.


We understand that you are using a third-party PCIe wireless card from TP-Link* (which comes with an Intel® Wi-Fi 6 Chipset). Based on the device's website*, under "Specifications", it says that "only Windows 10(64-bit)" is supported. However, please allow us to take a look into this and we will be posting back as soon as more details are available.


Best regards,

Andrew G.

Intel Customer Support Technician


gusarg81
Beginner
2,004 Views

@AndrewG_Intel 

 

Seems you are not aware that this chipset has Linux support using iwlwifi / iwlmvm driver. So what TP-Link website says is irrelevant.

Would be nice if you investigate further before replying that, so together we can save us the waiting time between posts, please.

 

Thanks.

gusarg81
Beginner
1,978 Views

By the way, can you confirm that this problem is caused by Intel DRS (LAR/DRS)? (https://blogs.intel.com/technology/2015/01/intel-drs-wi-fi-trouble-international-travelers/)

 

LAR = Location Aware Regulatory

DRS = Dynamic Regulatory Solution

 

If this is the case, there must be a way to disable it, so I can use this board for AP with both signals.

AndrewG_Intel
Moderator
1,960 Views

Hello gusarg81

Thank you for your patience in this matter.


In regards to the first problem described in your initial post, the no-IR flag is set to meet the regulatory compliance and disable the soft AP mode on 5GHz channels in certain countries. For details, please refer to the article Linux Wireless - Regulatory rules.

Please try to enable the AP mode on channels without the "no-IR" or "Passive-scan" flags in your county.

We recommend confirming this with TP-Link* support since this is a third-party device using only the AX200 chip from Intel®.


With respect to your question about Intel® DRS (LAR/DRS), please allow us to look into this and we will be posting back as soon as more details are available.


Best regards,

Andrew G.

Intel Customer Support Technician


gusarg81
Beginner
1,954 Views

@AndrewG_Intel Hi:

 

Right, but I do need to enable SoftAP in both channels, so how I can bypass or set another regdomain that allows me to use 2.4Ghz and/or 5Ghz for SoftAP mode? Thats is what I need, because this is the main problem I've posted here, that I can't change/bypass regdomain and thats why this is happening.


Also, this is why I ask how to disable LAR/DRS if this is what causing the problem.


I am not the only one suffering from this problem, but anyone that owns any Intel WIFI 6 device... So, is not a problem from TP-Link, but from your chips/driver/firmware and related.
What TP-Link does in this case (means, in this card model), is just to use a PCIe to M2 NGFF adapter. So, there is NO TP-Link device/chip/software/firmware at all here. I know because I've dissembled it, and you can look at here as well:

 

Thanks.

AndrewG_Intel
Moderator
1,950 Views

Hello gusarg81

Thank you for your response and for the additional details.

We are reviewing your inquiries. Please allow us more time to check this and we will be posting back as soon as possible.


Best regards,

Andrew G.

Intel Customer Support Technician


AndrewG_Intel
Moderator
1,913 Views

Hello gusarg81


After reviewing this further, we would like to clarify this feature is meant to comply with regulatory standards, therefore, it can't be simply deactivated.

Our recommendation is to contact your Original Equipment Manufacturer (OEM) TP-Link* to validate compatibility with WiFi 6 and country regulatory information.

Having said that, we will proceed to close this inquiry now. If you need any additional information, please submit a new question as this thread will no longer be monitored. Thank you for your understanding.


Best regards,

Andrew G.

Intel Customer Support Technician


gusarg81
Beginner
1,905 Views

@AndrewG_Intel :

 

No matter how Local regulations are, the option to change Regulatory Domain should be a MUST, since for example I can travel with the card to another country and then the device becomes useless (no matter if automatic Regdomain works or not).

 

Again, is useless to contact TP-Link because is not a problem of TP-Link but a INTEL implementation (Hardware/Driver/Firmware).

In the past I always thought you were the worst company ever. Now, I am 200% sure about this. I wonder why Qualcomm are way better in this area than you...

Thanks for nothing.

Reply