Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
7308 Discussions

AX200 Linux very low speeds

rbarsoianu
Beginner
2,665 Views

I've tried quite a few distros (Manjaro, Ubuntu 22.04 and Suse both Leap and Tmbl) and on all my AX200 has very slow speed compared to Windows (i would say less than a quarter). I've installed different kernels, disabled power save, nothing seems to make any difference. Currently this is what i have :

 

iwconfig
lo        no wireless extensions.

enp6s0    no wireless extensions.

wlp5s0    IEEE 802.11  ESSID:"LaVecinu5"   
         Mode:Managed  Frequency:5.2 GHz  Access Point: FC:34:97:86:84:E4    
         Bit Rate=29.2 Mb/s   Tx-Power=22 dBm    
         Retry short limit:7   RTS thr:off   Fragment thr:off
         Power Management:off
         Link Quality=54/70  Signal level=-56 dBm   
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:69   Missed beacon:0

 

 

Link will vary and occasional it can go up to 432 Mbit, far from the 1000 i get on W10. More info :

 

sudo dmesg | grep iwlwifi          
[   12.380882] iwlwifi 0000:05:00.0: enabling device (0000 -> 0002)
[   12.397150] iwlwifi 0000:05:00.0: api flags index 2 larger than supported by driver
[   12.397165] iwlwifi 0000:05:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 89.3.35.37
[   12.397352] iwlwifi 0000:05:00.0: loaded firmware version 66.f1c864e0.0 cc-a0-66.ucode op_mode iwlmvm
[   12.467399] iwlwifi 0000:05:00.0: Detected Intel(R) Wi-Fi 6 AX200 160MHz, REV=0x340
[   12.591533] iwlwifi 0000:05:00.0: Detected RF HR B3, rfid=0x10a100
[   12.656354] iwlwifi 0000:05:00.0: base HW address: c8:e2:65:08:01:6a
[   12.671876] iwlwifi 0000:05:00.0 wlp5s0: renamed from wlan0

 

 

 

cat /etc/modprobe.d/iwlwifi.conf      
# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211
options iwlwifi power_save=0
options iwlmvm power_scheme=1
options iwlwifi 11n_disable=8
filename:       /lib/modules/5.15.0-47-generic/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
license:        GPL
author:         Intel Corporation <linuxwifi@intel.com>
description:    Intel(R) Wireless WiFi driver for Linux
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-6.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-6.ucode
firmware:       iwlwifi-7265D-29.ucode
firmware:       iwlwifi-7265-17.ucode
firmware:       iwlwifi-3168-29.ucode
firmware:       iwlwifi-3160-17.ucode
firmware:       iwlwifi-7260-17.ucode
firmware:       iwlwifi-8265-36.ucode
firmware:       iwlwifi-8000C-36.ucode
firmware:       iwlwifi-9260-th-b0-jf-b0-46.ucode
firmware:       iwlwifi-9000-pu-b0-jf-b0-46.ucode
firmware:       iwlwifi-bz-a0-mr-a0-66.ucode
firmware:       iwlwifi-bz-a0-gf4-a0-66.ucode
firmware:       iwlwifi-bz-a0-gf-a0-66.ucode
firmware:       iwlwifi-bz-a0-hr-b0-66.ucode
firmware:       iwlwifi-SoSnj-a0-mr-a0-66.ucode
firmware:       iwlwifi-ma-a0-fm-a0-66.ucode
firmware:       iwlwifi-ma-a0-mr-a0-66.ucode
firmware:       iwlwifi-ma-a0-gf4-a0-66.ucode
firmware:       iwlwifi-ma-a0-gf-a0-66.ucode
firmware:       iwlwifi-ma-a0-hr-b0-66.ucode
firmware:       iwlwifi-SoSnj-a0-jf-b0-66.ucode
firmware:       iwlwifi-SoSnj-a0-hr-b0-66.ucode
firmware:       iwlwifi-SoSnj-a0-gf-a0-66.ucode
firmware:       iwlwifi-SoSnj-a0-gf4-a0-66.ucode
firmware:       iwlwifi-ty-a0-gf-a0-66.ucode
firmware:       iwlwifi-so-a0-gf-a0-66.ucode
firmware:       iwlwifi-so-a0-hr-b0-66.ucode
firmware:       iwlwifi-so-a0-jf-b0-66.ucode
firmware:       iwlwifi-cc-a0-66.ucode
firmware:       iwlwifi-QuQnj-b0-jf-b0-66.ucode
firmware:       iwlwifi-QuZ-a0-jf-b0-66.ucode
firmware:       iwlwifi-QuZ-a0-hr-b0-66.ucode
firmware:       iwlwifi-Qu-b0-jf-b0-66.ucode
firmware:       iwlwifi-Qu-c0-hr-b0-66.ucode
firmware:       iwlwifi-QuQnj-b0-hr-b0-66.ucode
firmware:       iwlwifi-Qu-b0-hr-b0-66.ucode
srcversion:     F27B91AF2B729D1CEE0E1CE

parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm:           amsdu_size:amsdu size 0: 12K for multi Rx queue devices, 2K for AX210 devices, 4K for other devices 1:4K 2:8K 3:12K (16K buffers) 4: 2K (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           nvm_file:NVM file name (charp)
parm:           uapsd_disable:disable U-APSD functionality bitmap 1: BSS 2: P2P Client (default: 3) (uint)
parm:           enable_ini:Enable debug INI TLV FW debug infrastructure (default: true (bool)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)
parm:           disable_11ac:Disable VHT capabilities (default: false) (bool)
parm:           remove_when_gone:Remove dev from PCIe bus if it is deemed inaccessible (default: false) (bool)
parm:           disable_11ax:Disable HE capabilities (default: false) (bool)
inxi -Fxxxrz
System:
  Kernel: 5.15.0-47-generic x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: KDE Plasma 5.24.4 tk: Qt 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Ubuntu 22.04.1 LTS (Jammy Jellyfish)
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: TUF GAMING X570-PRO (WI-FI) v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 4403
    date: 04/27/2022
CPU:
  Info: 6-core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP smt: enabled
    arch: Zen 3 rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 32 MiB
  Speed (MHz): avg: 2623 high: 3598 min/max: 2200/4650 boost: enabled
    cores: 1: 2235 2: 2239 3: 2797 4: 2240 5: 2235 6: 2844 7: 3072 8: 2871
    9: 3598 10: 2878 11: 2237 12: 2237 bogomips: 88801
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: ASUSTeK
    driver: amdgpu v: 5.16.9.22.20 pcie: speed: 16 GT/s lanes: 16 ports:
    active: DP-3 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0c:00.0 chip-ID: 1002:73bf
    class-ID: 0300
  Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
    loaded: amdgpu,ati unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0")
    s-diag: 777mm (30.6")
  Monitor-1: DisplayPort-2 mapped: DP-3 model: ASUS XG32VC serial: <filter>
    res: 2560x1440 hz: 165 dpi: 93 size: 697x392mm (27.4x15.4")
    diag: 800mm (31.5") modes: max: 2560x1440 min: 720x400
  OpenGL: renderer: AMD Radeon RX 6800 XT (sienna_cichlid LLVM 14.0.1 DRM
    3.46 5.15.0-47-generic)
    v: 4.6 Mesa 22.1.0-devel direct render: Yes
Audio:
  Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 0c:00.1 chip-ID: 1002:ab28 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 0e:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: ASUSTek STRIX SOUND CARD type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2 chip-ID: 0b05:180d
    class-ID: 0300
  Sound Server-1: ALSA v: k5.15.0-47-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: speed: 5 GT/s
    lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp5s0 state: up mac: <filter>
  Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
    pcie: speed: 5 GT/s lanes: 1 port: N/A bus-ID: 06:00.0 chip-ID: 8086:15f3
    class-ID: 0200
  IF: enp6s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-4:2 chip-ID: 8087:0029 class-ID: e001
  Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter>
    bt-v: 3.0 lmp-v: 5.2 sub-v: 237e hci-v: 5.2 rev: 237e
Drives:
  Local Storage: total: 953.87 GiB used: 243.25 GiB (25.5%)
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 002C temp: 43.9 C
    scheme: GPT
Partition:
  ID-1: / size: 914.69 GiB used: 242.99 GiB (26.6%) fs: ext4 dev: /dev/dm-1
    mapped: vgkubuntu-root
  ID-2: /boot size: 1.61 GiB used: 257.8 MiB (15.7%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 511 MiB used: 5.2 MiB (1.0%) fs: vfat
    dev: /dev/nvme0n1p1
Swap:
  ID-1: swap-1 type: partition size: 976 MiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/dm-2 mapped: vgkubuntu-swap_1
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 59.0 C
    mem: 62.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Repos:
  Packages: 2485 apt: 2474 snap: 11
  Active apt repos in: /etc/apt/sources.list
    1: deb http://ro.archive.ubuntu.com/ubuntu/ jammy main restricted
    2: deb http://ro.archive.ubuntu.com/ubuntu/ jammy-updates main restricted
    3: deb http://ro.archive.ubuntu.com/ubuntu/ jammy universe
    4: deb http://ro.archive.ubuntu.com/ubuntu/ jammy-updates universe
    5: deb http://ro.archive.ubuntu.com/ubuntu/ jammy multiverse
    6: deb http://ro.archive.ubuntu.com/ubuntu/ jammy-updates multiverse
    7: deb http://ro.archive.ubuntu.com/ubuntu/ jammy-backports main restricted universe multiverse
    8: deb http://security.ubuntu.com/ubuntu jammy-security main restricted
    9: deb http://security.ubuntu.com/ubuntu jammy-security universe
    10: deb http://security.ubuntu.com/ubuntu jammy-security multiverse
  Active apt repos in: /etc/apt/sources.list.d/amdgpu-proprietary.list
    1: deb https://repo.radeon.com/amdgpu/22.20/ubuntu jammy proprietary
  Active apt repos in: /etc/apt/sources.list.d/amdgpu.list
    1: deb https://repo.radeon.com/amdgpu/22.20/ubuntu jammy main
  Active apt repos in: /etc/apt/sources.list.d/deadsnakes-ubuntu-ppa-jammy.list
    1: deb https://ppa.launchpadcontent.net/deadsnakes/ppa/ubuntu/ jammy main
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
    1: deb [arch=amd64] https://dl.google.com/linux/chrome/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/kisak-ubuntu-kisak-mesa-jammy.list
    1: deb https://ppa.launchpadcontent.net/kisak/kisak-mesa/ubuntu/ jammy main
  Active apt repos in: /etc/apt/sources.list.d/lutris-team-ubuntu-lutris-jammy.list
    1: deb https://ppa.launchpadcontent.net/lutris-team/lutris/ubuntu/ jammy main
  Active apt repos in: /etc/apt/sources.list.d/rocm.list
    1: deb [arch=amd64] https://repo.radeon.com/rocm/apt/5.2 ubuntu main
  Active apt repos in: /etc/apt/sources.list.d/signal-xenial.list
    1: deb [arch=amd64 signed-by=/usr/share/keyrings/signal-desktop-keyring.gpg] https://updates.signal.org/desktop/apt xenial main
  Active apt repos in: /etc/apt/sources.list.d/teamviewer.list
    1: deb https://linux.teamviewer.com/deb stable main
  Active apt repos in: /etc/apt/sources.list.d/winehq-jammy.sources
    1: deb [arch=amd64 i386] https://dl.winehq.org/wine-builds/ubuntu jammy main
Info:
  Processes: 344 Uptime: 12m wakeups: 0 Memory: 31.26 GiB
  used: 3.12 GiB (10.0%) Init: systemd v: 249 runlevel: 5 Compilers:
  gcc: 11.2.0 alt: 11 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13

 

 

If anyone has any other ideas, I'm willing to try.  I don't think it's the router, it's a Asus Zen Wi-Fi AX and during my short test it worked perfectly under windows 10.

Labels (1)
0 Kudos
8 Replies
rbarsoianu
Beginner
2,651 Views

I've read that it could also be related to encryption and security, currently the network is WPA2-AES. So I just created a guest network with no security, there was no improvement. Link stays at 21 Mbit for 90% of the time, even if the signal strength is quite good.

0 Kudos
rbarsoianu
Beginner
2,631 Views

I tried swapping to IWD and there seems to be an improvement, although it's early to be sure. Now the link varies from 29.2 to 576.4. Still not close to W10

:~$ iwconfig
lo        no wireless extensions.

enp6s0    no wireless extensions.

wlan0     IEEE 802.11  ESSID:"LaVecinu5"  
          Mode:Managed  Frequency:5.2 GHz  Access Point: FC:34:97:86:84:E4   
          Bit Rate=576.4 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=52/70  Signal level=-58 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:100   Missed beacon:0

:~$ sudo iwctl device list
                                    Devices                                    
--------------------------------------------------------------------------------
  Name                Address             Powered   Adapter   Mode      
--------------------------------------------------------------------------------
  wlan0               c8:e2:65:08:01:6a   on        phy0      station   

 

0 Kudos
rbarsoianu
Beginner
2,612 Views

rbarsoianu_0-1662207669304.png

This is what i get under W10. Tried on Manjaro with all kernels from 5.4 to 5.19. Tried ubuntu and variants as well, tinkered with all settings i could think of but no improvement. So i finally gave up, I do expect a performance drop on certain HW (such as wireless ax or gaming perf) while on Linux, but that's usually marginal within the 5%, here we are talking about a 80%-50% drop. If it's not the distro nor the kernel nor the network manager, i suspect it might be the driver that's why i came here for support. Anyway, using this little bloatware for now waiting for a driver update in the kernel.

0 Kudos
rbarsoianu
Beginner
2,321 Views

300+ views, almost two months later and zero replies from any Intel moderators ? No advice no nothing ? This is ..disappointing and something to keep in mind when purchasing my next wireless card, or any other Intel hardware for that matter.

0 Kudos
MichielBruijn
Beginner
2,204 Views

I second this problem.

Researched this problem for days and hours on end. Reinstalling different linux flavours give same result.

Linux mint 20, 21, Ubuntu 22.04, 22.10. All the same.

I played with several iwlwifi options but no solution for slow download, power=off gave me a slight improvement.

Strange thing is that upload is acceptable with 3 times higher rate than download.

I test this with local network to and from a local server.

Wired speeds are maxed out at 1000mbit

I get consistent 400mbit upload and around 130mbit download.

I even opened up my laptop to change the antenna and change the mini pci-e card from another laptop.

 

michiel@clevo:~$ sudo dmesg | grep -i wifi
[sudo] password for michiel: 
[    6.515474] Intel(R) Wireless WiFi driver for Linux
[    6.516296] iwlwifi 0000:2a:00.0: enabling device (0000 -> 0002)
[    6.525284] iwlwifi 0000:2a:00.0: Direct firmware load for iwlwifi-cc-a0-72.ucode failed with error -2
[    6.526394] iwlwifi 0000:2a:00.0: api flags index 2 larger than supported by driver
[    6.526406] iwlwifi 0000:2a:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 89.3.35.37
[    6.526909] iwlwifi 0000:2a:00.0: loaded firmware version 71.058653f6.0 cc-a0-71.ucode op_mode iwlmvm
[    6.668207] iwlwifi 0000:2a:00.0: Detected Intel(R) Wi-Fi 6 AX200 160MHz, REV=0x340
[    6.816283] iwlwifi 0000:2a:00.0: Detected RF HR B3, rfid=0x10a100
[    6.885575] iwlwifi 0000:2a:00.0: base HW address: 3c:21:9c:f1:bc:bf
[   11.312565] iwlwifi 0000:2a:00.0: Got NSS = 4 - trimming to 2
[   30.590803] iwlwifi 0000:2a:00.0: Got NSS = 4 - trimming to 2

 

 

Now I'm going to try linux kernel 6 to see if there's improvement.

Maybe this thread is related.

0 Kudos
rbarsoianu
Beginner
2,147 Views

Think there is a slight improvement in 6. Now the link varies between 576 and 648

 

lo        no wireless extensions.

enp6s0    no wireless extensions.

wlp5s0    IEEE 802.11  ESSID:"LaVecinu5"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: FC:34:97:86:84:E4   
          Bit Rate=648.5 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=50/70  Signal level=-60 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:147   Missed beacon:0

 Currently using tumbleweed

System:
  Host: localhost.localdomain Kernel: 6.1.8-1-default arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.26.5 Distro: openSUSE Tumbleweed 20230129

 

0 Kudos
MichielBruijn
Beginner
2,128 Views

After days of tweaking and digging I managed to improve my bandwidth greatly with another antenna just hanging outside my laptop for testing purpose.

My conclusion is that my metal laptop enclosure is the culprit of bad wifi reception.

I switched back to stock kernel and only use wifi power management off which still produce slight improvement.

0 Kudos
rbarsoianu
Beginner
2,109 Views

Glad this worked for you, in my case if the speed more than doubles under win then it's not a antenna positioning issue.

0 Kudos
Reply