Showing results for 
Search instead for 
Did you mean: 

Intel Centrino Advanced N 6205 only sees 802.11A from Linksys EA4500 router, and not 802.11N

I have had my Fujitsu T902 laptop for about 5 months now and it was custom built with the Centrino Advanced N 6205 card. I have had my EA4500 router from Linksys for about a year and have seen and connected to its N network before. In fact, I had never had the A portion of the 5ghz network turned on until I could not see or connect to the N network with this laptop.

When pulling up available networks in my area, I can see other N networks, but my linksys router only shows an A network. If I disable A, I don't see anything at all from the 5ghz side. Is this a known issue and is there a fix? I have tried drivers from both Fujitsu and Intel and have not been able to fix this.

Oddly, in the advanced tab on the 6205 driver, it shows the available modes as variations of A/B/G but no N mentioned in any of the version I have. Not sure what the deal is. Strange that I can connect to a 5ghz A network from my router but not a 5ghz N network.

Any ideas?

Tags (1)
0 Kudos
4 Replies


From the Intel® wireless adapter properties you may want to check the following:

  • 802.11n Mode: Enabled
  • Preferred Band: Choose the desired option 2.4 or 5.2 GHz

What are the recommended settings for 802.11n connectivity?

In regards of security and encryption we recommend WPA2-AES instead of TKIP or WEP as described in the article below.

Data rate will not exceed 54 Mbps when WEP or TKIP encryption is configured

Please also note that your wireless AP is simultaneous dual-band so, it is possible you will only see one SSID. You may contact the router manufacturer for assistance setting it up.

The CMD command netsh wlan show interfaces can be used to get more information from the network you are connected to.

NOTE: These links are being offered for your convenience and should not be viewed as an endorsement by Intel of the content, products, or services offered there.


Thanks for your reply Joe.

I did already have 802.11N mode enabled. I did not have a band preference, but I did try 5 ghz previously and again this time with no change.

WPA2 was enabled in a mixed mode with WPA, but I did set it straight to WPA2 Personal as well, with no change.

I still only see wireless A on 5 ghz. My 2.4ghz side is also capable of N, but I cannot see it as N on that side either. It shows up as G.

I know my router works in N mode because I can get N on the 2.4 ghz side on my other laptop and I can see the 5ghz with a usb 5ghz N adapter on some other devices. Its this laptop with this card that only sees A, B, and G and not N on either 2.4 or 5 ghz.

I tried turning both bands to N only and couldn't connect at all, and even though it was broadcasting in N, the Centrino adapter still showed it as G and A in their respective bands.


After scouring the web, I finally found another person with a similar issue on a mac book pro and my same router. I had to go into media prioritization on the router and enable WMM. Supposedly Intel and some other manufacturers require WMM when going to high speed N connections. WMM would not stay on unless I also added my laptop to the priority device list as well. As soon as I did, the connection no longer showed up as only a 802.11a connection, but now shows up correctly as a .11n connection and I get speeds above 54mbps.


I opened the "Control Panel" - "System" - "Device Manager".

Then under "Network Adapters" i opened the properties for the "Intel Centrino Advanced-N 6205".

In the register card "Advanced" i set the setting "preferred band" to "3. prefer 5,2-GHz band".

It then immediately re-initialized the network connection and connected to the 5,2 GHz WLAN.

For my card (Austria / Europe) I had to set my router to "N Only". The setting "A/N Mixed" did NOT work.

Security is AES - higher data rates only work with AES and not with TKIP.

Now the data throuput is optimal and since the 5,2 GHz band is completely free in my area I don't have to share it with other users.