Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
6,537 Views

Intel Centrino Wireless N 2230 conectivity issue!

Hello,

I have a brand new notebook Lenovo ThinkPad Edge E330 with Centrino wireless N 2230 card.

The issue is that my laptop doesen't connect to my wi-fi router at more than 54 Mbps.The router is from my ISP , Huawei HG 655b.

I use WPA2-PSK ,WMM activated, 20/40 Mhz band,also i have another 2 laptops from Toshiba, they both connect to the router at minimum 150 Mbps or 270 Mbps.

So far i've updated to the latest drivers, QOS enable/disable nothing seems to work.

Any ideea what should i try? it's really frustating to have a brand new laptop and not being able to fully enjoy it.

Thank you.

 

0 Kudos
31 Replies
Victor_B_Intel
Employee
891 Views

Thank you for your post Entis,Please note that the /message/168421# 168421 Intel® Centrino ® Wireless N 2230 card has a single band frequency meaning that this will work at 2.4 GHz with a maximum speed of 300MbpsAccording to the description of your issue, you might set your wireless router to use channel bonding at 40 MHz. This will allow the router to use two channels at the same time.You might also check the following links for further information:Wireless Networking: What are the recommended settings for 802.11n connectivity?

http://www.intel.com/support/wireless/sb/CS-030709.htm http://www.intel.com/support/wireless/sb/CS-030709.htm

 

Intel® Centrino® WiFi Products: Possible interference by other wireless devices may impact 802.11n performance.

http://www.intel.com/support/wireless/wlan/sb/CS-031509.htm?wapkw=wireless+performance http://www.intel.com/support/wireless/wlan/sb/CS-031509.htm?wapkw=wireless+performance

 

Data rate will not exceed 54 Mbps when WEP or TKIP encryption is configured:

http://www.intel.com/support/wireless/wlan/4965agn/sb/cs-025643.htm http://www.intel.com/support/wireless/wlan/4965agn/sb/cs-025643.htm

I hope this helps.
idata
Community Manager
891 Views

Thanks for the reply.

So i've set the router to channel bonding and everything was the same.

Then i've noticed that the WPA encyption is set to TKIP+AES

but when checking propreties on wi-fi card i get this

I've tried to change the setting on my router to WPA encryption AES but the i can't connect anymore: "windows was unable to connect" ,tried reseting the adapter, the laptop and the router, deleting the wireless network ...still not working.

Any ideea what to do next?

Thank you!

idata
Community Manager
891 Views

I'm facing the same exact issue with a brand new laptop with Wireless-N 2230 and windows 8. I noticed the question posted above was never answered. If you have resolved this issue, please let me know what was the solution.

I have been looking at this issue for the last few days with no luck. I did the configuration that was recommended above without any notable improvement in performance. N 2230 gives 1/5 of the performance that I get on any of the other laptops I have.

Thanks,

-Hany

idata
Community Manager
891 Views

I have the same issue with my new HP dv7t-7000. I believe it's problem with the Centrino n2230 wireless card. I did update the driver, tried different configuration, and still cannot detect WPA2-Personal channel of my VIZIO router (XWR100 Dual Band), it can only detect WPA Personal channel. My old laptop, blackberry and iPad can detect the WPA2-Personal without any problem.

idata
Community Manager
891 Views

The problem appears to be that you have your Intel wireless configured for "Encryption type: TKIP." As per the documentation, this results in a maximum connection speed of 54Mbs. ("Note Data rate will not exceed 54 Mbps when WEP or TKIP encryption is configured." http://www.intel.com/support/wireless/sb/CS-030709.htm http://www.intel.com/support/wireless/sb/CS-030709.htm)

Since you have your router configured for "WPA encryption: TKIP+AES," you can simply reconfigure your Think Pad for AES encryption. In case that still doesn't work (I've seen something similar), you may also have to change your router to *only* allow AES encryption.

Hope this solves it - for you, and all the other commenters having the same issue!

idata
Community Manager
891 Views

Hi

Same issue for me. With my old laptop it's so easy to connectto my router, but it's impossible with my new mothercard Gigabyte which includes the Intel Centrino N 2230 chipset.

Can anynone help me ? I've tried everything !

(Pls forgive my english)

idata
Community Manager
891 Views

I have the same problem with my new Inspiron 15R 5520. I have the Intel Centrino 2230 wireless card.

When I am sat next to my router the connectivity is 3/5 then when I leave the room it disappears. Surely this isn't right.

JLuke
Beginner
891 Views

I recently got Fujitsu AH532 laptop with Centrino 2230 NIC. Even if I stand beside the AP, I never get full signal. If I try to use it than, the connection drops and is generally unusable. I've tried it with several accesspoints with the same results. If I walk further from the AP, I get no connection whatsoever.

If i plug cheap $5 802.11n USB stick from eBay, I get full signal and eventually really long rage.

I've heard about a guy with his AH532 having antenna disconnected from the factory, but it isn't my case.

There is a black antenna connected to "Main 1" and a gray one connected to "Aux 2". I've disconnected and reconnected them just to make sure there isn't a bad contact. It didn't help.

Anybody has idea, if the cables shouldn't be connected in the opposite order? I've read quite a lot from people having the same kind of trouble with this NIC in this forum.

What to do? I am sure the problem isn't in my Accesspoints. I have turned off powersaving features for the adapter.

I have the most recent drivers from Intel's site,

idata
Community Manager
891 Views

Hello

 

I also bought a lenovo thinkpad edge e330 with windows 8 and I have the same problem.

 

I've tried various drivers available, but nothing has changed, it is a really strange problem .... who can help us?
idata
Community Manager
891 Views

Alright so the network card by default only runs on 54mbps and you have to change a setting within the device manager.

1. open device manager

2. network adapters right click on the network adapter 2230

3. hit properties

4. advanced tab

5. 802.11n channel for band 2.4 should be set to auto

There you go it is by default set to 20 and will only run at 54mpbs also once enabled you will still likely only get 150mbps since to be honest this is a crappy network card. I had a gateway nv55su for a year and it constantly had 300mbps and 11MBps speeds. This laptop that I paid more than double the price of my previous laptop had a lower class network card? I get 300mbps half the time and that is with windows managing it the Intel wifi management software that came with it would always set it to 150 and give me 5-6 MBps speeds.

It's ok I deal with it the laptop still has a decent video card and processor which is why I purchased it. In the future I will never buy a dell/intel again due to the loss of customization and limitation of the hardware as compared to an AMD but I'll deal with it for now since I pad about $1000 for this laptop. Hope I helped some of you fix your network cards!

DLowe
Beginner
283 Views

Thank you, that did the trick!

Jose_H_Intel1
Employee
891 Views

Hello entis! You may want to make sure the router is setup to WPA2 - AES only. Please avoid using TKIP+AES option. Then, setup the corresponding values in the computer's wireless profile which should also be AES only.

idata
Community Manager
891 Views

And why can't we use TKIP protocol ?

Is this product defective ?

idata
Community Manager
891 Views

I have the same problem with my laptop. With driver 15.3.1 I am able to somewhat surf the net, but with later drivers I get no wifi connection at all, as it's unable to register and after some seconds it's not able to find any wifi network.

It seems a driver problem with Windows 8.

Jose_H_Intel1
Employee
891 Views

Hello groschax! The product is not defective. Older security protocols like WEP or TKIP will limit the transfer rate to 54 Mbps; this is a limitation due to the advance in the new wireless protocol 802.11n which allows transfer rates higher than 54 Mbps (when not using above security encryptions). Let's remember such transfer rate was the limit for previous wireless standards like 802.11 a/g.

It is for this reason that AES encryption has superseded the previously mentioned security protocols. Basically, 802.11n in combination with WPA2-AES will provide a higher throughput (up to 300 Mbps) and better security compared to older protocols.

The following article provides more information about this topic:

http://www.intel.com/support/wireless/wlan/4965agn/sb/cs-025643.htm http://www.intel.com/support/wireless/wlan/4965agn/sb/cs-025643.htm

Recommended settings for 802.11n:

http://www.intel.com/support/wireless/sb/CS-030709.htm http://www.intel.com/support/wireless/sb/CS-030709.htm

Can anyone else confirm if the issue happens with Windows* 7, Windows* 8 or both?

idata
Community Manager
891 Views

It happened to me with W7.

But since today it's not a problem to me, I returned my MB with Intel Centrino N 2230 wifi chipset to amazon. The customer Service understood my problem and I return it for free !

Thanks Intel ! Répondre au billet original

idata
Community Manager
283 Views

Hi there.

I had the same problem as you have. Until I came across a page in intel which said you must enable WMM in your router. I did so and as soon as I checked the option my speed from 54 mb/s went up to 270 mb/s. So go to your router configuration page under advanced menu choose advanced wireless there you see a menu called WMM enable just click it and save your work. You are done. I promise

VMila
Beginner
283 Views

Hello,

I have found a solution fix (look lower)

Property

Value

802.11n Channel Width for band 2.4

Auto

802.11n Mode

Enabled

Ad Hoc Channel 802.11b/g

9

Ad Hoc QoS Mode

WMM Enabled

Bluetooth(R) AMP

Enabled

Fat Channel Intolerant

Disabled

Mixed Mode Protection

RTS/CTS Enabled

Roaming Aggressiveness

5. Max / Highest

Transmit Power

5. Highest

Wake on Magic Packet

Disabled

Wake on Pattern Match

Disabled

Wireless Mode

2. 802.11g

aggressiveness of homelessness: 3. average

Disactivated ARP WoWLAN: On

Incompatible with 40 MHz channels: Off

Regeneration GTK keys to WoWLAN: Off

Ensures disconnection WoWLAN: Off

Wake on Magic Packet: Off

Encryption = WPA PSK TKIP

new drivers available for Windows 8.1: https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23231 https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23231

But you must use WPA Personal TKIP.

let all notified as above except for roaming aggressiveness setting, put on 5.

Then do the following:

go to Control Panel, Network and Internet, Network and Sharing Center, left click on Change adapter settings.

There you should see an Wi-Fi, right click on it click properties, look on the right there is a bar for you to get down to the bottom, there you will see Internet Protocol Version 4 (TCP/IPv4).

Choose the properties you will see the button (bottom right) click on it, then look down you will see the Advanced ... button, click on the top right there WINS click, uncheck: Enable LMHOSTS lookup.

In Parameters/paramètres NetBios must tick: Disable NetBIOS over TCP / IP, confirm by clicking OK.

if you still have disconnections try this: go to the command prompt to run the administrator then copy these two lines of command netsh wlan stop hostednetwork

netsh wlan set hostednetwork mode = disallow, restart the computer.

If it still does not go to Control Panel ==> System and Security ==> Administrative Tools ==> Services. Search and double click: Automatic configuration of devices connected to the network. Once above click Disabled in the Startup type.

also see if: Network Connections in Startup type, automatic, otherwise do as the previous procedure and put Connections networks automatically.

double-click Network Connections and startup type switch: Automatic.

Let me know the result.

 

Victor

DLowe
Beginner
283 Views

Yep, that worked. Good deal! I was ready to throw the laptop out the window LOL

JB26
New Contributor I
891 Views

It's a bigger issue, look at this thread.

Reply