Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,511 Views

Intel(R) Dual Band Wireless-AC 7260: Keep losing my wireless connection

Hi,

Lately i have started getting this problem with my on board wireless adapter. I am using my computer as normal surfing/streaming/gaming when suddenly i lose connection to my wireless network.

At first i thought maybe it had something to do with my router or internet provider, but after checking my phone and laptop i narrowed it down the fault is somewhere in my computer. First i tried to restart my network adapter in the "Network and sharing center", but every time i try to disable my network adapter from here windows keeps freezing up. So i tried to disable the network adapter through the device manager where i keep running into the same problem that windows freezes up. The only solution so far is to reboot my whole computer which is both annoying and tiresome.

So that's when i start looking for a solution to my problem. First i did the obvious things and downloaded the newest driver for the network adapter. I uninstalled everything that had to do with Intel wireless and uninstalled the driver directly in the device manager. After that i made sure that everything was uninstalled before I reinstalled the newest driver in hopes this would solve my problem (suffering?).

Unfortunately this did not help my cause. So i started digging through the Event Viewer to see if there were any obvious errors to be found. Every time i lose connection to the wireless network i get the same message in the event viewer:

The network interface "Intel(R) Dual Band Wireless-AC 7260" has begun resetting. There will be a momentary disruption in network connectivity while the hardware resets.

Reason: The network driver requested that it be reset.

This network interface has reset # time(s) since it was last initialized.

So after what i have gathered, the network adapter isn't able to reset normally.

All the silly stuff i tried in addition to what is named previously was to open up my computer and re-plug the wireless adapter. I also tried an older version of the network driver without any luck. So in my last attempt to fixing this issue i hope some of you might be kind enough to help me fix this issue.

My system

OS NameMicrosoft Windows 10 EnterpriseVersion10.0.10586 Build 10586System ManufacturerMSISystem ModelMS-7851System Typex64-based PCProcessorIntel(R) Core(TM) i7-4790K CPU @ 4.00GHz, 4001 Mhz, 4 Core(s), 8 Logical Processor(s)BIOS Version/DateAmerican Megatrends Inc. V4.7, 23.12.2014SMBIOS Version2.8NameIntel(R) Dual Band Wireless-AC 7260Adapter TypeEthernet 802.3Product TypeIntel(R) Dual Band Wireless-AC 7260

If you need any further information please don't hesitate to ask for it.

Thanks in advance

Best regards

Andreas

0 Kudos
3 Replies
idata
Community Manager
184 Views

obimoro,

 

 

In this particular case, Intel recommends first to contact your http://www.intel.com/content/www/us/en/support/topics/OEMs.html computer manufacturer in order to obtain the latest customized drivers. After using their drivers you notice the issue still persists, you are welcome to peform a clean installation of our generic drivers found in our download center. Please, follow the procedure below and let us know if this helped you resolve the issue.

1. Download and save https://downloadcenter.intel.com/download/25833/Intel-PROSet-Wireless-Software-and-Drivers-for-Windo... Intel® PROSet/Wireless Software and Drivers for Windows®10 - File Name: Wireless_18.40.0_PROSet64_Win10.exe

 

2. Go to Control Panel, Programs and Features and Uninstall "Intel® PROSet/Wireless Software", if it is installed. When prompted, choose the option to "Discard settings".

 

3. In Control Panel, Device Manager, Network Adapters, right click on the Intel® Dual Band Wireless-AC 7260 and Uninstall it. Make sure you mark the option to "Delete the driver software for this device".

 

4. Reboot the PC or scan for hardware changes, check device manager and if an older driver is detected and installed, repeat the actions to uninstall and delete it as well. Repeat this process until the OS does not allow deleting the driver, or until the controller shows as Unknown Device.

 

5. Reboot or scan for hardware changes, then uninstall and delete any older driver versions as you did for the Wireless adapter.

 

6. Install the Intel® Wireless driver. During the first steps of PROSet/Wireless installation, make sure to customize the installation and install all the 3 driver components.

 

 

Let us know if this helped you.

 

idata
Community Manager
184 Views

Hi,

And thanks for such a quick answer. I had not thought about actually downloading the drivers directly from the computer manufacturer of my motherboard (a bit embarrassing). So i started by downloading the driver from their page and uninstalling all the drivers i had installed. After i had installed the new driver i was hoping it would have solved the problem, unfortunately it did not.

So that is when i tried going through your step-by-step solution to install you generic drivers. I was not able to fully remove the driver in the device-manager, because every time i re-scanned the hardware it just showed up normally as seen in the picture:

At first i thought i just needed to keep uninstalling and rebooting, but after my 6 times i gave up. So i finish the rest of the step-by-step guided and crossed my fingers it would have solved the problem. Unfortunately this did not solve the issue either.

I ended up with re-installing the Windows OS and installing every driver. It seems to be working so far, but time will tell. I will update this post if it worked or not for future people looking for a solution.

idata
Community Manager
184 Views

obimoro,

 

 

We are glad to know the issue is resolved by now. And yes, please let us know if you experience any inconvenience. We will be more than glad to provide all the support within our reach. Thank you for your time taken to let us know it ok for the time being.
Reply