Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,276 Views

Intel(R) Dual Band Wireless-AC 7260 hot spot issues limited connectivity

A client of mine purchased a Dell XPS 13 that has this network card installed.

On half occasions (some routers) the WiFi card connects and work just fine.

On the other half occasions the card connects but a limited connectivity exclamation mark shows

in the network sign.

The operating system is windows 8.1

When i try to debug the limited connectivity issue the ipconfig /all shows that an IP address has been successfully been

acquired.

When i try to ping though the default gateway the request always times out.

I have tried selecting the 2.4 Ghz band as preferred, fully update the drivers to the latest version, updated the operating system,

updated with the vendors (dell) latest drivers but with no luck.

The card will selectively work on some hot spots and not work on others. For example it will not work with any apple mobile hotspot (ipad,iphone)

etc.

Is there any official solution to this issue?

As you know this laptop is supposed to be an ultrapad thus the requirement of wifi compatibility should not

be a 50/50 chance.

Tags (1)
0 Kudos
2 Replies
Highlighted
Honored Contributor II
8 Views

Hello Coonz,

When you installed the latest drivers from Dell* did you clean uninstalled the previous ones making sure no files were left? This problem with limited connection could be caused by many reasons. Please click on this link as it may contain information that might help you resolve this issue: http://www.intel.com/p/en_US/support/category/wireless/db-ac7260/trblsht Troubleshooting for the Intel® Dual Band Wireless-AC 7260 we also found this link provided by Dell* that might help you as well: http://www.dell.com/support/article/us/en/19/SLN288871/EN How to Fix Limited Wi-Fi Connectivity Issue in Windows 8.1 | Dell US - Please let us know if this helped you resolve this issue.

0 Kudos
Highlighted
8 Views

Got the info from this forum:

 

 

The problem is the newer Intel drivers, as many have pointed out.

 

Now to those remaining, take the steps that intel techs pointed out months ago, which involves:

 

* removing all intel network software from your 'add/remove applications"

 

* rolling back your driver version. This is done by going uninstall driver in device manager and choosing 'also remove software' tick box.

 

* Rescan again so it shows again, then repeat, and repeat, and repeat, till you get sick of repeating!

 

* Use CCleaner and clean your registry of any shit leftover, use windows disk cleanup etc. (good practise)

 

* Rescan till nothing shows, restart, repeat.. (now they didn't tell you about this repeating! hehe)

 

* Most of those who are onto it, won't have to repeat so much, but if you have been stuffing around trying to fix this, then there is a lot of rubbish to clean.

 

* Reboot

 

* It will reinstall it, check the version, is it the MS version? We are looking for version: 17.15.0.5 or simular 17x version.

 

Now you check your wifi, and it should be mint.

 

Now to stop Windows Update reinstalling the shitest driver from intel again, you can google this:

 

 

https://www.google.co.nz/search?q=how+to+stop+windows+10+installing+drivers&rlz=1C1CHBF_enNZ806NZ806...

 

 

To anyone still having disconnect issues with the ac-7260 module, please try falling back on the driver version. Doing so has worked for many, including myself.

 

You can get drivers from Microsoft (Update catalog) here: https://www.catalog.update.microsoft.com/Search.aspx?q=ac-7260 Try drivers prior to 18.33.x.x.

 

If it works for you, please leave a comment here so others will know.

0 Kudos