Issues related to Intel® Wireless Adapters and technologies
6404 Discussions

Intel WiFi Link 5100 AGN does not connect to network



I have a Lenovo U450p, which came with a built in WiFi Link 5100 chipset. Recently, it started disconnecting randomly. Now the problem is even worse, where I can see available wireless connections in Windows, but when I try to connect to them, I get a standard Windows error. I've since purchased a USB network adapter and that works well on my PC. I also bought a Centrino Wireless-N 2230 chipset to see if I could use that instead, but my computer seems to be rejecting it.

Does my wireless adapter need to be replaced? I've tried all sorts of settings, but nothing has worked so far.

Also, is there a way I can get my Centrino card to work on my computer?

Any help is appreciated.



0 Kudos
1 Reply

Shravan, it is possible the wireless adapter itself is failing but it is highly recommended to try uninstalling and reinstalling the latest driver just in order to discard a software issue. The article below shows a list of supported operating systems and drivers, just verify your wireless adapter is listed for the respective version.

http://www.intel.com/support/wireless/wlan/sb/CS-031641.htm Intel� Wi-Fi Products; Which operating systems are supported by Intel� Wireless Products?

http://www.intel.com/support/wireless/wtech/proset-ws/sb/CS-034041.htm Intel� PROSet/Wireless Software; Intel� PROSet/ Wireless Software Downloads

In case the adapter needs to be replaced we suggest you contacting the system manufacturer since only they are entitled to provide a list of validated adapters for your system.

http://www.intel.com/support/wireless/wlan/sb/CS-031167.htm Intel� Wi-Fi Products; Why doesn't my laptop recognize my new Intel� wireless adapter?

http://www.intel.com/support/wireless/wlan/sb/CS-011644.htm Intel� Wi-Fi Products; Regulatory information regarding hardware installation or upgrade