Issues related to Intel® Wireless Adapters and technologies
5984 Discussions

Intel Wireless-AC 7260 is still slow


Hey guys,

two month ago I bought a Lenovo Thinkpad T440p with Intel Wireless-AC 7260. Since then I tried pretty much any driver, that has been released during that time. But even with the latest drivers ( im not getting the same performance as my Thinkpad T61 with an 4965AGN card.

Measuring with iperf I'm getting 10-11 MB/s on the 4965AGN and only 6-7 MB/s on the AC 7260.

My wifi router (AVM FritzBox 7390) is running on the 5GHz band with no other 5GHz wifi signals in my area.

I've already tried different power management and driver settings but I still don't get the speed I had hoped. Does anyone have an idea?



0 Kudos
5 Replies

Hello Tmoehle, thanks for contacting us through the Intel Communities.

Some recommendation I could give you regarding your issue are the following. Please try each suggestion and then check if the performance change:

  • * Reset the router and check is your router needs a firmware updated.
  • * Please access the properties of your adapter and disable uAPSD.
  • * would you please let me know when and where are you getting this behavior? Does this happen while you are transferring files or streaming?
  • * Have you tested any other AP network?
  • * Are you experiencing this behavior does this happen when he does something, what is he doing?
New Contributor I

Been told to post in a thread here so here goes:


Having serious speed issues with the 7260AC card.


First, Answering your questions:

- Router has been reset, and is running off the latest firmware available


- uAPSD has been disabled

- The behaviour is completely random. Speeds are (tolerable, JUST acceptable but still slow) every time, but more often than not the card just slows ALL the way down to dial-up speeds, if not worse. Pinging the wireless router, the pings range from a good 700ms to 'unreachable' which is dismal to say at best.

- Other AP network tested, same result

- The 'experience' is more notable when I'm doing business Skype calls. Or streaming Youtube (1080 or 720, they all buffer). Internet browsing experience is generally VERY slow and spotty with the 7260AC card.

The above is besides the point though. I've a 6 year old laptop which runs a 5100 Intel card, and that operates without a hitch at the same location as the (different) machine that's running the 7260. More detail below.

- Hardware used - NUC D54250


- 16GB RAM


- 480GB SSD

- Windows 7 x64 Pro (relatively clean install, all Windows updates done, all the latest Intel drivers installed as of 20/11/2014)

- Using an Intel 7260AC Dual Band card with driver version

I'm currently using a Netcomm NB304N (it's an Australian designed N300 wireless modem / router with the latest firmware installed). But that's besides the point

The problem

Serious throughput issues. The 7260 has some serious issues with speed. As an example, I cannot stream 1080 on Youtube without the thing buffering every two minutes. 720 fares a little better but still buffers and sometimes gets stuck on buffering; extremely frustrating, and embarassing when the NUC is being used for legitimate work (eg, Skype conference calls). And I am at a pains to know / find out how to resolve this. My download speeds on the 7260 are approximately 4Mbps. Upload speeds are around 1Mbps but where I live that's (proportionally at least) normal. The internet service I've signed to offers around 20Mbps, and my other machine using the 5100 card gets around 15Mbps download and around 5Mbps up.

Been using and monitoring Intel's Download Center page for the 7260 since May, but my research regarding this whole issue (throughput AND limited access) suggests this has been going on for quite a while. That's my frustration.


Well, tell me what to do and I'll do it. As it stands now, I've tweaked the settings in Device Manager, swapped out drivers left-right-and-center, BIOS settings (which have inevitably failed...). There's very little 2.4GHz interference where I am, but again, that's besides the point because the 5100 on another computer works completely fine at the same location.



Currently using an Asus USB dongle because that at least provides a stable and consistent connection, but I don't think that was designed for 10 hours a day usage (it gets rather warm)... So yeah.

Any suggestions to fix the limited access upon wakeup once and for all, and the more annoying speed issues, is greatly appreciated.

Valued Contributor II

Your NUC's antenna is the problem. Retrofit an outside antenna and your speed/stability problems should go away.

New Contributor I

Spent 30 minutes carefully prying the motherboard out of the chassis.

...The NUC's antennae are fine...

I don't see why the NUC has more speed issues than my smartphone despite the two being the same distance away from the router (the phone, which has a much shorter antenna).

Either way. Started a new thread so will be continuing there.


Hi, I had speed problems with my Wifi running at less than half of router maximum speed, and drop out problems with my wifi and Bluetooth. For Bluetooth disable bluetooth power management also try the same for wifi. Also I found that the latest drivers did not work well. The drivers that worked for me are For Bluetooth version 17.0.1401 and for Wifi I now get full Wifi speed and no dropouts from Bluetooth and wifi. Goodluck.