Showing results for 
Search instead for 
Did you mean: 
Community Manager

MyWifi error when trying to share internet connection

Hello, I have an Intel Centrino Wireless-N1030 installed on my laptop, with Windows 7 64 Home Premium. I was using MyWifi Technology to give internet connection to my mobile device, but one day it started to give an error when trying to share the internet connection. This happened with the original laptop drivers, so I decided to update them to the newest version (15.1.1), including the Intel MyWifi Dashboard Lite.

Now, in the Dashboard, when I switch on the hotspot button at the right (with the "Automatically share internet connection" option enabled), I see an error similar to what I had with the old version, something like: "Unable to share the internet connection" (my Dashboard is not in English, so that I can't reproduce the exact words).

I have tried with and without Windows Firewall, but the problem still remains. The "ipconfig /all" command shows that the DHCP is disabled for that wifi port (Microsoft Virtual WiFI Miniport Adapter # 2), and the DNS are not established. I modified them using the Google ones ( and but still nothing. Since the error message doesn't specify anything, I have no idea of where should I search the problem.

Tags (2)
0 Kudos
6 Replies
Community Manager

Thank you for your post.

The issue that you describe may be caused by corruption, Anti-virus or a combination of the two.

First to clean out any possible corruption:


  1. First download and save to your desktop the latest drivers and software package (file: Wireless_15.1.1_s64.exe)
  2. Then download and save to your desktop the dashboard software: (file: Intel_My_WiFi_Dashboard_15.1.1_s64.msi)
  3. Remove the Intel® PROSet software from Control Panel\ Control Panel home\ programs, 'uninstall a Program', check also for any other PROSet software and uninstall it too.
  4. Go to 'Start' right-click on 'Computer' click on device manager (on the left panel) click on "Network Adapters"\Double-Click the adapter name\Drivers Tab and click on the "Uninstall" button if present.
  5. Remove the Wireless folder found at C:\Users\YOUR_PROFILE_NAME\AppData\Roaming\Intel. (if you do not see the "AppData" folder you need to "unhide " it, pres 'alt' click on tools then 'folder options' in folder options click on 'view' then select "Show hidden files, folders and drives" then click ok )
  6. Install the latest drivers. (Double-click on the icon of the driver, click next, then accept the agreement, select "Custom installation' make sure all the features are available, no red "X" marked)
  7. Install the Intel® My WiFi Dashboard.

Make sure your antivirus program does not block the connection, check both the Windows* firewall again and if your security software has a firewall check that too. Make sure that the Firewalls and antivirus allow the "Wireless PAN DHCP Server." In private and public networks.

Community Manager

Hello, thanks for your help.

I have followed all the steps, but I'm still getting the same error. Sometimes the error message doesn't appear, but the result is the same: a yellow triangle appears in the WiFi icon on the Windows notification area, and the "ipconfig /all" command shows that the DHCP Server is disabled. I have also tried to disable both firewall and anti-virus protection (Avast shields) and the error is still there, so that the problem should not be a conflict between them.

Some days ago, I noticed my computer was affected by a malware called "Zero Access Rootkit". The malware was already removed, but it made me impossible to activate the Windows Firewall. Finally I solved that problem, but I'm wondering if that malware could also affect other components which are needed for the Intel MyWifi technology. For this reason, I think re-installing Windows would solve the problem, but I would only do that if there is no other option because I work with this laptop daily.

Community Manager

I have the same problem. My machine is a Dell V131 running W7 Pro. Sharing internet connection was running smooth until some Windows updates started to install. My solution was to restore the laptop to a previous date (before the update) and sharing returns as usual. However, recently, Restore fails to restore the system earlier date and I am stuck with no sharing even after applying the steps above. The system is protected with Trend Micro Titanium Internet Security antivirus.

Any suggestions?

Community Manager

Same issue with Dell XPS L702X (Centrino Wireless N-1030 inside)

Contacted both Dell support and Intel support hotline:

- Dell support told me to do system restore and then reinstall Windows *sigh*

- Intel support hotline redirected me to Dell support.

Issue pops up with both the original Dell software as well as with the latest "Dashboard" 15.3.0.

Who can help ?

Community Manager

Ok well I got it working now, but had to reinstall like 5 times. I'm still not sure about the cause.


I don't know what kind of TI people they use but always the same answer uninstall and install....Is the only solution that people can find...useless

The problem is that the automate script is not able to link your internet connection to the virtual wireless order to make it work you have to check the name of the microsoft virtual wifi network in control panel network connections.....

Now go to your network card connected to the internet....right click and go to properties....look in the sharing tab...with the dash board hotspot off...check both boxes, finally choose in the dropbox the microsoft virtual wifi ok and turn on hotspot...that should solve the problem....if not is because something is blocking the ICS service...try to run the service in services.msc