Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7113 Discussions

No 6Ghz Networks Showing On AX210, AX211, and Killer 1675 in Windows 11


I have gone through Intel and Dell support to try and resolve this and neither of them was able to, so I just wanted to document what I did and what results I got from Intel and Dell for their "support"

So I bought an ax210 wifi module for my Alienware M15 R6 laptop replacing the existing Killer 1600. Installed newest Intel drivers and the card worked...but could not see the 6Ghz network. After 3 weeks minimum of researching, troubleshooting, etc, I was finally able to get it working with 6ghz in the only way I found out how from other posters, using the older driver. No other driver allowed this card to recognize 6ghz networks.

Since the card I removed from my laptop was a rebadged ax201 (cnvio2), I purchased an ax211 (also a cnvio2 card), so I was hoping that maybe that would work. Nope. Drivers wouldn't even install, the ax210 went back in and the ax211 was returned.

Grasping at straws at this point...I figured that my Alienware came with a Killer Ethernet chipset...MAYBE it really wants a Killer wifi module too, stranger things have happened. I ordered a Killer 1675x and I get the same results as the ax210. Works but no 6ghz unless I use the aforementioned driver. Since it's a rebranded ax210, I wasn't expecting any different, but at this point, I would have tried about anything to get this working as intended.

After spending weeks with Intel support and e-mailing them reams of documents and system diag and debugging data that they requested, all I get is "you need to call Dell". I'm thinking...REALLY GUYS!? You couldn't have LED with that? I assumed they were going to just play hot potato with me and just send me on a while goose chance so they didn't have to deal with me, but to do that AFTER I put in all this effort troubleshooting this crap and sending them everything they asked for? Nice...real nice.

So...the day I dreaded most arrived...having to contact Dell tech support. I envisioned a guy in Calcutta peddling a frankenbike hooked up to a make-shift alternator to power his crappy laptop, headset, and internet hotspot. So I contact them and they clearly had trouble listening to what I was telling them. It was like if I was telling them something that wasn't on their script, they would just go back around and repeat the previous question hoping my answer would allow them to progress to the next step in their tech support script.

I let them remote into my computer, I showed them as I switched drivers for the ax210 and how the 6ghz network would appear with one version but not the other. Their response ultimately was, "It's not the card that came with the computer." That's it. I mean...I know it isn't the card that it came with, I told them I upgraded it and it's not doing everything it's supposed to do. There was no "it's not supported" or "You need to use the card that came with the computer", nothing like that, just stating a fact like "Hey, the sky is blue. Just thought you should know."

I think I must have read at LEAST 20 different posts in various locations from people identifying the EXACT SAME PROBLEM as mine.


AX210 Wifi 6E card - Newest drivers

Tried AX211 card, couldn't get it to work

Killer 1675x card - Newest driver

Windows 11 PRO - All current updates ( and even tried insider edition and reformatting)

Asus GT-AXE11000 6E router running the newest version of Merlin's firmware (also tried stock firmware and tried every 6ghz-related setting possible on/off, nothing changed.)

I tried the same card on another Dell laptop I have here at the house, a Dell G15 5515, same exact problem.

Tried both Intel's and Dell's Killer Suite of drivers and the same result for both.

Created an Ubuntu Live bootable USB drive and booted to Ubuntu. Would you look at that! My 6ghz network was right there on the list and I was able to connect to it!

Summary: Two things allowed me to even SEE a 6ghz SSID using any of these Intel Wifi 6E cards. 1. Using driver version and 2. Using Linux.

One can conclude through the process of elimination and deductive reasoning that there can be only one culprit here....the Windows versions of these drivers. And I refuse to believe it isn't intentional because version was released in March of 2021, over a year ago. So, since that time, Intel couldn't release a driver for their Wi-Fi 6E products that would allow them to connect to 6ghz connections? As far as the motive, I have no earthly idea. All I know is I spent over half a grand on a router that looks like an extra-terrestrial Stonehenge/Sacrificial altar, bought three variants of the same wifi chipset, and spent well over a month and several hours a day figuring out how to get a product to do what I bought it to do.

So those of you out there searching for a solution.....sadly, there isn't a good one. Intel and the laptop vendor are completely oblivious or refuse to help no matter how much troubleshooting and information you provide them. This is the last time I'm going to be an early adopter of a new technology. This whole thing has been a dumpster fire. If anyone out there found something that worked for them and I haven't tried, I'm all ears. I'll streak across my backyard at night on a full moon if I thought it would help.

0 Kudos
5 Replies

Hello heisenberg832,

Thank you for posting on the Intel️® communities.  

I will proceed to check the issue internally and post back soon with more details. 

Best regards, 

Jean O.  

Intel Customer Support Technician

0 Kudos
Thank you. I forgot to mention one thing. Dell tech support told me I would have to buy a wifi device from them for support. I checked their website with intent of buying one, but of course they only sell 7 Wi-Fi USB dongles, no Wi-Fi modules.

I’ve been in IT work for about 25 years now. I can count on two fingers how many times I had to call tech support in that entire time if you don’t count requesting HDD RMAs. So you know if I encountered an IT issue where I have nothing left but to do but to contact tech support, it means that I’ve already moved mountains up to that point.
0 Kudos
Just got this replay from Dell:

Hello Chris,

Hope you are doing well.

My name is Eivor, I am a resolution expert for Alienware online services, your case was brought to my attention due to the issues being reported.

We understand that you are not using the original WIFI card and it gets to the 6GHz without an issue with Ubuntu.

Unfortunately, we can only troubleshoot the original components of the system and the original OS, and if the original WIFI card is working correctly and within specs, we would not be able to assist with the 3rd party part.

As per the Premium warranty states :
"Premium Support does not include: Support for 3rd Party hardware"

If there is an issues with the system with only the original parts, please let us now and we will gladly assist you to get them working as expected,, if the issue is directly that the 3rd party hardware is not working as expected on the system, we do apologize but we would not be able to continue.

Please let us know if any help is needed with the original parts of the system.

Hope to hear from you soon.

Best regards,

Eivor Corrales
Resolution Expert

Dell EMC | CSMB Technical Support Services
Monday – Friday 8 am- 5 pm MDT

So basically have no one else to turn to except for the community. I mean…a 1650i is a step down from a 1675x. There’s no reason it shouldn’t work. Should I try Microsoft next? I don’t know what to do
0 Kudos

Hello heisenberg832,

I understand your frustration with the issue.

Since you are using multiple integrated wireless cards, I believe the issue is being caused by hardware compatibility or limitation. My recommendation is still the same, reach for support from the Original Equipment Manufacturer to check if the wireless module is compatible or may be impacted by some systems limitations. Your system manufacturer may have altered the features, added customizations, or performed other changes to the software or hardware packaging they provide, creating conflict with any other component you add to it. They are the only ones that can validate what would work with their system. If you want to gather more information about wireless hardware installation or upgrade, you should visit this article:


I hope the information helped. Hopefully, it will help other community members; perhaps, fellow community members know to jump in and help you. I will close your thread now. If you need additional information, please, submit a new question, as this thread will no longer be monitored. 

Best regards, 

Jean O.  

Intel Customer Support Technician

0 Kudos
New Contributor I

I have this exact same issue with two Dell laptops that both shipped with 6Ghz capable adapters.   I also started a thread here, and Intel has been extremely helpful, however their suspicion that it has been disabled by the manufacturer has been confirmed by Dell. 

See my threads on Dell's support forum and Reddit for additional information. 

Does the XPS 9520 support Wi-Fi6E (6GHz)? - Dell Community

Is it deceptive that the XPS 9520 has an AX211 adapter, but Dell has disabled its 6GHz support? : DellXPS (reddit.com)






0 Kudos