Community
cancel
Showing results for 
Search instead for 
Did you mean: 
2,262 Views

WIRELESS AC 9260 regulatory (LAR/DRS) breaks 5ghz functionality.

hi, the description in the title is a bit vague but the problem is that 5ghz ac will not work unless the router is explicity set to 20mhz which all but defeats the purpose of 5ghz wireless-ac. doing this then makes every other 5ghz ac device slow so im left with only 2.4 ghz channels while using windows on this laptop so that my other devices dont suffer.

 

when i refer to "(LAR/DRS)" in the title i am referring to 2 acronyms for the same technology i believe.

LAR = Location Aware Regulatory

DRS = Dynamic Regulatory Solution

 

with linux im able to easily fix this issue with a simple module option or kernel parameter

`iwlwifi.lar_disable=Y`

or modprobe.d option line

`options iwlwifi lar_disable=Y`

 

so on the linux side of things i get excellent dual band performance with either of those, but on windows 10 im unable to find a way of doing this. i've tried ever conceivable setting in advanced options for the intel driver i can think of or find, i've search through the registry trying to find a key to disable it or properly set the regulatory domain which is what im assuming is the issue here.

 

im in the northeast usa, on a dell inspiron 15-7559 meant for the USA afaik and this very same laptop 2-3 months ago did not have this problem.

 

i replaced my previous intel wireless ac (8260 iirc) with this 9260 because of this issue but it turns out it's not the wireless adapter itself and rather a software/driver issue.

 

tl;dr

how do i do in windows 10 what `lar_disable=Y` does in linux?

 

info from windows settings:

```

SSID: <edited out>

Protocol: Wi-Fi 4 (802.11n)

Security type: WPA2-Personal

Network band: 2.4 GHz

Network channel: 1

Link-local IPv6 address: <edited out>

IPv4 address: 192.168.0.100

IPv4 DNS servers: 192.168.0.1

Manufacturer: Intel Corporation

Description: Intel(R) Wireless-AC 9260 160MHz

Driver version: 21.50.1.1

Physical address (MAC): <edited out>

0 Kudos
14 Replies
AlHill
Super User
1,281 Views

You simply cannot replace the wireless adapter in your laptop without consulting with Dell.

Contact dell for assistance with their laptop.

 

https://www.intel.com/content/www/us/en/support/articles/000005687/network-and-io/wireless-networkin...

 

Doc

 

1,281 Views

this is not a model specific problem, the 8265 that i had in this laptop before (also not OEM) used to work perfectly for 2+ years on both linux and windows, then the problem started just recently so i bought a 9260 but the problem remained. i've reinstalled windows and i've troubleshooted this problem to no end but something changed recently in both linux and windows drivers thats causing this regdom issue and it's not just me having the issue, especially on linux where people tend to be more technically involved with how things work which is how i knew to play with module parameters in the first place.

 

with `lar_disable=Y` in linux i get full speed 5ghz ac and dual 80mhz connection, without it i can only use 5ghz if i set the channel width to 20 on the router, otherwise it cant even see 5ghz access points. so it's not a problem solved with a "call the manufacturer" statement.

 

 

AlHill
Super User
1,281 Views

You still need to contact dell.

 

Doc

 

1,281 Views

the 8265 which i still have and just tested again earlier today is whitelisted, i checked this before i purchased it a while back. up until recently that 8265 functioned fine in this laptop as it has since i got it but when the regdom issue started and nothing i could find would fix it on windows, i purchased a 9260 which also works but still has the same problem the approved 8265 began having in the past couple months. calling dell would be useless in this matter, contacting intel however im hoping an educated response of how to disable LAR (Location Aware Regulatory) on windows as i have done it on linux which makes both the 8265 and the 9260 perform perfectly.

 

LAR and DRS both sound like the very same thing, just worded differently.

https://blogs.intel.com/technology/2015/01/intel-drs-wi-fi-trouble-international-travelers/#gs.gqcku...

1,281 Views

as another point of reference, heres the difference between regulatory domain info when using `lar_disable=Y` and when not using it.

 

#this is with lar_disable=Y or lar_disable=1 (same thing) #everything works perfectly   ~ >>> iw reg get [234] global country US: DFS-FCC (2402 - 2472 @ 40), (N/A, 30), (N/A) (5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS (5735 - 5835 @ 80), (N/A, 30), (N/A) (57240 - 71000 @ 2160), (N/A, 40), (N/A)   #this is without lar_disable=Y and i cant use anything other than #20 for channel width which results in no 5ghz ac ability and terrible speed ~ >>> iw reg get global country US: DFS-FCC (2402 - 2472 @ 40), (N/A, 30), (N/A) (5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS (5735 - 5835 @ 80), (N/A, 30), (N/A) (57240 - 71000 @ 2160), (N/A, 40), (N/A)   phy#0 (self-managed) country ID: DFS-UNSET (2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ (2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ (2447 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ (5735 - 5815 @ 20), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ

Location Aware Regulatory feature of the intel wireless drivers are disabling the channels, all except for 20mhz which is very slow

AndrewG_Intel
Moderator
1,281 Views

Hello User15740198994512119537,

 

Thank you for posting on the Intel® communities.

 

We understand that you have integrated the Intel® Wireless-AC 9260 into your DELL™ laptop. In those scenarios, the information and link provided by Al.Hill is correct about contacting the Original Equipment Manufacturer (OEM, laptop manufacturer) for support with Intel Wireless Adapter upgrades.

 

Laptop manufacturers must meet regulatory requirements to determine if you can install the Intel Wireless Adapter in your system. Also, your computer manufacturer can customize drivers and software to enable or alter features, or provide improved operation on your computer. We kindly recommend you to contact your laptop manufacturer for more accurate assistance: DELL™ Contact Information*

 

Regarding your concerns, you may also check the Regulatory Information Regarding Wireless Hardware Installation or Upgrade for information and details on why disabling Location Aware Regulatory (LAR) is not allowed. Intel® Wireless Adapters is subject to country-specific legal regulations. The Intel® Wireless Adapter that is installed in your system and was sold on the market doesn't necessarily mean that it can be used or installed in any system.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

 

*Links to third-party sites and references to third-party trademarks are provided for convenience and illustrative purposes only. Unless explicitly stated, Intel® is not responsible for the contents of such links, and no third party endorsement of Intel® or any of its products is implied.

1,281 Views

i would understand contacting dell if the network adapter was the original or even if the previous adapter was not whitelisted but it is. if users only stick with what comes installed then hardware quickly becomes obsolete. i could also understand if i was using a laptop with a restrictive whitelist in which i installed a modded bios to accommodate the upgrade but its not.

 

this problem is getting more and more recognized by intel wireless owners and just a few weeks ago this problem didnt exist and intel drivers were rock solid on linux and on windows but something changed and i spent a great deal of time troubleshooting with others on linux that had a constant issue with dropping wifi connections and not being able to see anything other than 20mhz channels in 5ghz wireless ac access points.

 

if im able to mitigate this problem on linux by disabling LAR by using a module option that intel itself included in the firmware then it stands to reason there would be a way to do this in windows as well. i can barely stomach using windows as it is but it's a necessary nuisance i have to deal with and i would greatly appreciate if intel could assist me with a product i purchased.

 

how can i disable Location Aware Regulatory for the windows 10 64-bit intel wireless drivers? or at least force the adapter to stop detecting the incorrect regdom info?

1,281 Views

in addition to my previous reply, and in response to your statement that it's not possible to disable LAR, why would your linux drivers come with the included module option to disable it?

 

~ >>> modinfo iwlwifi -p debug:debug output mask (uint) swcrypto:using crypto in software (default 0 [hardware]) (int) 11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint) amsdu_size:amsdu size 0: 12K for multi Rx queue devices, 2K for 22560 devices, 4K for other devices 1:4K 2:8K 3:12K 4: 2K (default 0) (int) fw_restart:restart firmware in case of error (default true) (bool) antenna_coupling:specify antenna coupling in dB (default: 0 dB) (int) nvm_file:NVM file name (charp) d0i3_disable:disable d0i3 functionality (default: Y) (bool) -------- lar_disable:disable LAR functionality (default: N) (bool) -------- uapsd_disable:disable U-APSD functionality bitmap 1: BSS 2: P2P Client (default: 3) (uint) enable_ini:Enable debug INI TLV FW debug infrastructure (default: 0 (bool) bt_coex_active:enable wifi/bt co-exist (default: enable) (bool) led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int) power_save:enable WiFi power management (default: disable) (bool) power_level:default power save level (range from 1 - 5, default: 1) (int) fw_monitor:firmware monitor - to debug FW (default: false - needs lots of memory) (bool) d0i3_timeout:Timeout to D0i3 entry when idle (ms) (uint) disable_11ac:Disable VHT capabilities (default: false) (bool) remove_when_gone:Remove dev from PCIe bus if it is deemed inaccessible (default: false) (bool) disable_11ax:Disable HE capabilities (default: false) (bool)

also this is not an issue where regulatory emission limits are responsible for the driver failure, as i've posted earlier it's the intel wireless adapter that's "self managing" and it's not detecting the proper regdom or rather setting 2 of them which cancel each other out. im only asking for support of an intel product i purchased which is one of many and my go to brand when it comes to wireless adapters and the only ones i suggest to others but to be honest if this is something seen as "not intels problem" then consider me less than impressed.

 

im simply asking for direction as to where i as the end user can make a change to correct the behavior, im not asking intel to provide me with executable fix all.

 

answers to any of these would be better than "it's not our problem" response.

how to apply module options and/or which are available on the windows drivers?

is the regdom set in a windows registry key?

driver configuration file?

 

keep in mind, this is only a recent issue and the adapter i had in this very same laptop previously worked just fine for the longest time until this problem suddenly came to be and which is why i even purchased the 9260 in the first place. the bios version is the same but the intel drivers are not. thanks for your time, i look forward to your response.

AndrewG_Intel
Moderator
1,281 Views

Hello User15740198994512119537,

 

Thank you for your response. In order to understand better the behavior, could you please confirm the following details?

 

1- When exactly did the issue start to happen? (1 month? 3 months? etc.). We understand that Intel® Wireless-AC 8265 used to work fine before. Did the Intel® Wireless AC 9260 work fine at some point in time before?

 

2- Did the issue started after installing a particular driver version? If yes, please provide details.

 

3- Have you tried to roll back the driver or a Clean Installation of Wireless Drivers.

You can download the latest driver from your system manufacturer (if available) or from https://downloadcenter.intel.com/

 

4- Were you able to connect successfully to the 5GHz band before the wireless integration?

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

1,281 Views

thanks for your reply, answered in order

 

  1. i dont have an exact date, about 4-6 weeks ago right around the time i did the last major windows update. the 8265 worked fine for a long time until this problem came to be and after many hours troubleshooting the 8265 is when i purchased the 9260 which then also had the same behavior. until this issue began roughly 4-6 weeks ago both linux and windows had perfect 5ghz ac wireless performance.
  2. not that i noticed, i've also tried every version i could get my hands on to see if they behave differently but none of them had any possible effect.
  3. each version of drivers i installed was directly after removing the currently installed device drivers as explained in the "Clean install" page you linked. in addition, even with the 8265 i always used the intel drivers installed via the intel driver utility, same for 9260, but i have also tried the manufacturer supplied drivers but no difference.
  4. yes, 5ghz wireless ac worked perfectly and was able to use all the FCC regdom channels and band widths with the 8265 as explained in #1 until one day it didnt.

 

additional things i've done trying to troubleshoot this issue in regards to windows (i have linux working perfectly)

 

  • formatted the windows drive and did a clean windows 10 pro installation and purchased a new w10 pro key, made sure everything was regionally correct with the reasoning that maybe something in windows may of been causing the problem as it likes to do. no change.
  • made sure fast boot was disabled from windows and bios
  • tried the last 3 bios updates, no change.
  • tried finding ways of even displaying what regdom is actually being detected while on windows but for the life of me can not find anything, and so im also unable to try and fix what i cant find.
  • if i dont use the lar_disable=Y module option on linux, the behavior is identical to windows. same channels and widths are unable to be seen.

 

i understand your previous concern regarding legality of disabling LAR but disabling it as i do in linux using a module option thats built into the intel supplied driver does not force a regulatory domain, it just allows it to use the correct one without any further actions. i only disable LAR and everything works as it used to, i do not need to manually set a regulatory domain since the correct "US: DFS-FCC" regdom is used as it should be. if i were to try and force a regulatory domain other than my own then yes that would be illegal but i have no use for a different regdom and i dont travel outside the usa.

 

thanks again for your time, it's appreciated.

AndrewG_Intel
Moderator
1,281 Views

Hello User15740198994512119537,

 

Thank you for the answers provided and the additional details.

Please allow us to look into this behavior and as soon as we have more details we will be posting back in this thread.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

1,281 Views

thank you.

AndrewG_Intel
Moderator
1,281 Views

Hello User15740198994512119537,

 

Thank you for your patience in this matter.

 

We noticed that the Wireless Adapter works under Linux after some commands you run in the operating system, this indicates that there isn't a hardware issue.

 

Regarding your inquiry on how to disable Location Aware Regulatory in Windows, we would like to inform you that this is not possible in Windows® due to the Regulatory Information Regarding Wireless Hardware.

 

The Intel® Wireless adapter under Windows® is going to work based on the country settings detected based on the Regulatory Information and this is the expected behavior to comply with the country-specific legal regulations.

 

For details (if available) on how to disable Location Aware Regulatory in Windows or related Windows® Registry Keys, we recommend you to check with the operating system manufacturer.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

FK000
Novice
1,281 Views